PDC not showing in browse list

Discussion in 'Server Networking' started by Apple Eater, Jul 21, 2007.

  1. Apple Eater

    Apple Eater Guest

    First off, I am not sure if this behavior is by design or not, but it is
    something I need to deal with. I am the admin for a rather simple network
    with 4 Win 2k3 servers and 30+ XP clients. I have the aptly named Server01
    set as the PDC (also the Master Browser, obviously) in addition to Server02
    as the BDC. On Server04, I am running Veritas BackupExec, which can only
    backup computers listed in the Network Browse List (The "Entire Network"
    thingy in network places). All the servers show up correctly except for the
    PDC and Master Browser, Server01. I am having no problems other than this,
    and I have been led to believe this behavior is by design, but I need to
    somehow add Server01 to the browser list so I can back it up. Thanks in
    advance for any assistance!
     
    Apple Eater, Jul 21, 2007
    #1
    1. Advertisements

  2. Apple Eater

    Apple Eater Guest

    Here is the output of browstat status

    Status for domain DOMAINNAME on transport \Device\NetBT_Tcpip_{9BFD56D3-F98
    D-4BDB-BF4E-86C67ACCEEB9}
    Browsing is active on domain.
    Master browser name is: SERVER01
    Master browser is running build 3790
    1 backup servers retrieved from master SERVER01
    \\SERVER01
    There are 25 servers in domain DOMAINNAME on transport \Device\NetBT_Tc
    pip_{9BFD56D3-F98D-4BDB-BF4E-86C67ACCEEB9}
    There are 2 domains in domain DOMAINNAME on transport \Device\NetBT_Tcp
    ip_{9BFD56D3-F98D-4BDB-BF4E-86C67ACCEEB9}

    I didn't see anything fishy, but I coulud be misinterpreting something.
    Domain name removed for confidentiality.
     
    Apple Eater, Jul 21, 2007
    #2
    1. Advertisements

  3. Are you running WINS? Make sure everyone's registered in it (has the WINS
    server IP in its ipconfig). If you use DHCP for your workstations, add both
    the WINS server IP and node type (0x8, hybrid) to your DHCP scope options.
     
    Lanwench [MVP - Exchange], Jul 21, 2007
    #3
  4. Apple Eater

    Apple Eater Guest

    Yes, our network is running a WINS server, also housed on Server01. All the
    servers have static IPs which list the WINS server, and it is in the scope
    options as well. We have no name resolution problems, either with DNS or
    NetBIOS names. Also, all computers are listed in the browser from any
    computer, but Server01 is conspicuously absent from the list on EVERY
    machine, including the server itself.
     
    Apple Eater, Jul 21, 2007
    #4
  5. Hello,
    the servers address is also located in the WINS entry of the servers network
    card TCP/IP properties so that he can register himself? In the ancient NT
    age it was the case, that a WINS server had to have his own address here as
    primary and secondary WINS server.
    Enable NetBios over TCP/IP is selected on the WINS tab of the server?

    Check also, if on the server is by mistake the following registry key set:
    Hive: HKEY_LOCAL_MACHINE
    Key: SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Name: Hidden
    Type: REG_DWORD
    Value: 1

    This would hide the server from network neighbourhood.

    Best greetings from Germany
    Olaf
     
    Olaf Engelke [MVP Windows Server], Jul 21, 2007
    #5
  6. Apple Eater

    Apple Eater Guest

    Thanks for your response! First, the server does have its own IP address in
    the WINS tab, and it has properly registered with the WINS server (I checked
    the WINS database and found a 00h and 20h record for Server01 with the
    correct IP address, which is all that is required to appear in Network
    Neighborhood, I think). And yes, NetBIOS over TCP/IP is set to "Enable".
    Also, I did not find that registry key, but would creating it and setting to
    0 possibly have a positive effect?
     
    Apple Eater, Jul 21, 2007
    #6
  7. Apple Eater

    Apple Eater Guest

    Today I upgraded all the servers to Service Pack 2 with all the latest
    updates, and the error was NOT resolved. Does anyone have any more ideas? The
    event logs show nothing of use and everything about DNS/WINS appears to be
    operating correctly. Anyone? Please?
     
    Apple Eater, Jul 23, 2007
    #7
  8. Coraleigh Miller, Jul 23, 2007
    #8
  9. Apple Eater

    Apple Eater Guest

    Thanks for your reponse. Firstly, all our servers have 2 NICs, but each
    server has only one enabled. After viewing one of the articles you posted, I
    queried Server01, and found that it did NOT have Server01 in its list of
    computers using the following command:

    browstat view \device\netbt_ieepro1 \\server01

    I tried using some of the other commands to force Server01 to announce... to
    itself... but to no avail. Server01 is still not being listed in its own
    browser list, which is obviously a problem since it happens to be the Master
    Browser. Perhaps assigning a Backup Master Browser would alleviate the
    problem, since Server01 would perhaps announce to it? However, I am
    unfamiliar with the procedure for either designating a backup browser or any
    method of encouraging their election (assuming they are elected?). Could
    anyone shed some light on the subject, or perhaps suggest more
    troubleshooting I could attempt...

    Also, a side note that may or may not be related: When viewing "Entire
    Network" from the server in question, Server01, I am ONLY presented with one
    option, the Microsoft Windows Network, instead of the usual three. I know
    this seems insignificant, but it is the only significant different I can find
    in the network configurations of the servers.
     
    Apple Eater, Jul 23, 2007
    #9
  10. Apple Eater

    Apple Eater Guest

    Well, I finally realized the problem! I just realized the subnet mask was set
    incorrectly on Server01. Talk about being frustrating! It was set to
    255.255.254.0 which does not represent our actual subnet of 255.255.255.0 .
    This means all the Host announcements, which were being sent to an invalid
    broadcast address, were simply "lost in space" instead of being added to the
    browser lists across the network. Thanks to all you guys for your help,
    you've been great!
     
    Apple Eater, Jul 23, 2007
    #10
  11. This may seem pointless (since your 2nd nic is disabled) but try it
    anyway... :)

    On your master browser server within your Network Connections window go to
    your Advanced tab and open up Advanced Settings. Under Connections make
    sure that your active nic is above your disabled nic in the list, also in
    the Bindings window remove the checkmarks in your disabled nics bindings
    (select the diabled nic to access these).

    Coraleigh
     
    Coraleigh Miller, Jul 23, 2007
    #11
  12. Thats wonderful! Ignore my last post then. :)

    Coraleigh
     
    Coraleigh Miller, Jul 23, 2007
    #12
  13. Hello,
    what such a little digit can do for hassles ;-)
    Grats for finding it finally.
    Best greetings from Germany
    Olaf
     
    Olaf Engelke [MVP Windows Server], Jul 23, 2007
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.