permit desired applications to run correctly

Discussion in 'Windows Vista Security' started by John DeStefano, Mar 26, 2007.

  1. There are several "third-party" applications that I'd like to run on
    my Vista Home Premium machine, and that are being crippled on varying
    levels.

    I've tried disabling the User Access Center to see whether that has an
    effect, but it only stops "Cancel/Allow" dialogs from being displayed
    when I try to run them. Instead, the applications either return
    access errors, or nothing at all as they just don't get run. I've
    also tried right-clicking a file associated with an application (as
    well as the application itself) and choosing "Run as Administrator,"
    and assigning the "Run as Administrator" privilege to the application
    binary. All have similar results.

    Three good examples of apps that aren't behaving properly are the
    WinRAR archiving program, the QuickPAR archive recovery manager, and
    the testdisk partition management application. I assume the problem
    is that these apps don't have their drivers signed by Microsoft.

    is there an access list of some way to let Vista know that I trust
    these applications?
     
    John DeStefano, Mar 26, 2007
    #1
    1. Advertisements

  2. John DeStefano

    Kerry Brown Guest


    The problem probably isn't signed drivers but more likely the programs are
    trying to right to the system area of the registry or file system. Have you
    tried the program compatibility wizard? In Help and Support search for
    compatibility wizard. You probably won't be able to eliminate the UAC prompt
    on startup but you may be able to get the programs to work.
     
    Kerry Brown, Mar 26, 2007
    #2
    1. Advertisements

  3. John DeStefano

    Kerry Brown Guest

    LOL - that should be write not right.
     
    Kerry Brown, Mar 26, 2007
    #3
  4. That's definitely true in the case of testdisk: I was trying to
    recover a deleted partition table entry, and Vista would let me run
    the program and go through all the motions, but it wouldn't let the
    application write to the table to fix the problem.

    With the other two (WinRAR and QuickPAR), it doesn't seem to matter
    where they run: I tried moving the files they were working on in a
    different partition on a separate drive, and their operations would
    still fail.

    Thanks for the pointer toward Program Compatibility Wizard. Since
    these apps have no trouble running under XP, I'll give the wizard a go
    and see whether it helps.
     
    John DeStefano, Mar 26, 2007
    #4
  5. So, I ran through the prodcedure here:
    http://support.riverdeep.net/techtips_detail.asp?id=164

    Had no trouble following, until this step:
    "Choose the desired display settings and click Next to continue.
    Administrator privilege options will display."

    When I click Next, the only option on the screen is "Run this program
    as Administrator", and it's greyed out so I can't select it. I have a
    feeling that this setting would be necessary... why am I seeing
    something different here, and why isn't the option available to me?
     
    John DeStefano, Mar 27, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.