PIO mode after ATAPI errors

Discussion in 'Windows Vista Drivers' started by Thomas Johansen, Dec 22, 2004.

  1. Hi

    When there is some sort of disk error in WindowsXP, the data transfer to the
    IDE disk is set back to PIO mode.
    The only way of doing a reset of this, is to remove Primary IDE controller
    from the device manager (The only metode I know)
    After the PnP has installed the IDE controller, the disk is back in UDMA
    mode.

    So, is there any other way of remove the use of PIO mode ??

    Is it possible, somewhere in registry, to tell WIndows not to switch to PIO
    mode on IDE problems ??

    Thomas
     
    Thomas Johansen, Dec 22, 2004
    #1
    1. Advertisements

  2. Thomas Johansen

    Mark Roddy Guest

    If I recall correctly the registry is where this state information is
    lodged. Figure out what is getting set where and clobber it back to what
    it ought to be.

    Here, this person has done all the work for you:
    http://www.michna.com/kb/WxDMA.htm

    On the other hand, what has gone wrong with your disk?

    --

    =====================
    Mark Roddy DDK MVP
    Windows 2003/XP/2000 Consulting
    Hollis Technology Solutions 603-321-1032
     
    Mark Roddy, Dec 22, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.