"Play all" in Common Tasks (Music Tasks) in folders does not work

Discussion in 'Windows Media Player' started by JJ, Mar 1, 2007.

  1. JJ

    JJ Guest

    I posted this in an XP discussion thread and was advised to post here since
    the problem relates to WMP.
    ----------------------------------
    noticed a previous 3 yr old thread relating to the same problem but
    it didnt allow me to add to the thread which presumably is closed now

    http://groups.google.co.uk/group/mi...ee5bbb5da1/ae3fed05638b340e#ae3fed05638b340e#


    i have exactly the same problem as Ratan had, in that the play all
    function does not work. I have tried everything set out here in the
    above hyperlinked thread, culminating in applying the 2 fixes from
    lines 2 & 327 in Kelly's fixes table. This has restored the play
    function but now when i click the play all, it rapidly goes through
    all the files in the folder from start to end, i can see it scrolling
    thru the track numbers, and titles in WMP, before finally settling to
    play just the last track in the folder. Does anyone have any ideas as
    to what could be causing this and how i get it working again so that
    when i click play all, it plays all the files in sequence and not just
    the last file in the folder?
    I have pm'd Kelly as well so not sure whether this is overkill
    creating a thread..but just in case anyone else is able to help in the
    meantime...

    Kind regards

    JJ
     
    JJ, Mar 1, 2007
    #1
    1. Advertisements

  2. JJ

    Dale Guest

    Creating a thread for a new problem is not overkill. It is much better than
    tagging on to an existing but old thread.

    It sounds to me like you may have a corrupt library. What happens if you
    double click to play a single track? Are you sure the tracks exist in the
    place where the library thinks they are? Can you right-click a song in your
    library and choose Open Containing Folder? Is it able to find the actual
    file?
     
    Dale, Mar 1, 2007
    #2
    1. Advertisements

  3. JJ

    JJ Guest

    Thanks for the reassurance and willingness to try and get me back up and
    running again.It is appreciated.
    Yes i can open a single file and it immediately opens with WMP and starts
    playing fine when i double click it.
    I can also right click and select open (i do not have to select Open With
    and then choose WMP) and WMP will automatically fire up and play the track no
    problem.
    It just appears that the play all function does not work anymore and i dont
    know what i have done for this to stop
    working. I've tried a system restore but no luck. Clicking on play all, it
    just scrolls thru every track in quick succession in WMP( i can actually see
    the tracks being counted up in the Now playing pane on the right hand side of
    WMP) before settling to play just the last track in the folder.

    If i highlight a number of tracks(for example 5 tracks) and then click PLay
    Selection, it also does the same thing. ie scrolls thru the 1st 4 of those
    selected tracks before playing just the 5th track in the group of tracks i
    originally selected.
    You mentioned a corrupt library..how do i recover from that?.. ive done a
    sfc /scannow but this didnt show up any issues...
    I'm stumped..any ideas?
     
    JJ, Mar 1, 2007
    #3
  4. JJ

    Dale Guest

    The behavior you are describing is almost what you'd see if you had deleted
    files for items that are still in your library. The library tries to play
    each one and, as it cannot find it, it moves on to the next. This can go
    pretty quickly on a fast system. The difference is, in my experience, WMP
    turns the text orange on the tracks it cannot find.

    So, it sounds close enough to me to think your library database is
    corrupted. You'll want to rename or delete the folder your library database
    is in. Renaming is safer - you can get back if something goes awry. After
    the problem is solved, you could always delete the renamed folder.

    The instructions at http://www.zachd.com/pss/pss.html#medialibrary should be
    of help.

    Dale
     
    Dale, Mar 2, 2007
    #4
  5. JJ

    JJ Guest

    Hi Dale
    Those instructions show me where my library database is, however when i
    check this at a command prompt, i get the following

    C:\Documents and Settings\*******\Local Settings\Application Data\Microsoft\
    Media Player\CurrentDatabase_219.wmdb
    C:\Documents and Settings\******\Local Settings\Application Data\Microsoft\
    Media Player\CurrentDatabase_59R.wmdb

    but when i go to this location in Explorer, neither of those .wmdb entries
    are showing up and i have in Folder view, show hidden files checked and the
    hide system files button is unchecked????
     
    JJ, Mar 2, 2007
    #5
  6. JJ

    JJ Guest

    its okay i located those .wmdb entries ( i was looking inthe wrong
    application data dir!)...however that has not resolved my problem. Problem
    remains as before. Dale u still there?
     
    JJ, Mar 3, 2007
    #6
  7. JJ

    Dale Guest

    Then something appears to be wrong with the files themselves. If you browse
    to the files in Windows Explorer and double-click, do they play properly?

    Do the tracks play properly in any other player? Are the tracks on your
    local hard drive, a portable/removable drive, or a network drive?

    Dale
     
    Dale, Mar 3, 2007
    #7
  8. JJ

    frodo Guest

    Play All not working is a longstanding issue, I have never seen a complete
    "cure" posted for it, ever, tho there are many suggestions. It just
    doesn't work for everyone like it should, just accept it and you'll feel
    better!

    One Tip tho: if you have the "Move To Folder..." and/or "Copy To
    Folder..." right-click context menu entries installed in Windows Explorer
    (an older powertoy), they _MAY_ be the root cause of the issue. They were
    never really meant to be context-menu items, and are already present as
    toolbar icons in XP's explorer.
     
    frodo, Mar 3, 2007
    #8
  9. JJ

    JJ Guest

    its okay problem now resolved, following Ramesh's advice here

    http://windowsxp.mvps.org/playall.htm

    i now seem to have windows explorer issues, but i'll raise a separate post
    for that in the relevant sub-section

    cheers
     
    JJ, Mar 6, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.