Please Clarify

Discussion in 'Active Directory' started by Nik, Oct 19, 2009.

  1. How long did you wait? What the replication schedule set to? 180 minutes
    (default)? You can force theKCC by right-clicking NTDS, All Task - Check
    Replication. But the replication schedule jumps into play. You can cut it
    down to 15 minutes, which is the lowest it will go because intrasite
    topology will replicate data between DCs within 15 minutes.

    It may also be due to your current network routing topology.

    What errors are in the event log?

    Ace
     
    Ace Fekay [MCT], Oct 20, 2009
    #21
    1. Advertisements

  2. Nik

    Nik Guest

    Guys,
    I did force the KCC. Also let me give you a quick snapshot of the current
    sites
    1. The Default IP Site - halal all the sites bundled - This is a problem for
    me rite away if Im going to move to a star topology. So I decided to remove
    one site from the list.
    2. I then created my site link for that site
    3. Deleted all AD connections from the test site and wherever it was being
    referenced by other sites
    4. Activate the KCC
    5. I got the connection eventually in the hub site but not in the remote
    site.
    The Default IP Site Link has a cost of 5 and replication time of 100

    Now I already created all the site links today, but give them a higher cost
    so that I can work on them tomorrow.

    Now tomorrow I intend to reduce the cost and replication time - 15 - and
    then increase the values on the default site link, delete ALL current
    connections - automatic or manual - Then Run the KCC again and see what
    happens

    Whats your opinion on that strategy.
    P.S. I ensured i backed up AD before I started making the chanes
     
    Nik, Oct 21, 2009
    #22
    1. Advertisements

  3. Nik

    Nik Guest

    Ace,
    I just logged in and did what is written below, im just waiting now
     
    Nik, Oct 21, 2009
    #23

  4. I think this is a change that should have been done on a weekend.

    Ace
     
    Ace Fekay [MCT], Oct 21, 2009
    #24

  5. I see you started another thread. I replied to it asking for some specifics
    to better evaluate what's going on.

    Ace
     
    Ace Fekay [MCT], Oct 21, 2009
    #25
  6. Nik

    Nik Guest

    Guys,
    I'm so sorry for wasting your time on that issue. I figured I choose the
    wrong site to start this process. After not being able to solve the problem,
    I decided to try another site. Those worked without any issues. As a result,
    I've already migrated 3 sites without any further issue. So I decided to run
    repadmin with a few more options against that server and I have concluded
    that along with the outputs I have received, it would be safe to say that
    the KCC knows nothing about that server since I keep geting it is beyond the
    tombstone period or something showing a date months ago or even never in
    some instances.
    So once again, thanks for the help sorry for wasting your time. I will
    migrate the other sites and when all is done then I demote this server and
    then promote it back to a DC in the domain.
    Thanks
     
    Nik, Oct 21, 2009
    #26
  7. No problem, NIk. We are here to help.

    As for the past the tombstone time on that specific DC, it may not demote
    properly. When demoting, run dcpromo /forceremoval, and delete its reference
    in Sites and Services. If it doesn't demote, you'll have to run a metadata
    cleanup on the AD database.

    Ace
     
    Ace Fekay [MCT], Oct 21, 2009
    #27
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.