Please help "The Windows Installer Service could not be accessed"

Discussion in 'Windows Vista General Discussion' started by XYZ1, Aug 31, 2007.

  1. XYZ1

    XYZ1 Guest

    Hi,
    I'm using Windows Vista x64 Home Premium (my system see below).

    I have problems with the Windows Installer.
    For example if I want to uninstall "Microsoft Visual C++ 2005
    Redistributable" I receive the following error message:
    "The Windows Installer Service could not be accessed. This can occur if the
    Windows Installer is not correctly installed. Contact your support personnel
    for assistance."

    I'm getting the same error if I try to install/un-install other programs as
    well.


    How can I fix this error?



    Thank you in advance!

    --------------------------------------------------------------------------------------
    Gigabyte 965P-DS3P, Intel Core2Duo 6420, BFG GeForce 8800GTS, MDT 2GB DDR2
    800, Scythe Infinity + Socket 478 Retention Modul + Cool Laboratory Liquid
    MetalPad, 2x Samsung Spinpoint 2504C SATAII 250GB, Samsung Spinpoint HD321KJ
    SATAII 320GB, LG GSA-4167, Chieftec Mesh, Thermaltake Purepower 460W, 120mm
    Coolermate Fan ALF-12S, 2x 92mm Coolermate Fan ALF-9A, HP W2207, Windows
    Vista Home Premium 64Bit
     
    XYZ1, Aug 31, 2007
    #1
    1. Advertisements

  2. XYZ1

    XYZ1 Guest

    XYZ1, Aug 31, 2007
    #2
    1. Advertisements

  3. XYZ1

    XYZ1 Guest

    Hi,
    in the meantime I tried "Method 1: Re-register the Windows Installer" from
    this support link:
    http://support.microsoft.com/kb/315346/EN-US/
    -> It's not working

    Therefore I tried "Method 2: Reinstall the Windows Installer" from the above
    support link:
    I identified that the files msi.dll, msiexec.exe and msihnd.dll given in
    Step 4. are in the folder "C:\WINDOWS\SYSTEM32" and not as described as there
    (I'm using Vista.)
    My problem is I can't rename those files, I always receive the message
    "Access is denied" (in the command prompt) or "You need permission to perform
    this action" (in the Explorer). How can I rename those files? If I know this
    I can try if "Method 2: Reinstall the Windows Installer" works.
     
    XYZ1, Aug 31, 2007
    #3
  4. XYZ1

    Chad Harris Guest

    Hi XYZ1--

    Get permission. Right click the System 32 folder by typing
    C:\Windows\System32 in your IE address bar.


    Right click the system 32 folder>properties>security tab>add/or edit>type
    "users" (no quotes) in the object box>check all the permission boxes>close.
    You may want to grant the permission temporarily to fix your MSI (Windows
    Installer). Or you could go to msconfig>tools tab> and turn the pesty UAC
    off **temoprarily to get your job done.

    Good luck,

    CH
     
    Chad Harris, Aug 31, 2007
    #4
  5. XYZ1

    XYZ1 Guest

    Hi,
    I right clicked on the folder "System32" - "Properties".
    In the "Group or user names" box I highlighted "Users" and checked all boxes
    on "Allow".
    -> I receive the error message "Access is denied"

    I also tried the second thing you mentioned:
    Start - Run typed in "msconfig" and went to the "Tools" tab.
    There I can see two entries:
    - "Disable UAC"
    - "Enable UAC"
    -> What exactly should I do now?
     
    XYZ1, Aug 31, 2007
    #5
  6. XYZ1

    Chad Harris Guest

    Hi--

    Either right click the folder (as I also said)>permissions>add> TYPE USERS
    IN THE OBJECT BOX) then put checks in all the permission boxes for users and
    if no joy there then do this:

    ***SFC as a Remedy***:

    SFC or System File Checker is a bit like the spare tire in your car or a
    backup battery I suppose. In Vista of course, they have changed it somewhat
    and come up with a new name--Redmond stands for name it something different
    twice a year and now it's part of WRP or Windows Resource Protection. It
    scans protected resources including thousands of files, libraries, critical
    folders, and essential registry keys, and it replaces those that are
    corrupted with intact ones. It fixes a lot of problems in Windows XP, OE,
    Windows Vista, Win Mail, IE6, and on Vista or if it is installed on XP, IE7.
    It protects these things from changes by any source including
    administrators, by keeping a spare of most of them.

    How to Run SFC:

    Type "cmd" into the Search box above the Start Button>and when cmd comes up
    at the top of the Start menu>right click cmd and click "run as Admin" and
    when the cmd prompt comes up at the cmd prompt type "sfc /scannow" no quotes
    and let it run. This may fix things quite a bit. It replaces corrupt files
    with intact ones, if you're not familiar with it.

    ***Startup Repair from the Vista DVD***

    How to Use The Vista DVD to Repair Vista (Startup Repair is misnamed by the
    Win RE team and it can be used to fix many Vista components even when you
    ***can boot to Vista):

    http://www.windowsvista.windowsreinstall.com/vistaultimate/repairstartup/index.htm

    If you elect to run Startup repair from the Vista DVD (it can fix major
    components in Vista--I've verified this many many times; it's good for more
    than startup problems, and the Win RE team simply screwed up when they named
    it not understanding its full functionality):

    Startup Repair will look like this when you put in the Vista DVD:

    http://www.vistaclues.com/wp-content/uploads/2006/12/click-repair-your-computer.png

    You run the startup repair tool this way (and system restore from here is
    also sometimes effective):

    http://support.microsoft.com/kb/925810/en-us

    How To Run Startup Repair In Vista Ultimate (Multiple Screenshots)
    http://www.windowsvista.windowsreinstall.com/vistaultimate/repairstartup/index.htm

    It will automatically take you to this on your screen:

    http://www.vistaclues.com/wp-content/uploads/2006/12/click-repair-your-computer.png

    That will allow you to go to the Vista setup that has a Repair link on
    thelower left corner>click it and then you'll see a gray backgrounded list
    and I want you to click Startup Repair from it and follow the directions.

    The gray screen after you click the first link in the above pic will look
    like this:

    http://www.windowsreinstall.com/winvista/images/repair/staruprepair/Image17.gif

    Click Startup Repair, the link at the top and after it scans>click OK and
    let it try to repair Vista. It will tell you if it does, and if it
    doesn't, try System Restore from the Recovery Link on the DVD. If these
    don't work booting into Safe Mode by tapping the F8 key and using System
    Restore from one of the safe modes besides VGA may work. That means you
    have the option to try 4 different safe modes to get to system restore, (one
    from the Recovery link on the DVD) and sometimes one will work when the
    others won't.


    You could also try a Repair Install with Vista which is done exactly the
    same way as in XP:

    ***Repair Install Steps*** (can be used for Vista) MVP Doug Knox
    http://www.microsoft.com/windowsxp/using/helpandsupport/learnmore/tips/doug92.mspx


    ***Using the F8 Environment***

    ***Taking Full Advantage of the F8 Options (Windows Advanced Options Menu)
    by starting the PC and tapping F8 once per second when the firmware screen
    with the pc manufacturer's name shows a few seconds after restarting***:

    The F8 options in Vista are the same as XP, and the link for Safe Mode Boot
    options is labled XP by MSFT but they are the same for Vista (they haven't
    updated to add Vista to the title as they have with several MSKBs that apply
    to both).

    Again, pressing F8 repeatedly when you seem the firmware screen may be is a
    generic way to launch Windows RE on some OEM Vista computers.

    You could also:

    Think: I have 4 different ways to get back my XP at F8 and try 'em in order.
    1) Safe Mode 2) Safe Mode with Cmd to Sys Restore which is simply a cmd
    prompt in safe mode 3) Safe Mode with Neworking 4) LKG or Last Known Good
    Configuration


    Try to F8 to the Windows Adv Options Menu>try 3 safe modes there (I don't
    use WGA) and Last Known Good>then I go to Win RE in Vista. That gives you a
    choice of Safe Mode, Safe Mode with Networking,and Safe Mode with Command
    Prompt.

    These methods are outlined in

    A description of the Safe Mode Boot options in Windows XP/and Vista
    http://support.microsoft.com/kb/315222/

    Frequently Asked Questions Regarding System Restore from MSFT:

    http://www.microsoft.com/technet/prodtechnol/winxppro/plan/faqsrwxp.mspx

    System Restore can be run from the Win RE recovery environment from the same
    link as Startup Repair, and sometimes it will work from one F8 safe mode
    location or from the Win Recovery Environment when it won't work from other
    locations.

    How to start the System Restore tool at a command prompt in Windows XP

    http://support.microsoft.com/default.aspx?scid=kb;en-us;304449

    Good luck,

    CH
     
    Chad Harris, Sep 1, 2007
    #6
  7. XYZ1

    XYZ1 Guest

    Hi,
    first of all thanks for your help.

    I already tried what you said:
    I can already see "USERS" in the object box and allowed everything (except
    "Special permissions" which can't be ticket). Then I click on "Apply" and
    receive the error message "Access is denied."
    The same happens if I try it with "ADMINISTRATORS".

    Seems like it's not possible to change anything in the "System32" folder. I
    hate this, how can I de-activate this whole bullsh*t, I'm the owner of my
    computer and therefore want full control!
    Is there no way to run everything as an administrator and have the
    possibility to delete or rename all the files you want?


    I also tried this:
    I searched for "cmd" but can't find it. Therefore can't run it as an
    administrator.
     
    XYZ1, Sep 1, 2007
    #7
  8. XYZ1

    McClairey Guest

    I also have been having the same problem.

    I tried the cmd method, but that didn't work. I was able to log on as
    administrator, but the thing didn't work anyway.

    Claire
     
    McClairey, Nov 7, 2007
    #8
  9. XYZ1

    XZ3R0 Guest

    the repair method does not work on vista, because vista uses windows
    installer 4.0 and it is not for download. The repair method only works
    for older versions you can download. I think they give you instructions
    on how to get full control over the files using command prompt commands,
    if not theres another kb that does.

    I am running vista and get the following error too, "the windows
    installer service could not be accessed. this can occur if the windows
    installer is not correctly installed. contact your support personnel for
    assistance." when trying to install certain programs, but not all of
    them. I have treid all the suggestions i could find on microsofts kb.
    Along with, checking that the service is running and is set to manual
    and is started, trying to install in safe mode, trying to do a clean
    boot with needed services, cleaning my registry, sfc scan, and quite a
    few other things.
     
    XZ3R0, May 11, 2008
    #9
  10. XYZ1

    DigiLA Guest

    I had the same problem with the Windows Installer, both in Vista & Win7
    x64's. After 5 hours of searching and trying just about every solution,
    I was about ready to give up. Then I stumbled upon this thread and
    Leokev's advice. Since I knew it was a 64 bit installer issue, changing
    the WOW64 setting made sense and worth my last try at the problem. IT
    WORKED!! Thank you, Leokev! Thank you, thank you, thank you!!
     
    DigiLA, Sep 24, 2009
    #10
  11. XYZ1

    Phil88 Guest

    Hello

    I have the same problem but with vista 32-bit version
    So WOW64 doesn't exist in 32-bit version,
    How could I repair the installer

    Thank's in advance

    Phil
     
    Phil88, Dec 28, 2009
    #11
  12. XYZ1

    Tim Slattery Guest

    Not sure I understand what you're asking. You cannot run 64-bit
    software on a 32-bit OS.
     
    Tim Slattery, Dec 28, 2009
    #12
  13. XYZ1

    Phil88 Guest

    hi

    No, I have the problem that I can not install msu or msi programs
    I receive the error : 'the windows installer service could not b
    accessed...

    So I read in this article that it was solved for vista 64-bit version

    And I have a 32-bit version

    I hope someone can help solving this BIG problem

    Thank's

    Phil
     
    Phil88, Dec 28, 2009
    #13
  14. XYZ1

    RondaB1963 Guest

    Need more help --I've been having the Windows installer problem for a
    couple weeks and thought this sounded great. Then I edited the registry
    as Leokev says and can't find the WOW64 entry. The entried have names
    like 'DependOnService', 'Description', 'ObjectName', 'ImagePath',
    'ErrorControl'. Not a WOW64 in the bunch, does it have a different
    name??? Thanks
     
    RondaB1963, Jan 14, 2010
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.