Plrase Help after java install, no java option in IE

Discussion in 'Internet Explorer' started by jules, Nov 17, 2008.

  1. jules

    jules Guest

    Hi,
    i had some worries with IE7, under vista home premium( french all updates)
    No way to get the "java" option appearing'between "International" and
    "microsoft vm", in
    Ie7 /tools/internet options/advanced

    I installed java 1.6.10 (offline)
    as the online said
    "Java for Windows - Internet Explorer
    Recommended Version 6 Update 10 (filesize: ~ 7 MB)
    Windows Vista, XP, 2000, 2003 Server
    We encountered an issue while trying to automatically install Java software
    onto your machine.
    If you encounter an error, try the following options:
    ..Check the top of the browser for an information bar that may read 'This
    site might require the following ActiveX control: Java SE Runtime
    Environment 6 Update 10 from Sun Microsystems, Inc.. Click here to install.'
    Click the colored bar and choose Install ActiveX Control to allow
    installation to proceed "


    I uninstalled all previous jre install/updates, deleted all jre related
    registry keys,
    ran a ccleaner, rebooted,
    I installed the jre 1.6.10(successfully), deleted the java cache files again
    in the Java cpl(
    general/internet temporary files)
    reinstalled ava 1.6.10 etc

    No way to have the java option, described above, appearing.
    I checked in Tools>Manage add-ons> if java addons werent not listed in the
    "Disabled" list.
    i checked spybot's teatimer/sdhelper isnt active
    i have not antivirus,
    windows vista firewall(i added all java relative exe, in the exception
    rules) to allow internet access,
    i dont have at the browser top, as quoted from Sun above, any information
    bar
    , when i go to java.com/fr/download

    i tried so, to install IE8, same worry and when i try to change the security
    levels
    in Ie8 /tools/internet options/security for example for 'internet zone" from
    medium to medium low
    i validate ben when i exit IE8 (top right red cross) , ie8 crashes. see
    below (3)

    Below find(1) a java log, (2)the exception log : ParseException:
    Unparseable date: ""
    Many thanks for any help or suggestion, in advance
    Best regards

    1)
    -- Start in LogInfo --
    COUNTRY is: FR
    COUNTRYOVERRIDE is: 0
    DEFAULTBROWSER HTTP\Shell\open\ddeexec\Application is: Firefox
    DEFAULTBROWSERVISTA2NDKEY
    Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice\Progid
    is: IE.HTTP
    -- Start in ShowOO --
    -- ShowOO -- Turning off OO
    -- Start in ShowYahoo --
    -- ShowYahoo -- rcode key is: 2
    -- ShowYahoo -- ytb key is: 0
    -- ShowYahoo -- intl key is: fr
    -- ShowYahoo -- Turning off Yahoo
    -- ShowYahoo -- Yahoo CCT failed for other reason, setting install stats key
    -- DetermineSponsor -- begin
    -- DetermineSponsor -- The following sponsors have already been offered:
    -- DetermineSponsor -- The preference order is: SP4;SP3
    -- DetermineSponsor -- The sponsors that are offerable are:
    -- DetermineSponsor -- szSponsorsOfferableNotAlreadyOffered is:
    -- DetermineSponsor -- NO sponsors found that have not already been offered
    -- DetermineSponsor -- walking through sponsors offerable to find a sponsor
    found that WAS already offered. szSponsorsOfferableSave is: ,
    szPreferenceOrderSave is: SP4;SP3
    -- DetermineSponsor -- NO sponsor found



    2)
    basic: unique id: JavaControlPanel
    basic: server port at: 51425
    basic: getSingleInstanceFilename:
    C:\Users\Bruce\AppData\LocalLow\Sun\Java\Deployment\tmp\si\JavaControlPanel-x86_51425
    basic: waiting connection
    got exception:java.text.ParseException: Unparseable date: ""
    basic: Running JVMParams: [JVMParameters: isSecure: true, args: ]
    -> [JVMParameters: isSecure: true, args: ]
    basic: recv: javaws.singleinstance.stop
    basic: getSingleInstanceFilename:
    C:\Users\Bruce\AppData\LocalLow\Sun\Java\Deployment\tmp\si\JavaControlPanel-x86_51425
    basic: getSingleInstanceFilename:
    C:\Users\Bruce\AppData\LocalLow\Sun\Java\Deployment\tmp\si\JavaControlPanel-x86_51425
    basic: removed SingleInstanceFile:
    C:\Users\Bruce\AppData\LocalLow\Sun\Java\Deployment\tmp\si\JavaControlPanel-x86_51425


    (3)
    Nom du journal :Application
    Source : Windows Error Reporting
    Date : 17/11/2008 19:13:02
    ID de l'événement :1001
    Catégorie de la tâche :Aucun
    Niveau : Information
    Mots clés : Classique
    Utilisateur : N/A
    Ordinateur : inv
    Description :
    Récipient d'erreurs 913402872, type 1
    Événement : APPCRASH
    Réponse : Aucun
    ID de CAB : 0

    Signature du problème :
    P1 : iexplore.exe
    P2 : 8.0.6001.18241
    P3 : 48ae8fee
    P4 : StackHash_f7e0
    P5 : 0.0.0.0
    P6 : 00000000
    P7 : c0000005
    P8 : 4e0d8b00
    P9 :
    P10 :
     
    jules, Nov 17, 2008
    #1
    1. Advertisements

  2. (cross-post added to Vista Perf & Maint)

    Try asking in a Vista NG. Cross-posted to one for convenience.
    I don't have Vista but suspect this could be one of its security/obscurity quirks.
    Have you tried doing the install as the Administrator?

    Also, if that StackHash crash report that you included is relevant
    I think it could be an indication of the presence of incompatible modules.
    Seeing the related Stack Back Trace could help check that idea.
    In fact, I thought that Java kept logs with such details somewhere.
    You could do a search of all files changed at the time of the crash
    to try to find that diagnostic and any others which the crash produces.
    Alternatively, Run... ProcMon and get a Stack Back Trace from it.


    Good luck

    Robert Aldwinckle
    ---

     
    Robert Aldwinckle, Nov 20, 2008
    #2
    1. Advertisements

  3. jules

    jules Guest

    Hi Robert,

    Good idea,
    i will give it a try
    It seems more tricky, i will test that when 'll more spare-time :)


    Thanks for your time and your (good) ideas
    Best regards
     
    jules, Nov 26, 2008
    #3
  4. jules

    jules Guest

    Hi again,
    I didnt find your cross post in
    microsoft.public.windows.vista.performance_maintenance

    but i found in "microsoft.public.internet.explorer.java"
    quite the same problem:

    Juan Kerr" <> a écrit dans le message de
    have a 2008 Vista (Home, SP1
    fully updated) laptop that refuses to
     
    jules, Nov 26, 2008
    #4
  5. (cross-post added to IE Java)
    Oops. ; )


    Thanks. I wasn't aware of that newsgroup.
    I still think you're more likely to find more knowledgeable
    help in a Vista NG but I was really cross-posting to get some
    help with your StackHash symptom. ; )

    But now that I have reviewed your original post
    and see a mention of Microsoft VM I'm wondering
    if you are confused about what you *should* be seeing
    anyway. E.g. it looks to me that, at least in XP, the only
    thing left in the Internet Options about Java is a checkbox

    Use JRE 1.5.0_02 for <applet> (requires restart)

    and I suspect that is redundant anyway, since it duplicates
    an option that is otherwise available in the Java
    Control Panel applet. E.g. Run... (press Win-R and enter:)

    control javacpl.cpl

    Then open the Advanced tab and expand the node
    Default Java for browsers

    Oh. Perhaps if there are no boxes checked in there
    the option would not appear in the Internet Options
    Advanced tab? I'll leave it to someone who is more
    interested in this scenario to do the necessary testing
    to confirm this idea... ; )

    One difference you may have in Vista, if I understand it
    correctly, is having to start that Control Panel applet
    using the Administrator, e.g. instead of being able to use
    the standard Run... dialog you might have to open the
    Control Panel itself, navigate to the Java applet, and then
    press Shift-RightClick to see a Run As... command to use
    with it. Etc.


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Nov 27, 2008
    #5
  6. jules

    jules Guest

    Hi Robert,

    As some java websites werent working and as the sun java
    i installed wasnt "selectable" in IE7 options(as it didnt show)
    i looked for the Msoft's old java virtual machine(not available anymore
    from them) and installed it (see the link below to screen capture)

    http://cjoint.com/?lDmlEm4Z8X

    Sun java is missing in IE7 options after install
    between "international" And "microsoft VM"/"multimedia"
    see both links below for the Java's advanced tab deployed:

    http://cjoint.com/?lDmpcdW0Sz
    nb: internet explorer is grayed out but checked

    http://cjoint.com/?lDmpEt4zss


    No way to run it as administratror, in the control panel under vista
    Many Thanks for your kind help
    Happy thanksgiving
    Regards
     
    jules, Nov 29, 2008
    #6

  7. But since nothing is checked there, what's the point? ; )

    Also, you don't show the Internet Options, Security tab's
    Custom Level settings. There are Java related options
    in that dialog and also IIRC a special supplementary dialog
    for customizing the use of the MS Java VM.

    That's odd. There is in XP. Are you pressing Shift-
    when you right-click on the icon for the Java CP applet?
    The command I'm referring to only shows when I press
    Shift- while right-clicking there.

    BTW if you don't get it working with those hints,
    what I would do is uninstall the old MSJava stuff
    and try to see if the Sun stuff will reinstall properly
    normally.


    That was last month for me. ; )


    Robert
    ---
     
    Robert Aldwinckle, Nov 30, 2008
    #7
  8. jules

    jules Guest

    The Microsoft VM has been checked/unchecked
    to make different tries with java install(so what you saw is a temporary
    state ;)

    for active x


    http://cjoint.com/?lEllc0nTxy
    http://cjoint.com/?lElmi82lc3
    http://cjoint.com/?lElmIOCUH5

    For java
    http://cjoint.com/?lElnhEcQkM

    http://cjoint.com/?lElnUl2s3q
    shift-right gives me only 2 options
    "open"/"create a short link"

    i'll will try that, i have to reboot ;-)
    i'll keep you advised
    Regards
     
    jules, Nov 30, 2008
    #8
  9. jules

    jules Guest

    Hi Robert,

    Finally with your bright help,
    i managed to get it work !

    i uninstall the microsoft VM
    following a Sun procedure found here(sorry in french must exist also in
    other languages
    owe to your regional settings on java.com)

    http://www.java.com/fr/download/help/uninstall_msvm.xml

    i uninstalled , also, before the rebooting the jre update10
    i deleted the windows java folder/the java files described above
    deleted the registry keys

    And then i went to java.com and i had been able
    to do an online installation and then the online sun's java
    version checking worked !
    Probably , from my xp to vista upgrade,
    the previous installations of both java/Microsoft VM
    let some bad settings/files.
    But i has been nearly two years ago(!) and never i had encountered
    any worries java related but since one month.
    I dont understand why my problem occured.
    perhaps last java version(update10) or some vista KB updates
    modified java "behavior".

    Two notices:
    One:
    java options in IE7/8 /advanced are still not there(so must be vista "rule",
    under xp were there)

    Two:
    in the java cpl/advanced tab the "java by default for internet browsers":
    Microsoft Internet explorer is grayed out and ticked

    i hope it will work now !

    Anyway many thanks again Robert, your patient advices brought me to the
    solution !
    (crossing fingers)
    Best regards
     
    jules, Nov 30, 2008
    #9
  10. jules

    Pam Guest

    Actually - I was just about to weigh in with this problem myself! I have the
    latest version of Java installed (11) and I have been unable to get past the
    splash screen that comes up - it always says "Splash: recv failed" and then
    the Java window hangs and fails to load. It is only when I try to enter a
    chat program called vereconference - someone also told me to uncheck the
    Java box in Tools in Internet Options - but like you - I found it wasn't
    there.

    I have not been able to get it to work with this program - although all
    other java applets work. I've also tried to uninstall Sun/Java - but my
    question is - is the Microsoft VM hidden somewhere? Is it not listed in the
    Advanced Section of the Internet Options tab?

    Pam
     
    Pam, Dec 3, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.