Porting physical drive issues.

Discussion in 'Virtual PC' started by Jack, Mar 8, 2008.

  1. Jack

    Jack Guest

    I am giving up.
    After 7 days of tweaking I have enough.
    I used Acronis True Image Echo Workstation with Acronis Universal Restore
    and I have tried these 2 methods:
    A.
    Create a physical drive image, convert it to virtual disk and mount it.
    B.
    Create a physical drive image and restore it directly inside VPC.

    Host: Windows XP PRO 3 MB RAM
    1.
    physical Windows XP:
    ------------------------
    method A never succeeded. ---> tried 5 times
    method B after hard trying:
    - booting Normal failed
    - booting Safe failed
    - booting Last working configuration ---> worked?????
    but virtual machine is not operative. Any Windows action (opening window)
    takes 5-7 minutes!!! and booting itself takes about 30 minutes until the
    last start-up app get loaded
    2.
    physical Vista
    --------------
    method A and method B both fail the same way.
    There is some hard drive activity at bootup and then bootup freezes.
    Using Safe mode the last loaded entry is:
    crcdisk.sys
    and booting stops.
    There is not boot log created, despite selecting "boot with logging" option.
    I used Vista DVD installation disk to repair it. It find few areas and
    repaired them but that did not help booting.

    Conclusion:
    ========
    Do not waste your time. It is not worth.

    If you have any experience porting XP or Vista physical drives and you
    succeeded and your vm are working normally I invite you to share your
    experience.
    Jack
     
    Jack, Mar 8, 2008
    #1
    1. Advertisements

  2. Jack

    Robert Comer Guest

    If you have any experience porting XP or Vista physical drives and you
    I've never tried restoring Vista into a VM, but I've done a physical
    XP box to VM more than once.

    Back up box with Acronis True Image
    Restore to a VM using True Image with Universal restore
    Boot into safe mode in VM the first time, reboot, install VM
    additions, reboot, done.
    That's basically what I did, but I copied the image to an existing VHD
    using another VM and restore from that.
    Install the VM Additions. How much RAM are you allocating to the VM?
     
    Robert Comer, Mar 8, 2008
    #2
    1. Advertisements

  3. Jack

    Jack Guest

    RAM allocated to guest 1.2 GB
    VM additions installed.
    XP non-operative.
    I wonder if the hardware installed on host can influence porting.
    I have a video capture PCI card and 2 modems installed on host.
    Robert, how did you do that:
    Please elaborate.
    What I did it was very labourous way.
    First installed WinXP from CD and created 2 partition during installation.
    Then copied image file to the second partition.
    Then restarted with Acronis bootable disk (iso) and restored image to c:\

    Jack
     
    Jack, Mar 8, 2008
    #3
  4. Jack

    Jack Guest

    One thing more.
    How did you install VM Additions in Safe mode?
    That is impossible on my system.
    The error message is:
    "The Windows Installer Service could not be accessed. This can occur if you
    are running Windows in safe mode or...."
    ???
    Jack
     
    Jack, Mar 8, 2008
    #4
  5. Jack

    Jack Guest

    Ok. Ignore this. You did not install additions in Safe mode.
    My mistake.
    Jack
     
    Jack, Mar 8, 2008
    #5
  6. Jack

    Robert Comer Guest

    RAM allocated to guest 1.2 GB

    That's too much, back it down to 512M to start and raise it until it
    start slowing down.
    If you use Universal restore, it's not supposed to as it sets XP to a
    state that it should detect the hardware correctly.
    That should matter, the Video capture card isn't passed through, so XP
    shouldn't try to load the driver, and modems shouldn't ever cause a
    problem like that, even if they had a special serial port. You might
    be able to use them in the VM...
    I created a new VHD, attached it to a working VM, and copied it from
    the host using a normal networking share. (as apposed to shard folders
    which is a feature of VPC) Then shut down that VM, created a new VM
    and VHD, Also attach the VHD from the step before, booted from the
    Acronis CD and restored.
    That sounds as if it's basically what I did, except I already had a
    working VM to do the copy. I don't see anything wrong with doing it
    that way, except maybe how did you do the copy?
    Are you sure you're using the Universal restore option? On the
    Acronis menu it's a separate option than a normal true Image restore.
     
    Robert Comer, Mar 9, 2008
    #6
  7. Jack

    Robert Comer Guest

    How did you install VM Additions in Safe mode?

    You can't, I did that after rebooting. (That's a Windows installer
    problem I don't particularly care for.)
     
    Robert Comer, Mar 9, 2008
    #7
  8. Jack

    Jack Guest

    I've found the source of problem why guestXP was soooooo slow.
    It was Symantec NAV.
    I have unistalled it from Control Panel (it took about 2 hours to complete
    that task!)
    Now it is normal.
    I am confused about all these options Acronis offers.
    On bootable disk (iso) I have at least 2 restore options involving Universe
    Restore.
    One is so called 'Safe' and another 'full install'.
    I do not have any clue which is for what. (I tried both anyway).
    Jack
     
    Jack, Mar 9, 2008
    #8
  9. Jack

    Robert Comer Guest

    I've found the source of problem why guestXP was soooooo slow.
    Cool, glad to hear it. (That you fixed it, not that Symantec was a
    problem!)
    The only difference between safe and full install from what I
    understand is the drivers it tries to load. For instance, on my
    laptop it wont work at all with the full version, but works with no
    problem on the safe version.
     
    Robert Comer, Mar 9, 2008
    #9
  10. Jack

    Jack Guest

    Now, if I could port Vista....
    I even cannot analyse it, because it refuses to create boot log.
    Jack
     
    Jack, Mar 9, 2008
    #10
  11. Jack

    Jim Kay Guest

    If the original 'real' machine has an ATA controller for the boot disk, the
    Universal Restore will not convert it properly and the resulting virtual
    machine will not boot. The symptoms are exactly what you have described.

    I have an open case at Acronis on this problem but they seem to be making
    zero progress. The case has been open since December.

    Jim Kay
     
    Jim Kay, Mar 9, 2008
    #11
  12. Jack

    Jim Kay Guest

    The problem is almost certainly not Vista but an ATA controller in the
    original real machine.

    Actually, I have two open cases on this problem and there is no effective
    progress on either one.

    Jim Kay
     
    Jim Kay, Mar 9, 2008
    #12
  13. Jack

    Jack Guest

    Is Vista different in that case? WinXP does not have booting problem.
    Jack
     
    Jack, Mar 10, 2008
    #13
  14. Vista in a vm would not be an issue. Jim is telling you to look at the
    host.
     
    Colin Barnhorst, Mar 10, 2008
    #14
  15. Jack

    Jack Guest

    In my case it is the same physical machine!
    I have dual boot and there is the same ATA controller for both!
    So, where should I look in the host?
    Jack
     
    Jack, Mar 10, 2008
    #15
  16. Dual booting has nothing to do with Virtual PC. Please explain how you are
    using VPC.
     
    Colin Barnhorst, Mar 10, 2008
    #16
  17. Jack

    Jack Guest

    It has, if you are porting both physical drives into vm.
    Jack
     
    Jack, Mar 10, 2008
    #17
  18. The dual boot aspect wouldn't make any difference. You would ghost each
    volume separately to its own vm. You will have issues with the change in
    hardware following the move, of course, but that also is apart from any dual
    booting matter.
     
    Colin Barnhorst, Mar 10, 2008
    #18
  19. Jack

    Jack Guest

    Colin, I do not know what you want to say.
    The problem I am having is that I can port physical disk having Win XP but I
    cannot port physical disk having Vista.
    If you've succeeded that please help. I mean if you done it yourself. If
    not, please try it first if you have Vista and if you succeed please let us
    know.
    Otherwise, I don't think you can help in that matter.
    Jack
     
    Jack, Mar 11, 2008
    #19
  20. Jack

    jeffâ„¢ Guest

    Hi To All,

    I experience what Jack is telling about, I am using Windows Vista Ulitmate
    Ed., and have a Virtual Server 2005 R2 w/ SP1 installed on it got 3 partition
    on a single hard drive which I perform I want to mount one partition on a
    virtual machine, when I try to link a physical drive into a virtual hard disk
    it displays like this: "Physical computer drive: <NONE>" it cannot display
    anything or not supporting my physical hard disk. Even I don't know why, or I
    am thinking about maybe this is because of ACU "Access Control List"
    feautures built-in on Vista settings that restrict the physical mount drive
    into virtual hard drive. Iexperience the same issue with him as well. Please
    help us to find a solution or provide a hotfix for this issue.

    Thank you in advance and hope you can find a solution for this problem.

    Jeff
     
    jeffâ„¢, Mar 27, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.