PowerNow not working on my laptop (in Vista 32bit nor 64bit, works fine under WindowsXP)

Discussion in 'Windows Vista Hardware' started by kibusi, Jun 17, 2006.

  1. kibusi

    kibusi Guest

    Hi,

    Has anybody experienced PowerNow not working for AMD64 CPUs under Windows
    Vista?

    No matter what kind of strees is put on the CPU it's stuck at 800MHz (Mobile
    AMD64 3200+), Windows XP was able to scale up to up to 2GHz just fine, and
    so is my Gentoo Linux - but I just can't get Vista to utilize my CPU
    properly :(

    Anyone thoughts anyone?

    TIA
     
    kibusi, Jun 17, 2006
    #1
    1. Advertisements

  2. I think I've sorted my problem with Amilo A1630 w/ 3200+ and not getting past
    the 800 Mhz mark. I am not saying it is a fix but it has worked for me. I
    updated the Fujitsu/AMI BIOS to the reference Uniwill BIOS 1.05. I did not
    breathe the entire process but lo and behold, into Vista and we have
    performance! :)
    Went from a 1 rating to a whoppin' 3! (yes, I know....)
    I was previously using Fujitsu-Siemens BIOS 1.03c. Never needed to update it
    really. They have released a 1.04 and I should have tried that first but went
    to the Uniwill site and downloaded the 1.05 BIOS from
    http://www.uniwill.com/UserDownload/258KA0/258KA0.php because I hate Fujitsu.

    A note to "I told you so'ers", there are STILL no useful options with these
    BIOS ROMs and there are still no settings within to enable Cool n Quiet or
    Turbo or whatever has to do with the proc. I reckon something sneaked it's
    way in.

    Another word of warning. This flash caused all of my hardware to have to be
    reinstalled. XP spat me back out so tried Vista and it handled it all for me
    nicely. Oh, and these laptops do not come with legacy floppy drives but you
    can always boot to memory key and do the flash.

    Hope this helps someone. Please remember though, I half expected the
    notebook to catch alight at anytime, that's how daring I felt. Don't do it if
    you don't mind waiting!

    Oh and did I warn you not to do it?

    I'm headed back into XP now, see if I can get working again. Checks and
    balances.
    He who dares. Good luck!
     
    s t e w d o g, Jun 20, 2006
    #2
    1. Advertisements

  3. Part 2:
    Further warning, my dual booting w/ XP has called for XP to be re-activated.
    It appears that there are some sort of hardware identifiers that are changed
    with this new BIOS, hence the fact that XP thought I had a different machine.
    After activation, I could get in but many things did not work and hardware
    that worked before now is looking for it's drivers. Wireless lan cannot
    connect :( even after deleting devices in DM and letting PnP pick them up
    again.
    I believe that Vista will be ideal for those who get a new motherboard, in
    that it detected and re-installed all of the new-found hardware, on the fly.
    I also get a few interference lines popping up during the XP loading screen.
    Scary. I think I'll re-install XP from scratch but I don't want to loose the
    Vista boot loader. Can't say what it would do to Gentoo but this is all a
    risk to be weighed.
     
    s t e w d o g, Jun 20, 2006
    #3
  4. kibusi

    kibusi Guest

    Thanks for the replys - think I'll have a go at the bios update, can't
    remember which version I am currently running but think it might be
    Fujitsu's 1.04 as it hasn't been that long since I last checked if any
    updates should have apperared since I acquired my notebook.

    Having to re-install XP doesn't scare me off (actually planning that anyway
    because I'm tired of my regional (Danish) installation resulting in mixed
    languages whenever I use non-danish programs...), and I really don't expect
    my Gentoo-installation to be heavily affected from the BIOS-update (keeps
    fingers crossed :))
     
    kibusi, Jun 21, 2006
    #4
  5. I've since installed the 1.04 bios from Fujitsu (their latest) due to the
    display 'glitches' with Uniwill's bios 1.05, and same problem as before. I
    am now happily using the Uniwill 1.04 bios and works a charm.
     
    s t e w d o g, Jun 21, 2006
    #5
  6. kibusi

    kibusi Guest

    Indeed Uniwill's 1.04 and 1.05 seems to enable speed-stepping - alas they
    introduce another problem for me...

    Fujitsu's 1.04 BIOS includes Amikbc (what is that?) v1.02 which fixes some
    problems I had with my Hauppage USB TV-tuner (able to boot with it plugged
    in and it doesn't freeze the tuner randomly during usage) while Uniwill's
    1.04 and 1.05 'only' includes Amikbc v1.01 which renders me unable to boot
    the laptop whith the tuner pluged in and causes the tuner to randomly freeze
    when using it.

    So I'm back to Fujitsu's 1.04 and hoping they will either release a new
    fixed BIOS or that some windows-update will fixx the problem as Windows XP
    scales fine.

    Kim Sindalsen
     
    kibusi, Jun 28, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.