PPTP VPN connections fail if "Use default gateway on remote network" is set.

Discussion in 'Windows Vista Networking' started by Carl Farrington, Jan 21, 2008.

  1. Anybody else experiencing this?

    I have one or two PPTP VPN connections which have the "use default gateway"
    enabled, as there are multiple networks on the other side. When establishing
    these connections, they connect and then disconnect after about 15 to 20
    seconds. During this time I can see that the default gateway has not been
    set on the interface, and is still showing as 0.0.0.0.

    I try the connection many times and it still fails. I then unset the "use
    default gateway on remote network" and all is well. I can add a network
    route manually and no problems. I have not tried adding a default route to
    the network to see if something fails. I should try that I suppose.

    Anybody seeing anything similar? This is happening with both networks which
    have "use default gateway on remote network" set. One is an Astaro Security
    Linux 4 box, the other is a Draytek Vigor 2800 DSL router.

    cheers,
    Carl
     
    Carl Farrington, Jan 21, 2008
    #1
    1. Advertisements

  2. Robert L. \(MS-MVP\), Jan 21, 2008
    #2
    1. Advertisements

  3. De-selecting IPv6 from the connections Networking tab seems to have fixed
    it, thanks. I actually have IPv6 disabled through the registry (somewhere..)
    already. Strangely, I still see 0.0.0.0 as the default gateway for the
    interface when I run ipconfig, but the routing table looks fine when I do
    route print.

    That doesn't sound quite right, does it Bob? Although it's working, so thank
    you!
     
    Carl Farrington, Jan 25, 2008
    #3
  4. I take it back (sorry ;) ) it didn't work :(
     
    Carl Farrington, Jan 25, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.