Preparing AD for Exchange 2007

Discussion in 'Active Directory' started by bschneider, May 15, 2009.

  1. bschneider

    bschneider Guest

    I am trying to prepare my Windows 2003 AD for Exchange 2007. When I run the
    setup /prepareAD it fails. The ldif log gives an error
    CN=ms-Exch-Sender-Reputaion Add error on entry starting on line 52:
    unavailable

    I cannot seem to figure out what the issue is. Can anyone provide some
    guidence?
     
    bschneider, May 15, 2009
    #1
    1. Advertisements

  2. Hello bschneider,

    Have you run EXBPA "Check Readiness for Exchange 2007" before?

    Do you have at minimum SP1 installed on the server?

    What forest functional level / domain functional level do you run?

    Any additional information in %SYSTEMDRIVE%\ExchangeSetupLogs\ExchangeSetup.log
    file?


    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], May 17, 2009
    #2
    1. Advertisements


  3. Error = unavailable? That points to one or two things...

    What server are you running the setup /prepareAD? Is it on the Schema Master? If on the Schema Master or some other machine, are you logged on as the Enterprise Admin (by default the first domain's admin account is the EA).

    Whatever machine you are on, make absolutely sure the DNS settings on the machine, or any machine in the domain, are only using the domain controller's IP address, and not the ISP's or router's IP as a DNS address. This is a common cause of this type of 'unavailable' error because it may be asking some other DNS server where the domain controller is. Also a single label AD DNS domain name can cause this ('domain' rather than the required minimum of 'domain.com' domain.something", etc).

    If the above is properly configured, then one other issue is if the DVD is bad, or the DVD drive where you are running it from may have problems. If you copy the DVD to a folder on the drive, does it give you the same error?

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSA Messaging, MCT
    Microsoft Certified Trainer


    For urgent issues, you may want to contact Microsoft PSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    "Efficiency is doing things right; effectiveness is doing the right things." - Peter F. Drucker
    http://twitter.com/acefekay
     
    Ace Fekay [Microsoft Certified Trainer], May 17, 2009
    #3
  4. bschneider

    bschneider Guest

    I did run EXBPA first and it passed. The new Exchange server runs Windows
    2008 SP1. The DC is Windows 2003 SP2.

    Domain functional level is Windows 2003.
     
    bschneider, May 18, 2009
    #4
  5. bschneider

    bschneider Guest

    I am running the setup on the new Windows 2008 server. I am logged in as the
    EA. DNS is correct. I have copied the files to the local drive with the same
    error.

    It doesn't seem like it can't connect, it seems like it is this specific
    schema entry because there is a successful entry in the log before the
    failure for "ms-OWA-Virtual-Directory". Is it possible that this entry
    doesn't exist? When I search the schema I do not see it.
     
    bschneider, May 18, 2009
    #5
  6. Hello bschneider,

    Do you use Exchange 2007 SP1? I assume both versions are 64bit?

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], May 18, 2009
    #6
  7. bschneider

    bschneider Guest

    Yes Exchange 2007 SP1 64 bit. Server 2008 64 bit.
     
    bschneider, May 18, 2009
    #7
  8. bschneider

    bschneider Guest

    I have figured out the issue. It was a NIC card setting that was causing the
    issue. I had to disable the "IPv4 Checksum Offload" and "IPv4 Large Send
    Offload" settings.
     
    bschneider, May 20, 2009
    #8
  9. Interesting. You mean in the NIC's Advanced settings? I checked one of my client sites, and these settings are all enabled. Interesting this caused an issue. Is IPv6 enabled on the machines?

    Ace
     
    Ace Fekay [Microsoft Certified Trainer], May 20, 2009
    #9
  10. bschneider

    bschneider Guest

    IPv6 is not enabled. I figured it out when I connected remotely to the
    server and I kept getting disconnected with an encryption error and it was
    very slow. Once I made the change the disconnects were gone, the speed was
    back to normal and the install succeeded.
     
    bschneider, May 20, 2009
    #10
  11. Encryption error? Curious, what was the error? Posting it may also help others.

    Thanks!

    Ace
     
    Ace Fekay [Microsoft Certified Trainer], May 20, 2009
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.