Printer Offline

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Zach, Dec 9, 2007.

  1. Zach

    Zach Guest

    Using network printer HP 1320n from 3 XP PCs and 1 Vista PC. No problems
    with it for the past 2+ years with XP. With Vista, this printer has status
    of "Offline" when looking at the printer in Control Panel ==> Printers. The
    printer gets the problem at some unknown point. After installing the driver,
    it has the correct "Ready" status and have printed succesffully multiple
    times from Vista. The last time this problem occurred, I had to reinstall
    the driver but cannot keep doing this.

    1) How do I stop the printer from being "offline".
    2) Is there any way to make it "Ready" without reinstalling the driver ?

    Appreciate any help.
     
    Zach, Dec 9, 2007
    #1
    1. Advertisements

  2. Zach

    mathews2010 Guest

    make sure ur vista workgroup name matches the xp workgroup names..and
    that all your computer user names are different


    --
    mathews2010

    - ::Intel Core 2 Quad (Q6600)::
    - ::216BW Samsung Widescreen
    ::
    - ::Nvidia 8400 GS::
    - ::320 GB Seagate HDD::
    - ::2 GB G.Skill (DDR 2 800) (PC2-6400)
    ::
    - ::ASUS P5K LGA 775 Intel P35 ATX Intel Motherboard...::
    - ::Vista x64::
     
    mathews2010, Dec 9, 2007
    #2
    1. Advertisements

  3. Zach

    Zach Guest

    Matthew...thanks for the suggestion but what have already checked what you're
    suggesting. Have been using this printer from 3 XP PCs on the same network
    for a long time and the new Vista PC has a different computer name and the
    same workgroup name as the XP PCs.

    Pls let me know if you think of anything else.....thx
     
    Zach, Dec 9, 2007
    #3
  4. Zach

    Zach Guest

    Found the problem. For whatever reason, the driver installation process in
    the VISTA environment makes the assumption that static IP addressing is being
    used on the network when in fact I am using DHCP. There are no
    network-related options in the installation process. Defined a port using
    the printer's host name instead of the "current" IP address, which is what
    the installation process does, deleted all the IP address-based ports, and
    that did it.
     
    Zach, Dec 10, 2007
    #4
  5. Zach

    scgilman Guest

    Zach-- can you please describe how you accomplish those steps that
    were successful?
    Thanks,
    Stuart
     
    scgilman, Jan 7, 2008
    #5
  6. Zach

    Zach Guest

    Stuart,

    Here it is. FYI, after thinking about it, I think this problem was caused
    by the print driver install shield procedure and not Vista.

    1. Control Panel | Printers | Right click on the appropriate printer | Left
    click properties | Select Ports tab

    2. Deleted every port which had an IP address in its name (192.xxxx
    )....left column of port list, select port, Delete button.

    3. Added a port........ Add Port button and selected Standard TCP/IP Port.

    4. Printed my printer's configuration page (printer-specific, see manual)

    5. Highlighted newly defined port, then button Configure Port as follows:

    - For Port Name and Printer Name or IP Address, typed-in the printer's
    (actually the print server's) hostname (hostname obtained from step #4).

    - Protocol: Raw
    - Port Number: 9100
    - SNMP Status Enabled: checked
    - OK
    - OK

    Printer came online immediately. Good luck !
     
    Zach, Jan 8, 2008
    #6
  7. Zach

    nikwoof Guest

    Hi All

    I had the printer offline problem too. I solved it by reinstalling th
    printer driver from the manufacturer's installation CD. Just put the C
    in and follow the prompts. Too easy

    With Vista, do not try to install printers from contro
    panel/printers/add printer. Yeah, I know.....

    Good luck
    nikwoo
     
    nikwoof, Sep 8, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.