Problem clicking on e-mail link in IE 7

Discussion in 'Windows Vista Mail' started by kassa77, Dec 11, 2009.

  1. kassa77

    kassa77 Guest

    When I am in IE 7 and trying to click on a link to someone (to send an e-mail, send a resume, reply to a posting on Craig's List, ect.), all I get is a error message stating the following,"Could not preform this operation because the default mail client is not properly installed."  I have tried going to the tools section of IE7 and going down to internet options and clicking on the programs tab and choosing internet programs and hitting the set programs button, then choosing set your default programs.  Then I have seperately chosen both IE and Windows Mail and clicked on the "set this program as default" green arrow, and ok'd my way back out.  Still have the problem.  Does anyone know if this is a problem in Explorer, or the mail program, and how to fix it?  This started about a month or 2 ago, and is a real hassle.  Someone suggested dumping and reinstalling either or both programs, but not sure if I want to go to that drastic of a mesure, and I'd loose all my saved e-mails and sites too.  Any help you can give me is greatly appreceated!!!  Thanks much...............


    Post Originated from http://www.VistaForums.com Vista Support Forums
     
    kassa77, Dec 11, 2009
    #1
    1. Advertisements

  2. It sounds like your Windows Mail doesn't have all its defaults.
    Try this first:
    Open the Default Programs applet, which you can access either from
    the Start menu or via the Control Panel, then click the first item:
    "Set your default programs."
    After a few seconds, a list of programs comes up. Click on "Windows
    Mail". If it doesn't respond with "This program has all its defaults"
    then fix it by clicking on the option indicated by the first green arrow.

    If no improvement, the following procedure will rewrite the
    default protocol assignments in the registry:
    Open the Default Programs applet, then click on "Set program
    access and computer defaults." Expand the Custom selection, and
    select Windows Mail. Click OK.

    --
    Gary VanderMolen, Microsoft MVP (Mail)
    http://mvp.support.microsoft.com/default.aspx/profile/vandermolen


    in message news:...
     
    Gary VanderMolen \(MVP\), Dec 11, 2009
    #2
    1. Advertisements

  3. kassa77

    kassa77 Guest

    That took care of the problem for me, I want to thank you very much for your help.  I'm really grateful!!!!!  Have a merrry Christmas, and a happy and safe New Year!!!!


    Post Originated from http://www.VistaForums.com Vista Support Forums
     
    kassa77, Dec 11, 2009
    #3
  4. Gary VanderMolen \(MVP\), Dec 11, 2009
    #4
  5. kassa77

    alex mungo Guest

    Hell Gary

    I have another problem with my windows mail that you might be able to fix.
    When I send an email that contains a website link inside the email, the
    recipient is unable to open the link at the other end. Can you help me to fix
    this?
     
    alex mungo, Dec 21, 2009
    #5
  6. kassa77

    famsol Guest

     
    famsol, Dec 21, 2009
    #6
  7. This is a duplicate of the issue you posted under "Links sent not working..."
    Several responders already answered you there.
    Please limit posting to one thread per issue.
     
    Gary VanderMolen \(MVP\), Dec 21, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.