problem connecting windows update - CPU 100% svchost.exe

Discussion in 'Windows Update' started by Rollo, May 2, 2007.

  1. Rollo

    Rollo Guest

    Hi,

    everythime I try to connect to winduws update, no list of item can be
    displayed. The browser stays in "hang status", the svchost process arrives to
    100% CPU until it blocks everything. No error reported.

    I tried several workaround (deleting software distribution folder, stopping
    the firewall). But nothing worked until now! THe connection looks fine. The
    service for windowsupdate is correctly running. I really cannot understand.
    Anybody who can help, please?
     
    Rollo, May 2, 2007
    #1
    1. Advertisements

  2. If you want to have it resolved now (and not wait another ~4 weeks):
    Download and install KB927891 (v2) links to be found for your Windows
    version in http://support.microsoft.com/kb/927891

    After you've installed that one, download an install the actual version
    of Windows Update Agent 3.0 via
    http://download.windowsupdate.com/v7/windowsupdate/redist/standalone/WindowsUpdateAgent30-x86.exe

    I'm assuming you're *not* running Windows Vista and no 64bit version
    of any Windows.

    Bye,
    Freudi
     
    Ottmar Freudenberger, May 2, 2007
    #2
    1. Advertisements

  3. Rollo

    Rollo Guest

    many thanks Freudi for your suggestion, it worked pretty well.

    D.
     
    Rollo, May 2, 2007
    #3
  4. Hey Thanks.....,

    I have been working on this problem for the last couple days and your
    solution solved my problem!!! Thanks again,
     
    Troubled Updates, May 11, 2007
    #4
  5. Rollo

    qbert Guest

    Hi to you Freudi,

    we have a lot of laptops here and we have this problem since a week thanks
    for your help so much appreciated
     
    qbert, May 11, 2007
    #5
  6. Rollo

    alan Guest

    Hi, I happen to be running VISTA and have same problem. Am i doomed??!!
     
    alan, Jul 20, 2007
    #6
  7. Rollo

    sean Guest

    I think so.

    I'm in the same boat as well with Vista.

    My computer will not update anything from Microsoft.

    It quit updating about a month ago after updating fine on a regular basis.

    Nobody seems to know how to fix it.

    I have tried everything I could find on the internet and it still will not
    search for updates.
     
    sean, Aug 1, 2007
    #7
  8. Rollo

    Weezul Guest

    We have been having on ongoing problem with this svchost.exe process related
    to Microsoft auto updater. I have tried applying the 927891 patch each time,
    and it has resolved the problem on several. However, the last three pcs that
    I have worked on that have had this issue would not run free up after
    applying it. I have had to tell the users that they will need to run updates
    manually for now, and am becoming quite annoyed with this issue. If you
    reference the KB article, the end results that they are trying to achieve do
    not look promising to begin with. This being a main component of Windows, I
    would think they would have this resolved ASAP, but it is still an issue for
    us four months later.
     
    Weezul, Aug 15, 2007
    #8
  9. Rollo

    PA Bear Guest

    PA Bear, Aug 16, 2007
    #9
  10. And Windows Update Agnet 3.0 has been installed too? *Both*, KB927891
    *and* WUA 3.0 are needed to fix the svchost permanent 100% CPU usage
    in conjunction with wuauclt.exe running.
    Are there any Personal Firewall applications installed on these
    machines and/or any design changing "Vista Packs" and the like?
    Did you try running "netsh winsock reset" under "Run" in the Start
    menu and rebooted the machine? Did that help at least temporary?

    Bye,
    Freudi
     
    Ottmar Freudenberger, Aug 16, 2007
    #10
  11. Rollo

    Kitty_G Guest

    Thanks for your suggestion. worked straight away.

    Cheers

    Kit
     
    Kitty_G, Apr 22, 2008
    #11
  12. Rollo

    Jorte Guest

    Hey there Freudi,

    Having a similar problem here and nothing so far has resolved it. Any other
    quick ideas?
     
    Jorte, Apr 25, 2008
    #12
  13. What kind of "similar problem"?
    Would you mind answering the questions asked to Weezul?
    What Windows version are you on?

    Bye,
    Freudi
     
    Ottmar Freudenberger, Apr 26, 2008
    #13
  14. Rollo

    MoosieAZ Guest

    Unfortunately this problem (or one identical) has returned, almost exactly 1
    year after these posts began. On May 7th I had been using my stable Windows
    XP/SP2 desktop system as usual, until exactly 10AM, at which time the system
    became unresponsive. Eventually I was able to get into Task Manager and
    found SVCHOST at 99% CPU. Several reboots later, and using Process Explorer
    I found that wuaueng.dll was using the CPU. If I suspend that task, the
    system frees and everything returns to normal.

    I already had the fixes on my system mentioned in this thread. With no new
    info available from any source, I decided to just let my system run at 100%.
    Several hours later I found that the system was idle, and when I checked logs
    and other files I discovered that a windows update cycle had started at 10
    AM. I thought I was out of the woods, because after I rebooted everything
    seemed okay. At 3 PM another 'update' cycle started again (on its own; my
    auto update time is set to 3 AM) and the system went to 100% CPU. I left it
    alone again for several hours and when I checked it was fine. That was
    several days ago, and no recurrence since then. However, a friend asked for
    my help yesterday with his laptop - same issue, which I'm now trying to
    correct.

    This stinks Microsoft!
     
    MoosieAZ, May 11, 2008
    #14
  15. Rollo

    Chuck Guest

    Abruptly on Thursday (5/8/2008) my wife's laptop, a 16 month-old dual-core
    ThinkPad with XP SP2, began an extended run at 100% CPU like many of the
    other incidents described in this article, most notably that of MoosieAZ. I
    traced the problem to an instance of the svchost.exe process and am dismayed
    to report that it finally retired into the background after 47 minutes of CPU
    time. Further, it executed several hundred BILLION I/O Read Bytes. Yep,
    MINUTES and BILLIONS. I can't possibly imagine what operation could consume
    such resources and still run to apparent completion. Seems like a process
    that asks "Are these few/dozen/hundreds DLLs up to date?" should be able to
    answer that question in a mere fraction of the time . . . and resources.

    This behavior repeated itself everytime she restarted the laptop. (This
    occurs frequently, since her habit is to turn off the machine when she's
    done with any usage session. I realize some pain could be avoided by leaving
    the laptop running, but that's not the point.) After several 47 minute
    cycles on subsequent start-ups, the computer seemed to have been happy with
    the work it performed and, per the System Event Log, indicated that about a
    dozen Office 2003 updates were SCHEDULED for installation at 3:00 a.m. on
    5/10/2008. Most of the updates seemed to be security related.

    We left the laptop on over night so it could plow through the 3:00 a.m.
    installation, which logs indicate it accomplished successfully, though I have
    no CPU or I/O stats to report.

    I thought we were clear of the problem, but the same 100% CPU behavior began
    again this morning (Sunday, 5/11/2008). Armed with a little more knowledge
    of the potential culprit, I was able to confirm that a svchost.exe instance
    was indeed racking up the CPU and I/O, the former of which rivaled the System
    Idle Process. From Process Explorer (procexp.exe) I confirmed that
    'wuauserv' was a member of the svchost instance and was able to successfully
    kill 'wuauserv'. The system recovered in a matter of seconds and the
    computer returned to its normal responsiveness.

    I can confirm that KB 927891 was delivered on 5/23/2007, not too long after
    the initial post on this thread and presumably as a result of Windows Update
    performing properly. I'm not certain whether it was successfully installed,
    though. The KB927891.log file indicates fourteen files were copied, but the
    log also contains twenty consecutive lines of "KB927891 encountered an error:
    The update.ver file is not correct." near the beginning and scattered other
    "failure" messages throughout.

    Regarding any updating of Windows Update Agent to 3.0, I can only report the
    dates and internal versions of the following "wuau..." files in
    C:\Windows\System32:

    wuauclt.exe 07/30/2007 07:19 PM 7.0.6000.381
    (winmain(wmbla).070730-1740)
    wuauclt1.exe 05/26/2005 08:16 AM 5.8.0.2469 built by:
    lab01_n(wmbla)
    wuaueng.dll 07/30/2007 07:19 PM 7.0.6000.381
    (winmain(wmbla).070730-1740)
    wuaueng1.dll 05/26/2005 08:16 AM 5.8.0.2469 built by:
    lab01_n(wmbla)
    wuauserv.dll 08/04/2004 08:00 AM 5.4.3790.2180
    (xpsp_sp2_rtm.040803-2158)

    I present this information in as much detail as I can muster because it
    seems our symptoms align well with described problem, but it disturbs me that
    most of the posts on this thread date back to May 2007. I would have
    expected that Microsoft would have resolved the problem in less that twelve
    months. The laptop has been on Automatic Updates since shortly after we
    received it, although I only installed Office 2003 on it a few weeks ago.

    I am reluctant to proceed with the (re?)installation of KB 927891 and update
    to Windows Update Agent 3.0 described earlier because it seems like it is old
    guidance. How do we get this problem resolved?
     
    Chuck, May 11, 2008
    #15
  16. Try this:

    1. Start | Run | (type in) CMD | [OK]

    2. In the Command box, carefully type the following, hitting ENTER after
    typing each line:

    • net stop wuauserv [ENTER]

    • rmdir c:\windows\softwaredistribution /s [ENTER]

    • net start wuauserv [ENTER]

    3. Close the Command window and Reboot.
     
    PA Bear [MS MVP], May 11, 2008
    #16
  17. This may be applicable:

    <http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3241867&SiteID=17>

    The problem seems to be caused by CA antivirus.

    Harry.
     
    Harry Johnston [MVP], May 12, 2008
    #17
  18. Rollo

    jkloosterman Guest

    jkloosterman, May 12, 2008
    #18
  19. Rollo

    shayward Guest

    This is happening to me as well - and it just started in the middle of last
    week. Automatic Updates is the offender - I disabled it in MSCONFIG and all
    is well (other than the fact that Automatic Updates is disabled).

    SVCHOST consumes 100% CPU and it starts eating memory until it reaches >
    100MB.
     
    shayward, May 12, 2008
    #19
  20. Nice catch, Harry!

    From the thread cited above:

    <QP>
    Have just got off talking to a CA technician. Was advised to exclude all
    *.msp and *.msi files in the Real-Time scan.

    What I did was:

    1. "Open Security Center"
    2. "Open Advance Settings"
    3. Clicked on the "Options" button
    4. Clicked on the "Modify" link under the Exclusions list and then "Added"
    *.msi and *.msp to the list and clicked OK
    </QP>
     
    PA Bear [MS MVP], May 12, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.