Problem installing Lexmark x4650 - error 0x000006be, Print Spooler, Add Printer

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by AndyW68, Oct 13, 2008.

  1. AndyW68

    AndyW68 Guest

    I have had problems for the best part of a week now trying to install a
    brand new Lexmark x4650 printer onto my 6 month old Compaq Laptop
    running with Vista basic.

    I have tried other printers (HP and Dell) and have had similar
    problems.

    The printer seems to install fine (both using the provided disc and
    after downloading the latest drivers from the Lexmark website). However
    once installed I receive a message advising that some software for the
    drivers has not installed correctly. The printer is not then visible in
    the Control Panel.

    Also:

    1) When trying to install (add) a new printer manually (before and
    after removing all previously installed software) an error message
    appears,
    telling that the spooler is not running (or similar)

    2) When checking in the services.msc console,
    I can see that the spooler has stopped.

    3) When starting the spooler, it seems to stark ok,
    but as soon as I try to (again) "add" a printing (using the
    appropriate button)
    - the spooler immediately crashes (stops)
    and the same error message occurs
    - spooler not started and/or
    - windows can't open add printer and/or
    - Operation could not be completed and/or
    - error 0x000006be
    - etc...

    4) I have checked the dependencies for the spooler and they are all
    started and set to Automatic.

    I have spent hours going through this and other forums trying to find a
    solution. I have tried many that I have found but to no avail. I would
    be very grateful for any assistance anyone could provide - especially
    from Microsoft who (when I try to contact them) say they cannot help.

    I have spoken to Lexmark for an hour who said the printer and my laptop
    were working fine and it was a Vista problem.

    I have currently uninstalled all software and am back to square one!

    Please help. Many thanks in advance.

    AndyW
     
    AndyW68, Oct 13, 2008
    #1
    1. Advertisements

  2. Alan Morris [MSFT], Oct 13, 2008
    #2
    1. Advertisements

  3. AndyW68

    AndyW68 Guest

    Thanks for your response. When I look into services.msc the spooler i
    started and set to Automatic. However when I select file> serve
    properties I receive a message saying 'Server properties cannot b
    viewed. The local printer spooler service is not running. Pleas
    restart the spooler or restart the machine'

    thanks
    Andyw68

     
    AndyW68, Oct 15, 2008
    #3
  4. the spooler is crashing. This is typically caused by print drivers
    corrupting the memory in the spooler process

    Check the registry for the print drivers that are installed on the system
    and follow Bruce's instructions.

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

     
    Alan Morris [MSFT], Oct 15, 2008
    #4
  5. AndyW68

    AndyW68 Guest

    Hi.

    I have followed Bruce’s guide to the letter and manually removed a
    much printer related files as I can see. I was unable to use th
    cleanspl.exe as it does not work with NT6.0 (only 4.0 and 5.0).

    However this has not worked.

    When I reinstalled the Lexmark printer using the provided disc, th
    install completes successfully but the printer does not print and n
    printer is visible in control panel.

    When the USB cable is connected (both during and after the instal
    process) Windows searches for drivers and provides the followin
    message in a Found New Hardware’ box:

    ‘Windows encountered a problem installing the driver software for you
    device. Windows found driver software for your device but encountere
    an error while attempting to install it. One of the installers for thi
    device cannot perform the installation at this time’

    Selecting ‘Add Printer’ manually produces the messages below (dependin
    on whether the print spooler is running at the time):

    Error 1067 – could not start the print spooler service – terminate
    unexpectedly

    Unable to add printer spooler service is not working

    Error 0x000006be

    There were however some files that I was unsure as to whether I shoul
    delete or not. These were in folde
    %systemroot%\system32\spool\drivers\w32x86. A screen dump of these i
    the attached document.

    Thanks

     
    AndyW68, Oct 16, 2008
    #5
  6. The PnP service can't install a print driver when the spooler is not
    running.

    is there a WER (Windows Error Report) file for the failure?

    %systemroot%\programdata\Microsoft\Windows\WER\ReportQueue\Report[#####]

    if you see spooler.xml and the *.tmp.hmp then you have a full memory dump of
    the spooler service as it failed

    Report.wer
    spooler.xml
    SpoolerETW.etl
    WERAF80.tmp.version.txt
    WERAF81.tmp.appcompat.txt
    WERAFA2.tmp.hdmp
    WERC42C.tmp.mdmp
    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

     
    Alan Morris [MSFT], Oct 16, 2008
    #6
  7. AndyW68

    AndyW68 Guest

    I can see no WER in the folder ReportQueue but there are 5 in the Repor
    Archive (also in the WER folder you mention).

    However could you advise which program I should use to open them?
    receive the message 'Windows cannot open this file - please select fro
    a list' when I tried to.

    Apologies for my lack of knowledge on this. Thanks for you help.

     
    AndyW68, Oct 17, 2008
    #7
  8. open the report.wer file in notepad
    look for the Fault Module Name.


    Version=1
    EventType=APPCRASH
    EventTime=128556963484732107
    ReportType=2
    Consent=1
    Response.type=4
    Sig[0].Name=Application Name
    Sig[0].Value=spoolsv.exe
    Sig[1].Name=Application Version
    Sig[1].Value=6.0.6001.18000
    Sig[2].Name=Application Timestamp
    Sig[2].Value=4791956c
    Sig[3].Name=Fault Module Name
    Sig[3].Value=msvcrt.dll
    Sig[4].Name=Fault Module Version
    Sig[4].Value=7.0.6001.18000
    Sig[5].Name=Fault Module Timestamp
    Sig[5].Value=4791a727
    Sig[6].Name=Exception Code
    Sig[6].Value=c0000005
    Sig[7].Name=Exception Offset
    Sig[7].Value=0001225d

    to investigate the dump file, you will need ntsd.exe and internet access
    other than dialup

    http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx#a

    after installing the debugger files

    launch ntsd -z WER####.tmp.hdmp

    this will open a window and leave you at a prompt with a thread ID

    type
    ..symfix
    ..reload
    k

    0:022> .symfix
    0:022> .reload
    ..........................................................................................
    ...............................
    Loading unloaded module list
    .................................................................
    0:022> k
    ChildEBP RetAddr
    03cb7884 77bc9244 ntdll!KiFastSystemCallRet
    03cb7888 7783c3e4 ntdll!ZwWaitForMultipleObjects+0xc
    03cb7924 7783c64e kernel32!WaitForMultipleObjectsEx+0x11d
    03cb7940 778adb5d kernel32!WaitForMultipleObjects+0x18
    03cb79ac 778add89 kernel32!WerpReportFaultInternal+0x16d
    03cb79c0 7788f54d kernel32!WerpReportFault+0x70
    03cb7a4c 77be85b7 kernel32!UnhandledExceptionFilter+0x1b5
    03cb7a54 77b79a14 ntdll!__RtlUserThreadStart+0x6f
    03cb7a68 77b740f4 ntdll!_EH4_CallFilterFunc+0x12
    03cb7a90 77bc9b99 ntdll!_except_handler4+0x8e
    03cb7ab4 77bc9b6b ntdll!ExecuteHandler2+0x26
    03cb7b64 77bc99f7 ntdll!ExecuteHandler+0x24
    03cb7b64 76f1225d ntdll!KiUserExceptionDispatcher+0xf
    03cb813c 69dab854 msvcrt!strstr+0x1e
    03cb8474 69daa5e7 HPZUILHN!CHPPrintUI::VHandleInputTraysUIWIPCH+0xc4
    03cbb27c 69da9de1 HPZUILHN!CHPPrintUI::UpdatePrintPropSettingsWIPCH+0x7a7
    03cbb29c 69d9e10a HPZUILHN!CHPPrintUI::VProcessEACwIPCH+0x51
    03cbeed0 69d971e7 HPZUILHN!CHPPrintUI::BOEMPrinterEvent+0xc1a
    03cbeee8 71b0460e HPZUILHN!CHPPrintUI::printerEvent+0x27
    03cbef10 71affaa3 unidrvui!HComOEMPrinterEvent+0x33
    0:022>




    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

     
    Alan Morris [MSFT], Oct 20, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.