Problem raising forest functional level to Windows 2003

Discussion in 'Active Directory' started by Sly, Jul 14, 2005.

  1. Sly

    Sly Guest

    I have two domains in a single forest. All DC's are running Windows Server
    2003. I've raised both domains from 2000 native to 2003. Now I'm trying to
    raise the forest functional level from Windows 2000 to 2003. I keep getting
    the message "You cannot raise the forest functional level......one or more
    domains in the forest are still at Windows 2000 mixed functional level or
    Windows 2003 functional level". OK, so I save the file for details and it
    shows one of my domain is Windows 2000 mixed. But it's not. If I go to
    raise that domain, it shows Windows Server 2003 and that it's "operating at
    the highest possible functional level". I've waited over 24 hours to clear
    any replication issues. I've tried raising the level from the forest root
    DC and also from the DC of the domain that it claims is still in 2000 mixed.
    Anyone have any ideas?

    Thanks,
    Sly
     
    Sly, Jul 14, 2005
    #1
    1. Advertisements

  2. You have a replication issue. load replmon, it is part of the support tools
    and check replication

    Richard
     
    Richard Oltmann, Jul 14, 2005
    #2
    1. Advertisements

  3. Sly

    Sly Guest

    Hi,

    replmon and repladmin /showrepl shows successful replication between the
    DC's (ran this on all the DC's and no errors were shown).

    A side note: Microsoft Support used the metadata tool to remove a server
    that was originally NT and then upgraded to Windows 2003 a few weeks ago
    (while my domain was still in mixed mode). I had wanted to just use dcpromo
    to demote it but they assured me I would not have any future problems. I'm
    wondering if there's still something in AD that thinks the NT isn't gone
    yet...

    Sly
     
    Sly, Jul 14, 2005
    #3
  4. Check Sites and Services to ensure there's no NTDS Settings object for the
    machine that was removed. If there's an NTDS Settings object, or a server
    object in there (the NTDS Settings object's parent) delete it.

    Also ensure the computer account has been deleted (although this shouldn't
    make any difference you should get rid anyway).
     
    Paul Williams [MVP], Jul 15, 2005
    #4
  5. Sly

    Sly Guest

    Hi Paul,

    I've checked the NTDS Settings and the deleted machine is not there.
    However, I'm seeing something that could be my problem but I'm not sure how
    to fix it:

    On the DC in domain-A, under Servers, I see a list containing all my DC's
    from BOTH domains. When I go into the NTDS Settings for a server in
    domain-A, I see the replication partner list and other DCs in domain-B are
    there.

    On any of the DC's in domain-B, under Servers, the list only shows DC's from
    that domain. When I go into the NTDS Settings for any of those DCs, it only
    shows replication for other DCs on the same domain. There's nothing for
    domain-A.

    So this seems to indicate that my replication are only happening one-way.
    As a test, I used adsiedit to create some configuration folders and tried to
    replicate. The objects would go from domain-A to domain-B successfully but
    nothing gets replicated from B to A (I issued a replamdin /syncall /e /d and
    there are no errors) I'm confused because I thought the intrasites
    replication partners are automatically created during dcpromo. How would I
    get the domain-B to replicate to domain-A?

    Any input greatly appreciated,
    sly
     
    Sly, Jul 18, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.