Problem with Age of Empires II

Discussion in 'Windows Vista Games' started by cosarrara, Oct 2, 2007.

  1. cosarrara

    cosarrara Guest

    After install Age of Empires II, i try to play, but it not run and the
    message is: "Could not initialize graphics system. Make sure that your video
    card and driver are compatible with DirectDraw"
    My Pc is new, i have a good ATI card and i try with the solutions proposed
    in this link without any result:
    http://support.microsoft.com/?scid=kb;en-us;242902&x=22&y=12

    Can anyone help me, please??!! :s
     
    cosarrara, Oct 2, 2007
    #1
    1. Advertisements

  2. cosarrara

    Mark Guest

    Its possible this is AOEII's way of reporting missing DirectX components.
    Try going to www.microsoft.com/directx and clicking the download button.
    This will install DirectX 9.0c on your system. It will NOT interfere with
    the normal DirectX10 you got with Vista. What it will do is add some missing
    pieces that MS didn't include with DirectX10.

    Hope that helps!
    Mark
     
    Mark, Oct 5, 2007
    #2
    1. Advertisements

  3. Make sure you have the newest ATI drivers (http://ati.amd.com), and try
    installing DX 9 (you can get it off the MS site, or it may be included on
    the AoE2 CD).
     
    Dustin Harper, Oct 14, 2007
    #3
  4. i have the same problem an i also cant find any solution. i went to google
    and i saw a forum post by someone how has saying he has having problems in
    multiplayer mode, to have this problems he should be able to start the game
    he also sead he has using vista home premium. if find any solution let me
    know please, my email is .
     
    same problem but still need help, Dec 7, 2007
    #4
  5. were can i find direct x 9 for vista? when i go to your link it gives me the
    direct X 10.
    please help me again because i am a complete pc noob.
     
    same problem but still need help, Dec 7, 2007
    #5
  6. cosarrara

    manuel Guest

    i have already instaled direct x 9 but the problem continues.
     
    manuel, Dec 8, 2007
    #6
  7. cosarrara

    guppywily Guest

    As soon as i start a game and the map appears, the scroll box automatically
    starts climbing to the top of the screen. i switched out keyboards to see if
    a button was stuck; didnt work. my mouse seems operational. are there any
    software problems that could be responsible for this? if anybody can help,
    plz email me at
     
    guppywily, Dec 26, 2007
    #7
  8. cosarrara

    Gusanto Guest

    hello unit,

    I have the same problem, I tried to solve it with your suggestion but
    it doesn't work for me, please help me.

    I extracted the files of the zip to my desktop after that i copied them
    to my aoeii directory but it doesn't work, I'm following the steps
    correctly?

    Please answer me.

    Gusanto
     
    Gusanto, Apr 15, 2008
    #8
  9. cosarrara

    Unit92 Guest

    Gustano: firstly im making 2 assumptions.
    1. your problem is the same as the OP:

    2: that you are extracting all 3 files to both the age of empire
    directory and the subdirectory created by conquerors.

    If this is the case you may not have the specific Permissions t
    initiate Direct3D under your system so i would suggest selecting Run a
    Administrator" under the file options.

    see if that help
     
    Unit92, Apr 15, 2008
    #9
  10. cosarrara

    Gusanto Guest

    Hello,

    Thank you for answer me, I have many time without solve this problem,
    sice I changed my ati radeon x1950 pro to my geforce 8800 gt.

    1. Yes, that is my problem. ("Could not initialize graphics system.
    Make sure that your video card and driver are compatible with
    DirectDraw" error message when you start Age of Empires II), sometimes
    appear that message but other times starts the presentation of the game
    and then appear a black screen and when I move my mouse appear many
    diferent colors.

    2. I can't extract the files directly to my game's directory. so i had
    to extract them to my desktop and then i copied them to the games,
    should be work??


    I have a geforce 8800 gt, original windows vista and the game is also
    original.

    Thank you.

    Gusanto
     
    Gusanto, Apr 16, 2008
    #10
  11. cosarrara

    Gusanto Guest

    Gusanto, Apr 20, 2008
    #11
  12. cosarrara

    Phoenix2k4 Guest

    can u repost that or redirect? something is wrong with the link - either
    broken or removed
     
    Phoenix2k4, May 9, 2008
    #12
  13. cosarrara

    melocscz Guest

    Gusanto, can u post the link again because the page cannot be foun
     
    melocscz, Jun 18, 2008
    #13
  14. cosarrara

    Firegem50 Guest

    Hi,
    I don't know where the directories are so i can't do the zip thing.
    My computer said dd works but aoe2 won't work still.
    Plzzzzzzzzzzzzzzzzzzzzzzzzzzzzz help
     
    Firegem50, Jun 26, 2008
    #14
  15. cosarrara

    Firegem50 Guest

    Post it again properly
     
    Firegem50, Jun 26, 2008
    #15
  16. cosarrara

    ricco4 Guest

    i need it, post it again please:eek:
     
    ricco4, Jul 2, 2008
    #16
  17. cosarrara

    Olórin Guest

     
    Olórin, Jul 2, 2008
    #17
  18. cosarrara

    Olórin Guest

    <hits Ctrl-Enter instead of Ctrl-End first time...>

    What the dickens are you on about??? You've snipped out all the history of
    this thread so all it sounds like is, based on the subject line, that you
    want a problem posting....
     
    Olórin, Jul 2, 2008
    #18
  19. Has anyone found the solution yet ?!
    I was able to play the game fine on a low spec win98 PC with a simple
    Riva TNT 64 (does any one remember these??) and unable to do so on my
    much higher spec winXP laptop with an ATI X1400 ...

    really frustrating

    Age of nations, AoE III and the rest are all ok ...
    Just AoE II doesn't work ...

    You bet I have directDraw!!
    (dxdiag performed wonderfully!)

    I even tried the stupid suggestions in MS Knowledge base ... of course
    they didn't work ...

    any help is appreciated ... i really miss this game!
     
    Christoforos Korakas, Jul 2, 2008
    #19
  20. cosarrara

    ricco4 Guest


    oh sorry, i'm spanish and i haven't understand you:eek:

    i have the same problem as everyone, i have a new toshiba laptop with a
    ati mobility radeon hd2600 with all ok, new drivers, last directx and
    all these things, i have tried a lot of things, i have searched the
    problem in three different languages in google for more results but
    nothing, everytime the same message, so what can we do? i hope i have
    tell all correctly
     
    ricco4, Jul 3, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.