Problem with External DNS

Discussion in 'DNS Server' started by Salvador, Aug 5, 2009.

  1. Salvador

    Salvador Guest

    Hi!!!

    I have a external DNS, where the MX record, A, CNAME, etc. ..

    I have 2 servers on different networks under Windows 2003 St. The area I
    have in the authoritative SRVDNS01 and the secondary server - backup- in
    SRVDNS02.

    If I modify the records of a domain from the console on the SRVDNS01 be
    replicated correctly to SRVDNS02.
    I have the problem that there are domains that I should change about 50
    records with a given IP, and I want to modify all at once, instead of going
    row by row.

    To do this, open the area domain.dns in C:\windows\system32\DNS with
    notepad, replacing the old with the new IP and save the file. I do all this
    with the DNS service stopped, edit and start service.

    No records to replicate SRVDNS02.

    That is my problem and I do not understand why.
    Thank you.
     
    Salvador, Aug 5, 2009
    #1
    1. Advertisements

  2. You should use more CNAMEs instead of multiple Host Records ("A" Records)
    having the same IP#.

    When an IP# changes then you only have to change the one "A" Record of the
    one Host that all the CNAMEs point to. The CNAMEs stay the same.
     
    Phillip Windell, Aug 5, 2009
    #2
    1. Advertisements

  3. Salvador

    Salvador Guest

    Ok, I have to point to CNAME records, but I have too many records A and I
    need to change the IPs for the same. I can not do through the notepad?
     
    Salvador, Aug 5, 2009
    #3
  4. I don't know of any way.
    Maybe other will have ideas.

    --
    Phillip Windell

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------
     
    Phillip Windell, Aug 5, 2009
    #4
  5. When you changed it, did you bump up the version number by at least 1?

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Please reply back to the newsgroup or forum to benefit from collaboration
    among responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MCT, MCTS Exchange, MCSE, MCSA 2003 & 2000, MCSA Messaging
    Microsoft Certified Trainer

    For urgent issues, please contact Microsoft PSS directly. Please check
    http://support.microsoft.com for regional support phone numbers.
     
    Ace Fekay [MCT], Aug 5, 2009
    #5
  6. Salvador

    Salvador Guest

    yes, but the records do not transfer but if the SOA
     
    Salvador, Aug 6, 2009
    #6
  7. Not sure what you mean by "...but if the SOA" - incomplete sentence?

    When you loaded the zone after you changed it, did you see the changed
    records in the GUI? If so, try to make one more change, such as add a record
    (any record), then see if it changes, then transfers.

    Ace
     
    Ace Fekay [MCT], Aug 6, 2009
    #7
  8. Salvador

    Salvador Guest

    Tests

    1 .- Net stop dns
    2 .- Edit records with notepad
    3 .- net start dns
    4 .- In the console Primary DNS are changed
    5 .- any moficicacion in Secundary DNS
    6 .- In the Primary DNS serial number would increase the SOA from the
    console.
    7 .- In the Secundary DNS, that is replicated moficiacion but not the
    records.
    8 .- In the Primary DNS, edit or create a record from the console and is
    replicated to the secondary well.

    Problem can be notepad?
     
    Salvador, Aug 6, 2009
    #8

  9. Hmm, not sure. If you remove the secondary, and re-add the secondary, does
    it work?

    Ace
     
    Ace Fekay [MCT], Aug 6, 2009
    #9
  10. Also I assume that TCP and UDP 53 are both open?

    Ace
     
    Ace Fekay [MCT], Aug 6, 2009
    #10
  11. Salvador

    Salvador Guest

    if the reload works fine, but my question is: Why the changes are not
    replicated with notepad and if the console?.

    It is curious:
    1 .- net stop dns
    2 .- A record edit with notepad
    3 .- net start dns

    In the DNS01 everything OK.
    In the DNS02 is not replicated.

    And I edit a record in DNS01 is replicated in DNS02 at the time, but only
    those MODIFICATIONS in the console, which I modified with notepad are not
    replicated.

    And I edit a record in the replica DNS01 and DNS02 at the time, but only
    those ODIFICATIONS in the console, which I modified with notepad are not
    replicated.
     
    Salvador, Aug 6, 2009
    #11
  12. Salvador

    Salvador Guest

    yes

     
    Salvador, Aug 6, 2009
    #12
  13. After creating and saving the changes in the file, and updating the serial
    number by at least one, (you don't have to restart the DNS service), did you
    go into the console and right-click on the zone, and choose Reload? If so,
    did all the records show up?

    Ace
     
    Ace Fekay [MCT], Aug 7, 2009
    #13
  14. Salvador

    Salvador Guest

    1 .- I edit record (A) and change the IP of another (A)
    2 .- updating the serial number
    3 .- Right-click on the zone, and choose Reload in the DNS01. All records
    OK.
    4 .- After 3hours not updated DNS02 zone.
    5 .- Reload zone from the master and replicate the modified records.

    Should not replicate without the reload from the master ?
     
    Salvador, Aug 7, 2009
    #14
  15. Salvador

    Salvador Guest

    ACE!!!!,
    everything solved!.
    I installed a new server DNS01 with the same names, IPs and reloaded all
    areas.


    1 .- Change an IP record (A), and I think a new serial number and upload the
    zone area in DNS01. with notepad.
    2 .- For the 5 minutes I have replicated to the DNS02

    Do not tell me that happened because the DNS records did not make mistakes.

    Another thing if you do not mind.

    I have this configuration in the DNS:

    primary name server = dns01.domain.com
    responsible mail add = dnsadmin.domain.com
    serial = 2004101852
    refresh = 3600 (1hour)
    retry = 3600 (1hour)
    expire = 1209600 (14 days)
    default TTL = 3600 (1hour)

    TTL for this record: 0:0:15:0 (DDDD:HH.MM.SS)

    Is correct?

    If I want I need to change ISP, follow these steps would change in my ISP's
    the IP of DNS01 and then decrease the default TTL to 15 minutes for example?

    Thanks for your patience
     
    Salvador, Aug 7, 2009
    #15
  16. Cool. Glad you got it working, but I'm still not sure what happened.

    The zone data looks fine. For the TTL, as long as you find a home for your
    servers, I would bump up the TTL to a couple of hours or more. I know some
    bump theirs up to a week or longer. But yes, if you are going to change it,
    I would suggest 5 minutes so any queries will expire out of their local
    cache in 5 minutes so it forces them to query again.

    Ace
     
    Ace Fekay [MCT], Aug 7, 2009
    #16
  17. Salvador

    Salvador Guest

    As would be then?

     
    Salvador, Aug 8, 2009
    #17
  18. Not sure what you're asking. The data looks fine. As I said, bump the TT up
    to something higher. If moving it to another ISP or nameserver, drop it to 5
    minutes or less.

    Ace
     
    Ace Fekay [MCT], Aug 8, 2009
    #18
  19. Salvador

    Salvador Guest

    When you move a Friday to have replicated a Monday, put the following is
    not?

    primary name server = dns01.domain.com
    responsible mail add = dnsadmin.domain.com
    serial = 2004101852
    refresh = 3600 (1hour)
    retry = 3600 (1hour)
    expire = 1209600 (14 days)
    default TTL = 300 (5 min)

    TTL for this record: 0:0:15:0 (DDDD:HH.MM.SS)


    In these times the server will be operational on Monday?.
    We need to change any additional information?
     
    Salvador, Aug 8, 2009
    #19
  20. Yes, that will be fine. Matter of fact, you'll start seeing the change by
    the next morning. They say to allow 48 hours, but it happens much sooner.

    Ace
     
    Ace Fekay [MCT], Aug 8, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.