Problem with Installing Premium Technologies on VM running SBS2003

Discussion in 'Virtual PC' started by John Holmblad, Nov 19, 2004.

  1. I am running Virtual PC 2004 on a Windows XP Pro SP2 system which has 1 gb of
    physical memory & a 3.06 ghz processor. I have installed a virtual machine
    running Windows SBS 2003 Premium Edition with 512mb of virtual RAM. When I go
    to install the SQL server component which is contained on a disk entitled
    "Premium Technologies" by selecdting the menu option "Install SQL Server
    2000" on the autorun menu, the OS gives me the following error message in a
    text box despite the fact that from within the VM I can browse to the file on
    the virtual D drive that is claimed to be missing in the error message below:

    "The selected action could not be performed. Ensure that the Windows Small
    Business Server Premium Technologies is in the drive and try again."

    Now in fact, said CD IS in the drive,Physical drive E on my windows XP PRo
    system, and mapped to virtual drive D in the VM. I am running VM as a "Power
    User", not an Administrator in terms of privelege level. I also tried
    switching my credentials to give me Administrator priveleges but I got the
    same error message. Furthermore if I click on the option to install ISA
    Server 2000 I get the following error message:

    "Setup cannot access the required initialization file
    "D:\ISA\2000\I386\ACMSETUP.EXE".

    Any help on solving this problem would be much appreciated.

    I will add that when I was installing SBS 2003 PE itself, the installation
    of all the SBS components went well except that Exchange Server 2003 failed
    to install. Also, all of the updates from the Microsoft Windows Update site
    installed correctly except for:

    Failed Wednesday, November 17, 2004 Critical Update for Windows Small
    Business Server 2003 (KB832880)
     
    John Holmblad, Nov 19, 2004
    #1
    1. Advertisements

  2. Have you installed Virtual PC SP1?
    --
    Cheers,
    Benjamin Armstrong
    ===============================
    Virtual machine Program Manager

    This posting is provided "AS IS" with no warranties, and confers no rights.
    You assume all risk for your use.
     
    Ben Armstrong [MSFT], Nov 19, 2004
    #2
    1. Advertisements

  3. Ben,

    before I received your response I saw another thread which informed me of
    SP! so I am in fact installing it right now. I will let you know how it works
    out. I will also try to reinstall Exchange Server 2003.
     
    John Holmblad, Nov 19, 2004
    #3
  4. Benjamin,

    after completing the upgraded of Virtual PC to SP1 and then restarting the
    VM with SBS2003 and after installing a Windows Update that had come up, I
    then tried to again run the Premium Technologies CD. This time I got a
    different error as follows:

    --------------------------------------------------------------------------------

    Issue Description:

    SQL Server 2000 SP2 and below is not supported by this version of Windows.

    Any ideas??

    Even after restarting the problem recurred. Could it be that Microsoft
    issued a Premium Technologies disc that is incompatible with Windows SBS 2003?
     
    John Holmblad, Nov 20, 2004
    #4
  5. John Holmblad

    Robert Comer Guest

    SQL Server 2000 SP2 and below is not supported by this version of Windows.
    All that means is that when you actually ran SQL Server 2000, you should be
    running at least SP3. So just continue on with the install, then before
    doing something with SQL Server, install SP3. (or later, I don't remember
    what's current.)

    - Bob Comer
     
    Robert Comer, Nov 20, 2004
    #5
  6. Bob,

    thanks for you help. It is GREATLY appreciated. My overall mission is to
    conduct a lab test of Microsoft Mappoint Location Server/Service and I need
    this VM to work in order to support an instance of SQL server for the MLS
    database!

    In fact the first time I got the message to which I referred in my earlier
    post, I did "click through" but then another error message appeared. I gave
    up for the night and retried it the next morning and I guess the
    PC/XP/VPC/SBS must have felt better after a good night's rest because it
    worked when I retried the click thru and I was able to install SQL 2000 + the
    service pack upgrade. There are still problems with the install of the SBS OS
    because some of the snap-ins are failing and I am not certain how to fix
    them. Is it possible to run a Windows Repair on a VM? Here is the message I
    get when I attempt to run, for example the Domain Security Policy MMC:

    Snap-in failed to initalize.
    Name:<unknown>
    CLSID:{8FC0B734-A0E1-11D1-A7D3-0000F87571E3}


    Any further ideas you have on how to correct this would be appreciated. In
    the meantime I will continue to work with the system as is and, perhaps, try
    to simply install a new instance of the snap-ins that are failing.
     
    John Holmblad, Nov 21, 2004
    #6
  7. John Holmblad

    Robert Comer Guest

    There are still problems with the install of the SBS OS
    Very odd problem. maybe others here have seen this with VPC specifically, or
    maybe you can ask over in the SBS newsgroup, there's some really good people
    over there that know SBS VERY well.
    Most definitely -- you would do it the same as on regular hardware.

    - Bob Comer
     
    Robert Comer, Nov 21, 2004
    #7
  8. John Holmblad

    Scott Baker Guest

    These sorts of problems are not tied to VPC. I would
    check in the SBS newsgroup as Robert suggested.

    Scott
     
    Scott Baker, Nov 22, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.