Problems with background audio - IE7

Discussion in 'Internet Explorer' started by AWA, Dec 17, 2007.

  1. AWA

    AWA Guest

    AWA, Dec 17, 2007
    #1
    1. Advertisements

  2. AWA

    Leonard Grey Guest

    Not me. It's a MIDI-fied version of the theme from Shaft.
     
    Leonard Grey, Dec 17, 2007
    #2
    1. Advertisements

  3. AWA

    AWA Guest

    THANK YOU FOR YOUR help!

    I can not figure out WHY I can no longer hear the embedded music on the
    website and all realted wepages on it. What's even stranger, I am the owner,
    webmaster, designer of this site and it has been working fine for me for 9
    years.

    I am using IE7, Sony Vaio Desktop with Windows XP Media Center Edition, and
    last time I could hear the music on my own webpages was about four days ago.

    This, so far, is the ONLY website I am having problems with! My sound works
    fine on my computer, and I went ahead and ventured to other sites that have
    background midi's on them, and I have no problem.

    SO, can anyone HELP me figure out what spell has been cast?

    Thank you!~
     
    AWA, Dec 17, 2007
    #3
  4. AWA

    JohnMM Guest

    I am having the same problem. Look at this website (not mine):
    http://www.pianoladynancy.com/

    which has bgsound and midi. In my own searching for answers, I discovered
    that if I put the website in the Trusted Zone and additionally turn OFF
    Proected Mode for the Trusted Zone, the background midi music will play!!

    The problem does not exist with bgsound embedded with wav files, just midi.

    Does that help? Any way to FIX this?
     
    JohnMM, Dec 17, 2007
    #4
  5. AWA

    AWA Guest

    I am so glad someone else was having this same identical problem. I tried
    doing what you suggested, but it didn't work. :(
     
    AWA, Dec 17, 2007
    #5
  6. AWA

    JohnMM Guest

    You have to refresh the page after setting the zone to NOT protected mode.
    That way it opens in a new browser window. Or else turn off Protected mode
    for all Zones, and then restart IE7 and re-open the webpage.

    I have been scrounging Google and everywherer looking for a solution for
    about a week now. Very frustrating.

    When I look at the source (Page/View Source) it always looks similar to or
    something like this:

    embed type=application/x-mplayer2
    pluginspage=http://www.microsoft.com/Windows/MediaPlayer/ Name=MediaPlayer
    src=midi/takemyhand.mid AutoStart=True ShowStatusBar=0 HEIGHT=1
    WIDTH=1></embed>
     
    JohnMM, Dec 17, 2007
    #6
  7. AWA

    JohnMM Guest

    I finally solved it (sort-of). Not sure what setting of mine causes the midi
    background sound to not work, but resetting the IE7 settings did it:

    I reset my IE7 settings, by using Tools/Internet Options/Advanced/Reset
    Internet Explorer Settings/apply. Then restarted IE7. I had to then
    re-enable the disabled add-ins (Options/Programs), and restart IE7 again.

    Now I can hear all the nice midi piano background music! Not sure what was
    messed up, but that cured it.
     
    JohnMM, Dec 20, 2007
    #7
  8. AWA

    AWA Guest

    Man, I did that too, but it did not work for me!!!!!! :(
     
    AWA, Dec 24, 2007
    #8
  9. AWA

    JohnMM Guest

    I was comparing the Page/View Source of your web page wtih some others with
    midi background sounds.

    Can you modify yours slightly to something like this:

    <BGSOUND SRC="http://web.tampabay.rr.com/hottoys/shaft.mid" HIDDEN="true"
    LOOP="infinite" AUTOSTART="true">

    and see if that makes a difference. ??
     
    JohnMM, Dec 25, 2007
    #9
  10. AWA

    AWA Guest

    Yes, I can do that in a flash no problem, BUT, I still will not sleep knowing
    that I haven't changed my website in 9 years and I could hear sound 4 weeks
    ago and now all of a sudden I can not. What's stranger is that it appears to
    be only on my website - THOUGH I am sure it is the same on other websites
    also, but, of course, I wouldn't realize it being that I wouldn't know if
    there was sound or not without viewing the source of the page.

    I have NO viruses, malware, spyware - sound works fine on my computer, no
    problems at all. I am betting 99.9% it is IE7. IE7 pisses me off in other
    area's as well - it LOVES to crash when connecting to eBay. It is random, but
    when it happens it freezes my computer. Of course, I can unfreeze it by by
    task manager and ending task on DR. Watson. ONce I do that, it's back up to
    running, though I lose some icons in the right tray, so I end up rebooting
    anyway after I am finished. I usually get the same error code every time, or
    at least in the same location - but, THAT is another story - UNLESS you or
    someone else who happens to read this lights-up with the condition and
    remedy. :)
     
    AWA, Dec 25, 2007
    #10
  11. AWA

    AWA Guest

    Ok, just for the hec of it I tried it your way and still no background music.
    It is aggravating and becoming a Quest from Hell just to foigure out WHAT the
    deal is.

    BTW, I RESET IE7 - ALL OF IT - everything, and still no background sound.

    AARRRRGGGGGGGHHHHHH!
     
    AWA, Dec 25, 2007
    #11
  12. Hi,

    There is only one setting in IE that would determine whether or not your
    MIDI file plays in the Browser:

    Tools||Internet Options||Advanced||Multimedia
    "Play sounds in webpages"

    The corresponding Registry entry for that setting is:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    String Value: Play_Background_Sounds
    Data Values: yes or no

    So if you have "Play sounds in webpages" checked in the Tools||Internet
    Options||Advanced||Multimedia section, and the corresponding Registry Data
    Value at the above key is showing as "yes", then you might want to look in a
    different direction for your problems with MIDI playback.

    Midi playback troubleshooting:
    http://www.microsoft.com/windows/windowsmedia/knowledgecenter/mediaadvice/0067.mspx#EJAAC

    If none of the troubleshooting steps help solve you problem, you might try
    reinstalling the software that came with your Sould card.

    Good luck,

    Donald Anadell
     
    Donald Anadell, Dec 25, 2007
    #12
  13. AWA

    JohnMM Guest

    Since you originaly said that you heard NO sounds ONLY with your webpage
    which you created (9 years ago), here are 3 suggestions:

    1. Create a new test simple webpage based on a webpage that works and that
    you can hear, such as:
    http://www.pianoladynancy.com/
    Use Page/View Source and then copy/paste the html from that webpage into
    your new test webpage. Strip out everything except just a basic webpage with
    BGSOUND and a simple one or two lines of text.
    See if you can hear sounds when you open your new test webpage. Modify it a
    little to include your bgsound link and retry. See if you can detect any
    issues that way.
    2. Or take your own webpage that doesn't work and strip out everything
    except the basic text plus the background sound and retest.
    3. Since you created your html webpage 9 years ago, Microsoft and IE have
    changed a lot in terms of what is allowed (maybe disallowed) in webpage tags.
    Use one of the html verifiers to see if there are any mismatched tags or
    missing periods etc.

    http://validator.w3.org/

    or Search Google for html verify.
     
    JohnMM, Dec 25, 2007
    #13
  14. AWA

    AWA Guest

    AWA, Dec 25, 2007
    #14
  15. AWA

    AWA Guest

    Hey, thanks for that info - I feel like maybe I am getting somewhere. I
    checked the setting and the registry value and all is correct, so now I will
    stop looking at IE7. Thanks for getting me out of that dead end direction.
     
    AWA, Dec 25, 2007
    #15
  16. AWA

    AWA Guest

    Hello again. After going to the link you provided me in your last post, I
    tried playing back alot of midi files on my computer to test the device and
    all midis, including the ones on my webpages play back great! Still stumped.
     
    AWA, Dec 25, 2007
    #16
  17. AWA

    AWA Guest

    I do not have an "OFF" setting, just a "LOW" setting. Tried it again, no
    luck. :(

    (However, left my site in trusted zone with "low" setting enabled)
     
    AWA, Dec 25, 2007
    #17
  18. AWA

    JohnMM Guest

    It sounds nice on my pc (Vista, IE7). Looks like javascript from the
    Page/View Source pasted below. That's different that the other www links I
    previously posted.

    I am curious now if/when you resolve this, so please post if the html
    verifier or testing gives you any clues.

    <SCRIPT LANGUAGE="JavaScript">
    var OPER=navigator.userAgent.indexOf("Opera");
    var MSIE=navigator.userAgent.indexOf("MSIE");
    var NETS=navigator.userAgent.indexOf("Netscape");
    if((MSIE>-1) || (OPER>-1)) {
    document.write("<BGSOUND SRC=holiday-music/angelsoverme.mid LOOP=INFINITE>");
    } else {
    document.write("<EMBED SRC=holiday-music/angelsoverme.mid AUTOSTART=TRUE ");
    document.write("HIDDEN=true VOLUME=100 LOOP=TRUE>");
    }
    </SCRIPT>
     
    JohnMM, Dec 25, 2007
    #18
  19. AWA

    JohnMM Guest

    JohnMM, Dec 26, 2007
    #19
  20. AWA

    AWA Guest

    WHAT? THAT's messed up!!
     
    AWA, Dec 26, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.