Proxy PAC file not working in IE7 B2

Discussion in 'Internet Explorer' started by Peter Bates, Jan 31, 2006.

  1. Peter Bates

    Peter Bates Guest

    I'm trying to use IE7 behind a corporate firewall.

    If a manually set the proxy server IP and port it works correctly.

    If I tell IE7 to use an auto configuration file it behaves as if no proxy is
    set.

    This persists over application restarts.
     
    Peter Bates, Jan 31, 2006
    #1
    1. Advertisements

  2. Peter Bates

    Matt Kershaw Guest

    I'm having the same issue. I set it once, and now I cannot connect to
    anywhere using IE7, or my Outlook 2003 HTTPS connection, etc etc ... no
    matter how many times I restart IE7. I know the proxy is working, though, as
    FireFox works juuuuust fine with the same proxy setting.

    -m-
     
    Matt Kershaw, Feb 1, 2006
    #2
    1. Advertisements

  3. Peter Bates

    Peter Kersen Guest

    Matt, I have the same issue from behind a firewall. Did you find a solution
     
    Peter Kersen, Feb 7, 2006
    #3
  4. Peter Bates

    Peter Kersen Guest

    I have managed to get this to work though the LAN coneection settings (when I
    am in the office). However when I connect remotely (ie from home) using
    dialup, IE7 still uses the LAN settings, not the settings configured in the
    Dialup connection.
     
    Peter Kersen, Feb 16, 2006
    #4

  5. Perhaps you need to play with the proxycfg tool? (e.g. in a cmd window)

    Apparently it helps to redo some of the settings using its options
    even though they may appear to be already set by the GUI. YMMV.


    ---
     
    Robert Aldwinckle, Feb 17, 2006
    #5
  6. Peter Bates

    david Guest

    Yepp,
    I've got the same issue with .pac files. I can also make it happen with
    Firefox (same proxy.pac file). The only information I can add is that if I
    point out the IP-address and port (and don't use the .pac file) it works just
    fine :)

    Obviously there is a bug somewhere around here to be fixed before next
    release.

    -david
     
    david, Feb 20, 2006
    #6
  7. Peter Bates

    Caledai Guest

    Ok.

    I have come across this problem as well.
    I assume your proxy.pac was referenced locally? file://c:\proxy.pac.
    Mine was as well - and because I have over 8 proxies, and 10 network
    locations configured I really needed to get this to work.

    I solved the problem temporilly by putting the proxy.pac at the root
    directory of a web server running locally on my laptop - and referencing it
    in the internet control panel as http://localhost:81/proxy.pac

    Its on port 81 as I am using a lightweight http server (Sami HTTP Server) as
    I didn't want to have my full Apache configuration up and running just to
    host a proxy.pac, and being on a laptop - it affects performance and battery
    life to have a full fledged web server running all the time.

    As soon as I changed this - it worked perfectly..
    Hope this gives you some information to solve this.
    I hope the final release of IE7 corrects this, as it affects other
    applications as well that reference the internet control panel for proxy
    settings.
     
    Caledai, Mar 19, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.