Putting a certificate in the proper place after accidentally puttingit in the wrong place

Discussion in 'Windows Vista Security' started by Morris Cox, Aug 28, 2007.

  1. Morris Cox

    Morris Cox Guest

    We have a network printer and I have enabled security on it. Therefore,
    when I use the web interface or use software (that came with the
    printer) to check for new faxes, it uses a certificate. On two Vista
    Business computers, I accidentally went with the default of using the
    Personal store instead of the only useful store, Trusted Root
    Certification Authorities. Now I can't tell Vista to trust the
    certificate or to reinstall the certificate.

    I've tried using MMC with the Certification (Computer) and Certification
    (Current User) [where is should be] snap-ins and that didn't work. The
    certificate didn't even show up. I tried exporting the certificate from
    another Vista (Enterprise 64-bit) computer and then importing that, but
    no luck.

    How do I re-add or move a certificate that doesn't even show up in the
    list of certificates and that I can only see if I go to the web
    interface or use the printer software that checks for faxes (where I
    specify the printer's IP address)?
     
    Morris Cox, Aug 28, 2007
    #1
    1. Advertisements

  2. Morris Cox

    Haitao Li Guest

    If the certificate you are trying to import is a root or CA certificate,
    then on Vista by default it is saved in "Intermediate Certification
    Authorities" store. If you can find it there, drag & drop to root store. In
    import wizard, you need to select the root store to change the default
    behavior.
     
    Haitao Li, Aug 30, 2007
    #2
    1. Advertisements

  3. Morris Cox

    Morris Cox Guest

    I can not find it in any stores, even with the Find feature. However, if
    I go to the webpage, and choose to View Certificates, then the
    certificate is there.

    Morris Cox

     
    Morris Cox, Aug 30, 2007
    #3
  4. Morris Cox

    Haitao Li Guest

    "View Certificates" doesn't copy the certificate to any of your stores. If
    you want to trust its root certificate, click "Certification Path" tab,
    double click the root node, then click "Install Certificate..." button. On
    Vista, this button is available only if IE is not running in protected mode.

     
    Haitao Li, Aug 31, 2007
    #4
  5. Morris Cox

    Morris Cox Guest

    Thanks for replying again. It is a Vista system. Double clicking on the
    root node under the "Certification Path" tab doesn't do anything. The
    "View Certification" button is grayed out (even when I disabled UAC). I
    even tried running IE7 as admin (via the context menu). No luck.


    Morris Cox
     
    Morris Cox, Aug 31, 2007
    #5
  6. Morris Cox

    Haitao Li Guest

    That means the SSL certificate does not contain a link to its root
    certificate, so certificate viewer cannot find it. You will have to logon to
    the web server machine and export that root certificate, and import it on
    your machine.
     
    Haitao Li, Sep 4, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.