Radeon x1950 PRO AGP 512mb and FEAR Performance

Discussion in 'Windows Vista Games' started by JB, Apr 5, 2007.

  1. JB

    JB Guest

    Hi,

    I was playing FEAR with Windows XP with no noticeable problems, however,
    since installing Vista the game is now unplayable in any outside areas, even
    if I switch everything off or set to minimum and even at 800x600 resolution.
    I probably get 1 frame a second (literally).
    I have updated FEAR to version 1.8, I'm using the latest ATI drivers (7.3).

    I don't appear to have any other problems with other games, COD2 and NFSC
    all play brilliantly at 1680x1050 with all of the eye candy switched on.

    I've got an AMD X2 4200+, 2gig RAM and the X1950PRO.

    There must be some kind of driver / software issue?

    Can anyone help?

    Thanks
    JB
     
    JB, Apr 5, 2007
    #1
    1. Advertisements

  2. Funny enough I was just doing some more testing with FEAR and Vista. In this
    test I have everything set to max setting, Softshadows on, AAx4 ASx16. The
    Test benchmark gives me 54 low, 100 average, 250 High. This is using the Cat
    7.2 drivers. Under XP I get pretty much the same numbers with the 7.3
    drivers. This is with a X1900XTX @1024x768.

    So obviously, you do have an issue. My first question is, what Keyboard and
    Mouse are you using. If it is the Logitech G5/7/15, and I hear one of the
    Saitek keyboards, then you're in for a special treat. As those keyboard and
    mice and partly, their drivers causes problems in FEAR and FEARXP. In my
    case, it caused stuttering and reporting my framrates around 30 fps, even on
    the lowest settings.

    In the FEAR forums I also seem to remember hearing about performance issues,
    when running in a not standard resolution. I want to say 1600x1200 is the
    highest "optimized' resolution.

    I'm amazed you got the 7.3 cats working under Vista, as under both V32 and
    V64, I get a BSOD (which ATI is currently working on a fix for) There is a
    fix that works, in turning off the ATI External Event Service, but when I
    ran the FEAR benchmarks, (even with the 7.2 drivers) it caused about a 20+
    fps drop in FEAR. (didn't check other games yet).

    There is an active thread in the FEAR forums about massive performance drops
    in FEAR and Vista.
    http://forums.vugames.com/thread.jspa?forumID=168&threadID=43967

    The problem isn't limited to ATI or nVidia.
     
    Dale M. White, Apr 5, 2007
    #2
    1. Advertisements

  3. JB

    JB Guest

    Thanks for the reply.

    I have a 'standard' non usb keyboard and a Logitech Laser, MX1000 I think,
    mouse - although I haven't loaded any driver software for it.

    JB
     
    JB, Apr 5, 2007
    #3
  4. JB

    JB Guest

    By the way - with regard to CAT 7.3. I've had no problems at all and they
    have even cured a problem playing Star Wars Lego II that used to BSOD under
    CAT 7.2.
     
    JB, Apr 5, 2007
    #4
  5. JB

    Robert Moir Guest

    You've certainly got something odd going on. I'm running a X1800XT so i'm a
    little way behind you and FEAR runs pretty fine on my Vista installation.
     
    Robert Moir, Apr 6, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.