RDC doesn't work on new hardware .....

Discussion in 'Windows Small Business Server' started by John F Kappler, Mar 27, 2007.

  1. We've recently redeployed (via Swing)!) our SBS 2003 R2 Premium system
    to new hardware and now the fun and games has subsided we're left with
    a problem.......

    RDC wont work. We've run (and re-run) CEICW and RAW, including using
    RAW to disable Remote Acess and then run it again to enable it, but
    still cant RDC into the server.

    The router connected to the NIC is the same as on the old config, as
    it the ADSL line, static ip, the open port settings, etc, so I've
    ruled them out of the equation.

    I've looked the settings on the NICs and can only find two
    differences:

    1) New server has three NICs - We've disabled one ort on the dual
    port card and are using the remaning port as our external NIC. (The
    internal NIC is one built-in to the motherboard).

    2) If I look at Network Connection properties for the external NIC the
    only difference I can see is that Client for Microsoft Networks is
    turned on. All other properties, including TCP/IP settings are the
    same. I've also tried turning off CFMN but that doesn't seem to change
    anything.

    I'm in the fortunate position of being able to bring up screens for
    the old and new servers side by side to check settings, but I've now
    run out of ideas for places to look!

    Help please - we need remote access to get some of our server
    applications working again.

    TIA,

    JohnK
     
    John F Kappler, Mar 27, 2007
    #1
    1. Advertisements

  2. Did you apply Win2k3 sp2 to this server?
     
    Susan Bradley, CPA aka Ebitz - SBS Rocks [MVP], Mar 27, 2007
    #2
    1. Advertisements

  3. Possibly - it rings a bell but I'm not in front of server now to check
    (and cant RDC in!!). Only updates done were MS Update automatics.

    Does it make a difference (I assume it does or your wouldn't have
    asked!)


    Thanks,

    John

    p.s. There's no firewall configuration on the server (its all done at
    the router).
     
    John F Kappler, Mar 27, 2007
    #3
  4. Susan Bradley, CPA aka Ebitz - SBS Rocks [MVP], Mar 28, 2007
    #4
  5. Thanks. So ... If I uninstall SP2, will I get it back? (I know life is
    never that simple, but its orth asking!)

    JK
     
    John F Kappler, Mar 28, 2007
    #5
  6. Just in case anyone else looks in here, the solution is/was:

    It seems that somewhere along the line something had turned on the
    NAT/Basic Firewall!

    Going into Administrative Services, Routing and Remote Access, right-
    clicking on the external Nic, and choosing properties, the check-box
    "enable a basic firewall on this interface" was checked and removing
    this solved the problem.

    (we also fixed it slightly prior to this by going to Services & Ports
    and checking the Remote Desktop option)

    I would have expected the Remote Connection Wizard (or CEICW) to have
    done this, but it seems they dont!
     
    John F Kappler, Mar 29, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.