RDP only allowing one simultaneous RDP connection

Discussion in 'Windows Small Business Server' started by shannon, Jun 20, 2006.

  1. shannon

    shannon Guest

    Since we applied some security updates TS is only allowing 1 simultaneous RDP
    connection. Yesterday it allowed two simultaneous RDP connections. The
    updates we applied were:
    Windows Server 2003 Windows Malicious Software Removal Tool - June 2006
    (KB890830)
    Windows Server 2003 Security Update for Windows Server 2003 (KB918439)
    Windows Server 2003 Cumulative Security Update for Internet Explorer for
    Windows Server 2003 (KB916281)
    Windows Server 2003 Security Update for Windows Server 2003 (KB917953)
    Windows Server 2003 Security Update for Windows Server 2003 (KB914389)
    Windows Server 2003 Security Update for Windows Server 2003 (KB911280)
    Windows Server 2003 Security Update for Windows Server 2003 (KB917344)
    Windows Server 2003 Security Update for Windows Server 2003 (KB917734)

    When I look at the sessions it shows the second one as listening. But when
    someone else tries to connect they now get this message "The remote session
    to the computer was ended by means of an administration tool. Your
    administrator might have ended your connection." Where prior to update
    install if a third person tried to connect it just kicked you off. Any ideas
    would be much appreciated.
     
    shannon, Jun 20, 2006
    #1
    1. Advertisements

  2. Hi Shannon,

    Thanks for posting here.

    From your post, my understanding on this issue is: the Terminal Server only
    allows one RDP connection at one time. If I am off base, please feel free
    to let me know.

    Based on the information I have now, I suggest you try the following steps
    to solve this issue:

    1. Click Start, click Programs, click Administrative Tools, and then click
    Terminal Server Connection Manager.
    2. Double-click the RDP-TCP connection.
    3. Increase the maximum connection count.
    4. Click OK.
    5. Have the user try to connect again.

    If the issue persists, please try to reconnect at a later time, because
    there is connection cache in Terminal Server.

    I hope the above information helps.

    Have a nice day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Jun 21, 2006
    #2
    1. Advertisements

  3. shannon

    shannon Guest

    Thank you for your response Steven. Unfortunately the maximum is 2 where it
    is currently set. You are correct in understanding the problem. Server is
    only letting 1 TS-RDP connection simultaneously. Any other suggestions would
    be appreciated. TIA Shannon
     
    shannon, Jun 21, 2006
    #3
  4. Hi Shannon,

    Thanks for taking time to respond.

    Based on your description, Please help me collect the following information
    in order to narrow down this issue:

    1. Please let me know whether the all of workstations cannot connect to the
    Terminal Server. If not, please restart the specific workstation with clean
    boot, to do so:

    a. Click Start, click Run, type "msconfig" (without the quotation marks) in
    the Open box, and then click OK.
    b. In the Startup tab, click the "Disable All" button.
    c. In the Services tab, check the "Hide All Microsoft Services" checkbox,
    and then click the "Disable All" button.
    d. Click OK and restart your computer.

    2. please temporary uninstall some security updates and test whether this
    issue disappear?

    Please let me know the result above so that I can provide the further
    assistance on this issue. I am looking forward to your reply.

    Have a good day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Jun 22, 2006
    #4
  5. shannon

    shannon Guest

    Dear Steven,

    Thank you for the advice. It is numerous workstations. It must have been
    some of the winserver 2003 seucrity updates cause it is doing it to both
    winserver 2003 machines. I guess I will try to unstall some and see.
     
    shannon, Jul 10, 2006
    #5
  6. Hi Shannon,

    Thanks for taking time to respond.

    Please capture the screenshot of the error message when you connect the
    terminal server and send it to me at: .

    Also, please restart the workstation with clean boot, to do so:

    a. Click Start, click Run, type "msconfig" (without the quotation marks) in
    the Open box, and then click OK.
    b. In the Startup tab, click the "Disable All" button.
    c. In the Services tab, check the "Hide All Microsoft Services" checkbox,
    and then click the "Disable All" button.
    d. Click OK and restart your computer.

    Please let me know the result above so that I can provide the further
    assistance on this issue. I am looking forward to your reply.

    Have a nice day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Jul 11, 2006
    #6
  7. shannon

    shannon Guest

    Well I only installed a few updates that might not have been pertinent but
    the others are relevant security patches. There is no error message per say
    but the servers use to let us log in to both TS sessions with the same
    account. (Up until I installed those updates) It will let us use both
    logins with different accounts. It’s better practice to use separate
    accounts anyway.
     
    shannon, Jul 26, 2006
    #7
  8. shannon

    shannon Guest

    I mean uninstalled a few
     
    shannon, Jul 26, 2006
    #8
  9. Hi Shannon,

    Thanks for your update.

    From your description, I understand that you can use the same user account
    to logon the Terminal Server, but you cannot login TS with different
    accounts.

    First at all, please let me know whether you use the Terminal server in SBS
    with remote admin mode. If so, in this mode, you only have two connections
    to connect to Terminal Server.

    Hope the above info helps.

    Have a good day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Jul 27, 2006
    #9
  10. shannon

    shannon Guest

    No we were both logging in to TS with the same account at the same time.
    This use to work now it automatically kicks the logged in user off.

    Yes we are using Terminial server in SBS. Yes I am aware you can only have
    two. We use to be able to have two logged in to any server with the same
    account at the same time and now only one can login.
     
    shannon, Jul 31, 2006
    #10
  11. Hi,

    Thanks for your reply.

    To trouble shoot this problem efficiently, let us perform the following
    steps to disable this setting on the terminal server to test whether this
    problem continues:

    1. Click Start -> Run, type "tscc.msc" in the text box, and click OK.
    2. Click "Server Settings".
    3. Locate the "Restrict each user to one session" item, and set it to "No".
    4. Restart the server to test.

    Please also ensure that the following group policy is not configured on the
    terminal server or any other container that the terminal server belongs to:

    [Computer Configuration->Administrative Templates->Windows Components ->
    Terminal Services -> restrict terminal service users to a single remote
    session]

    Does it work now?

    Please let me know the result. Thanks and have a nice day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Aug 1, 2006
    #11
  12. shannon

    shannon Guest

    Hi Steve
    Thanks for the response.

    1. The Restrict each user to one session item, was already set to "No".
    2. The GPO restrict terminal service users to a single remote session was
    set to not configured. I changed it to disabled. I can’t reboot until after
    hrs but will try again after the policy refresh.

    Thanks Shannon
     
    shannon, Aug 1, 2006
    #12
  13. Hi Shannon,

    Thanks for your reply.

    please help me collect some information so that I can perform further
    research on this issue:

    1. Does this problem happen for a specific user or some specific versions
    of client OSs?
    2. Please perform the following steps to collect the MPSReport of the
    terminal server:

    - Download the MPSRPT_SETUPPerf.EXE file from the following website:

    http://www.microsoft.com/downloads/details.aspx?FamilyId=CEBF3C7C-7CA5-408F-
    88B7-F9C79B7306C0&displaylang=en

    - Double-click to run the MPSRPT_SETUPPerf.EXE file and wait for it to
    complete.
    - Send me the .cab file generated in the following folder:
    systemroot%\MPSReports\Setup\<Report Type>\Cab

    My email address is . You can send the MPSReport to
    my email address directly. I look forward to hearing from you again.

    Have a nice day!

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Aug 2, 2006
    #13
  14. shannon

    shannon Guest

    1. Yes we are all trying to login to the server from XP pro sp2 machines
    with the same account.
    2. I will peform the test on one of the servers and email the results to
    you asn soon as I can.

    Thanks
    Shannon
     
    shannon, Aug 2, 2006
    #14
  15. Hi Shannon,

    Thank you for keeping in touch. I will waiting for your reply and if you
    have any technical questions in the future, please don't hesitate to let us
    know. It's always our pleasure to be of assistance.

    Have a great day.

    Best Regards,

    Steven Zhu
    MCSE
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    ======================================================
    PLEASE NOTE the newsgroup SECURE CODE and PASSWORD were
    updated on February 14, 2006.? Please complete a re-registration process
    by entering the secure code mmpng06 when prompted. Once you have
    entered the secure code mmpng06, you will be able to update your profile
    and access the partner newsgroups.
    ======================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from this issue.
    ======================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ======================================================
     
    Steven Zhu [MSFT], Aug 3, 2006
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.