Read-only Flags as Owner

Discussion in 'Windows Vista File Management' started by jcuk, Mar 19, 2008.

  1. jcuk

    jcuk Guest

    Hi

    I designed my own directory structure in windows xp and used it as
    template for software and file management on vista. (seems to have bee
    a big mistake

    Currently i have all my games installed just on a Games folder, create
    by me in the Program-Files folder

    Steam needs to write its own config file for any edits i make, Howeve
    when trying to do this is just reverts back to prior settings. (As wit
    other games

    I tried removing the read-only flag from the attributes looked like i
    had done, closed and re-opened window and sure enough its back again

    NB : im logged onto a user account, set in Administrators Group
    created by myself.

    I then tried Security > Advanced > Owner > Edit to change from SYSTE
    to Jamie (my username

    After that, i also went to Security > Edit (To Change Permissions)
    Add - Added Jamie as a user and set to full control

    However still i cannot change from Read-only for all subfolders also

    So to save me the hassle, as i never seem to get malicious softwar
    anyway... how do i disable this whole, lets be safe and wear a condo
    crap that microsoft have put into this somewhat good but REALL
    annoyingwhenitdoesntwork operating system.

    Im Running Windows Vista Ultimate x64

    Thanks
    Jami
     
    jcuk, Mar 19, 2008
    #1
    1. Advertisements

  2. jcuk

    dmex Guest

    Place the games outside the ProgramFiles directory (c:\Games) as UA
    protects anything located inside the ProgramFiles, UAC will redirect al
    files and registry keys used by any game or program not launched wit
    admin rights.

    Steam is one exception its completely vista capable as it installs it
    own service to manage UAC or required system-privileges, My other game
    CoD4, BF2, BF2142, World in Conflict, Unreal 3, GTASA........ are no
    vista aware but run perfectly fine because they are not under UAC`
    control in the program files directory, If your still having problem
    use the compatibility tab under properties to set them to run a
    administrator it should let them read/write to the locations the
    normally use without Vista`s security getting in the way
     
    dmex, Mar 19, 2008
    #2
    1. Advertisements

  3. jcuk

    jcuk Guest

    UAC is disabled - the location is alread C:\Games\Steam.

    Ive tried also running as administrator. (running explorer.exe a
    administrator
     
    jcuk, Mar 19, 2008
    #3
  4. jcuk

    Bob F. Guest

    Our goal is to solve technical and operational problems by using this
    newsgroup as a collective forum.
    Please include enough of the previous message(s) so that others trying to
    follow this thread know what you are talking about. Also please try to
    "edit out" the non relevant portions. It helps everyone. If you are using
    Windows Mail, Go to:
    Tools > Options > Send > check - "Include message in reply"
     
    Bob F., Mar 19, 2008
    #4
  5. jcuk

    Kerry Brown Guest

    It is normal for folders to show as Read Only. This doesn't affect the files
    in the folder.

    http://support.microsoft.com/kb/326549

    It sounds like you are running into a permissions problem not an attribute
    problem. Can you post the full path to the folder?
     
    Kerry Brown, Mar 19, 2008
    #5
  6. jcuk

    jcuk Guest

    kerry, thanks.

    However ive decided to give into the extreme power that is vista and
    somehow it has infact let me now cut my C:\Games folder and paste into
    C:\Users\Myusernamefolder
     
    jcuk, Mar 19, 2008
    #6
  7. jcuk

    dmex Guest

    dmex, Mar 20, 2008
    #7
  8. jcuk

    Kerry Brown Guest


    Part of the problem may have been caused by UAC being disabled. If you try
    to change NTFS permissions from the GUI (Windows Explorer) with UAC disabled
    it may not always work and you won't get any indication that it failed. This
    is because Explorer is Vista aware and expects to be elevated for certain
    tasks. With UAC disabled the elevation never takes place. To get consistent
    results when changing NTFS permissions with UAC disabled you have to do it
    from a command prompt with the icacls command.
     
    Kerry Brown, Mar 20, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.