Register this connection's addresses in DNS Behavoir in Windows 2008

Discussion in 'Windows Server' started by Brad Baker, Jun 4, 2009.

  1. Brad Baker

    Brad Baker Guest

    In prior versions of windows (Windows 2000/2003 for instance) checking
    "Register this connection's addresses in DNS" (on a particular NIC's TCP/IP
    properties) only registered the primary/first NIC ip address in DNS.

    In Windows 2008 checking "Register this connection's addresses in DNS" seems
    to result in ALL NIC ip addresses being automatically registered in DNS.

    This new behavior is undesirable as we have windows services that bind to
    specific ip addresses and with multiple DNS records registered, dns lookups
    don't always result in the correct IP address being returned.

    We could turn off "Register this connection's addresses in DNS" and manually
    establish records for each server but that's not an ideal solution. Is there
    some way to revert the behavior back to the way it was in older versions of
    windows?

    Thanks!
    Brad
     
    Brad Baker, Jun 4, 2009
    #1
    1. Advertisements

  2. Brad Baker

    bhaley445

    Joined:
    Sep 20, 2011
    Messages:
    1
    Likes Received:
    0
    Disabling additional NIC DNS registrations

    Issue: Windows 2008 with multiple network adapters. For one adapter you want it to automatically register itself with DNS. For additional adapters you do not want it to register.

    Solution: In our environment simply going into the advanced IP properties -> DNS tab for the 2nd NIC and unchecking "Register this connection's addresses in DNS" worked under Windows 2003. But for Windows 2008 it did not. Here's what worked for me with Windows 2008:

    1. Make sure "Register this connection's addresses" is already unchecked first and leave it unchecked.
    2. Delete the 2nd DNS entry from your DNS server.
    3. Go back to the original server (the one with multiple NICs) and run: ipconfig /registerdns

    I've rebooted and we've had success for over a week. No 2nd entry is showing up in our DNS server. (FYI, our DNS server is still Windows 2003.) It seems like there's a Windows 2008 bug with that particular setting. Running ipconfig /registerdns seemed to shock it into proper operation.
     
    bhaley445, Sep 20, 2011
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.