reinstall defender

Discussion in 'Windows Vista Security' started by attiks, Feb 1, 2007.

  1. attiks

    attiks Guest

    hello,

    i uninstalled windows defender from my vista business, i tried reinstalling
    it but it got the message that it's part of vista and hence i can not install
    it, tried looking for a repair but couldn't find anything.

    any ideas?
     
    attiks, Feb 1, 2007
    #1
    1. Advertisements

  2. How did you uninstall it?

    Have you looked into OCSetup, if it is an ospackage you should be able to
    use this to add features.


    josh
     
    Josh Phillips, Feb 1, 2007
    #2
    1. Advertisements

  3. attiks

    attiks Guest

    Josh,

    I did the uninstall using add/remove programs

    I tried running ocsetup "defender" and ocsetup "windows defender" but no luck
     
    attiks, Feb 1, 2007
    #3
  4. attiks

    Mike Guest

    I did the exact same thing, but am not able to re-install it. I tried to
    download it again from Microsoft, but when you try to install it, it stops
    and says that because Windows if part of VISTA you do not need to download
    it...
     
    Mike, Feb 1, 2007
    #4
  5. attiks

    The Fallen Guest

    To restore defender I had to reinstall Vista:/ I wasnt able to install it in
    any other way.

    The Fallen One
     
    The Fallen, Feb 2, 2007
    #5
  6. attiks

    raebgib Guest

    Guys,

    I had a friendly "MS Tech at India" remove it as he tried to help fix
    another problem and left it uninstalled. I would like to know how to
    re-installed it.

    Appreciate some advice....
     
    raebgib, Feb 2, 2007
    #6
  7. attiks

    BobC Guest

    try this:
    Go to control panel,administrative tools,then services.find "windows
    defender" ,then click and "start the service"
    regards
     
    BobC, Feb 3, 2007
    #7
  8. attiks

    raebgib Guest

    BobC

    It did not work. There were no services with this name. I also tried Josh
    method - no luck. I downloaded the file, but Vista installer blocks it as it
    should be built. Any other ideas?

    Thanks in advance.
     
    raebgib, Feb 3, 2007
    #8
  9. attiks

    erobishaw Guest

    I've got the same issue:

    XP Pro upgraded to Vista Business.
    Had problems with Defender.
    Uninstalled using Add/Remove Programs
    Cannot Reinstall Defender as the Setup program says "Vista has
    Defender built in, you do not need to run this" or something like
    that.
    Any ideas out there?
     
    erobishaw, Feb 3, 2007
    #9
  10. attiks

    BobC Guest

    Open a command prompt as administrator,
    type servises.msc
    You will see DEFENDER on the list of services.click and select "start".
     
    BobC, Feb 4, 2007
    #10
  11. attiks

    BobC Guest

     
    BobC, Feb 4, 2007
    #11
  12. attiks

    Jessec1978 Guest

    I also uninstalled Windows defender after my new version of live one-care
    deactivated it and stated defender was now a part of one care. But i have
    lost all the other parts of defender that one care does not provide and am
    having same reinstall issues as you guys. Any help here would be appreciated
    I really dont wont to reinstall vista. Im sure the guys at one-care are
    working on this but id like to have my defender back. Thanks
     
    Jessec1978, Feb 9, 2007
    #12
  13. attiks

    BobC Guest

    To my knowledge,Windows Defender" cannot be uininstalled,if it were I would
    do it <g>
    Go to control panel,"Adminstrative tools',then services,down the list of
    services,you will find "Windows Defender" click and select "START".
     
    BobC, Feb 9, 2007
    #13
  14. attiks

    attiks Guest

    BobC,

    I hate to disagree, but I was able to uninstall it using add/remove
    software, I also opened a request with tech support but for the moment
    to no avail, they suggested sfc /scannow but it didn't detect any
    problems, afterwards they asked me to regsvr32 a couple of dll's, half
    of them are missing but I didn't get any solution.

    List of dll's:
    wuapi.dll: OK
    wuaueng.dll was loaded but call failed
    wucltui.dll failed to load, module could not be found
    wups.dll: ok
    wuweb.dll failed to load, module could not be found
    atl.dll was loaded but error 0x8002801c
    softpub.dll: ok
    wintrust.dll loaded, but error 0x80070005
    initpki.dll failed to load, not found
    mssip32.dll: ok
     
    attiks, Feb 14, 2007
    #14
  15. attiks

    rramis Guest

    Has anyone been able to solve this issue? I am having exactly the same
    problem...
     
    rramis, Feb 26, 2007
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.