Remote Desktop Administration

Discussion in 'Server Networking' started by Ken Lizotte, Aug 27, 2005.

  1. Ken Lizotte

    Ken Lizotte Guest

    I would like to use remote desktop from my XP workstation to my 2003 server.
    On the server, I have gone to control panel/system/remote and checked "Allow
    users to connect remotely to this computer". I went to "Select Remote Users"
    and it said my user name already had access, but I added my user anyway.

    At the XP workstation, when I run remotr desktop and click the domain, I get
    a message "Domain does not contain any terminal servers"

    I started to install Terminal Server on the server, but saw a message that
    said"do not install terminal server if you only wanr remote desktop for
    administration"

    Can someone tell me what I may be doing wrong?
    Thanks, Ken
     
    Ken Lizotte, Aug 27, 2005
    #1
    1. Advertisements

  2. Ken Lizotte

    Guest Guest

    ignore the warning and put the name or ip address of the server. by default
    if its not a TRUE terminal server youll get that warning. however you dont
    get that warning with the remote desktop client that i know of... only with
    the remote DESKTOPS client thats part of the admin pack
     
    Guest, Aug 27, 2005
    #2
    1. Advertisements

  3. When you open Remote Desktop Connection, what happens if you type the IP
    address of the server and click Connect?

    Doug Sherman
    MCSE, MCSA, MCP+I, MVP
     
    Doug Sherman [MVP], Aug 27, 2005
    #3
  4. Ken Lizotte

    Ken Lizotte Guest

    I tried entering server name and ip address and got message "client could not
    connect to the remote computer..."

    I am running Symnantec Client firewall. Could this be a problem? I have
    disabled client firewall, but still no connection.
     
    Ken Lizotte, Aug 27, 2005
    #4
  5. Ken Lizotte

    Ken Lizotte Guest

    I tried entering server name and ip address and got message "client could not
    connect to the remote computer..."

    I can ping the ip address and the server name so network is good.
     
    Ken Lizotte, Aug 27, 2005
    #5
  6. If there is a firewall on the server, you need to open port 3389.

    Doug Sherman
    MCSE, MCSA, MCP+I, MVP
     
    Doug Sherman [MVP], Aug 27, 2005
    #6
  7. Ken Lizotte

    Ken Lizotte Guest

    I have just tried to go the other direction, from the server to my
    workstation and this works fine.
     
    Ken Lizotte, Aug 27, 2005
    #7
  8. Ken Lizotte

    Ken Lizotte Guest

    Doug,
    Please be patient. I am a bit confused.

    I had bought Symantec Client Security thinking that it would provide
    firewall and antivirus for server and clients, and I know that it scans
    workstations and server for viruses nightly. When I went to server to open
    port 3389, I could not find any way to "see" the firewall on the server so
    I'm thinking that it does not provide firewall for the server (I will pursue
    this issue with Symantec)

    So..as I was looking around on the server, I saw that Windows Firewall was
    off. I turned it on and I found that I still could browse the internet from
    the server but no longer from my workststion.

    1-assuming I am using Windows firewall only, how do I open port 3389?
    2-assuming I am using Windows firewall only, how do I allow internet access
    to workstations?
     
    Ken Lizotte, Aug 27, 2005
    #8
  9. Running a firewall on your server should have no effect on client Internet
    access unless the server is providing Internet access via ICS, RRAS/NAT, or
    a proxy server. If you have two network adapters in the server, you should
    either not run a firewall on the LAN or be prepared to open multiple ports.
    In order to provide Internet access to clients with a 2 NIC server, you
    would have to at least open port 53. For the pre-Service Pack 1 firewall,
    see:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;317530

    The SP 1 firewall is essentially the same as Windows XP SP 2.

    I recommend that you turn off the firewall on the LAN NIC, uninstall Norton
    and see if Remote Desktop/Internet works. If it does, you can then attempt
    to install or configure firewall/security as needed.

    Doug Sherman
    MCSE, MCSA, MCP+I, MVP
     
    Doug Sherman [MVP], Aug 27, 2005
    #9
  10. Ken Lizotte

    Joe Guest

    Ken,

    Can you type the public IP of your server and get to the desktop from your
    XP machine?

    e.g open up remote desktop connection app and type the public IP of your
    server and see what you get now make sure 3389 is open in a router if you
    have one.

    Let me know
    Joe
     
    Joe, Aug 29, 2005
    #10
  11. Ken Lizotte

    Ken Lizotte Guest

    Joe,

    I don't have a public IP. This is a really small network, 1 2003 server w/
    5 XP workstations. I am using 192.168.100.XXX as my network. I have tried
    turning off the firewall on the server and the workstation.

    As I wrote earlier, I can remote from the server to the workstation, but not
    the other way. I have tried entering the server name(dc1) as well as the
    IP(192.168.100.11), but no luck.

    All other network comms between server/workstation are fine (browse, ping
    IP, Ping name).

    I'm stuck. This should be a no-brainer.

    Ken
     
    Ken Lizotte, Aug 31, 2005
    #11
  12. Ken Lizotte

    Joe Guest

    Hello Ken so you say this is the only machine that is doing it?

    Is ther anything on this machine in the event viewer or the server?
     
    Joe, Sep 1, 2005
    #12
  13. Ken Lizotte

    Ken Lizotte Guest

    I found the problem...

    On the server, i had to go to services and turn on Terminal services. It was
    disabled and after I started it, I could connect from the workstation. It is
    now set as automatic.

    One question, why was it disabled by default?
     
    Ken Lizotte, Sep 1, 2005
    #13
  14. Ken Lizotte

    Todd J Heron Guest

    It is Automatic by default. Had to have been some admin on your network
    which did that at some point.

    --
    Todd J Heron, MCSE
    Windows Server 2003/2000/NT; CCA
    ----------------------------------------------------------------------------
    This posting is provided "as is" with no warranties and confers no rights

    I found the problem...

    On the server, i had to go to services and turn on Terminal services. It was
    disabled and after I started it, I could connect from the workstation. It
    is
    now set as automatic.

    One question, why was it disabled by default?
     
    Todd J Heron, Sep 2, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.