Remote Web Workplace Partially Works

Discussion in 'Windows Small Business Server' started by Gary Cee, Feb 3, 2005.

  1. Gary Cee

    Gary Cee Guest

    I am using SBS 2003 in my office and am trying to connect from home to the
    SBS network using Remote Web Workplace. Home machine has WinXP Media Center
    Edition (with SP2). I can connect to SBS using http:/xxx.xxx.xx.x /remote
    (where x's are static IP address on my office cable modem and can logon
    successfully. The server and workstation names show up correctly when I
    select Connect to Server Desktops or Connect to Workstation Desktops but I
    can't actually connect. I receive the following message:

    "The client could not connect to the remote computer. Remote connections
    might not be enabled or the computer might be too bust to accept new
    connections. It is also possible that network problems are preventing your
    connection please try connecting again later. If the problem continues to
    occur, contact your administrator."

    I've re-done the Web Workplace at the server several times but the problem
    persists. The home machine has the Windows firewall enabled. My home
    Internet connection is via a Linksys router. Disabling the Windows and
    router firewalls did not solve the problem. Likewise for reducing the
    security settings in IE.

    Home machine is running MS Office 2003 and I am using Outlook 2003. OWA
    works partially. Can see and delete my email on the server but can't send or
    reply to messages.

    Any body know why the problem is occurring and how to resolve?

    Thanks.
     
    Gary Cee, Feb 3, 2005
    #1
    1. Advertisements

  2. Hi Gary,

    This can be caused by several things.

    a) port 4125 TCP not being open/forwarded to the sbs.
    b) no user permissions on the computer(s) you're connecting to.
    c) remote connections not enabled on the workstation(s) - but should be set
    if you used the add computer wizard and /connectcomputer when setting up the
    workstation.

    How about if you log in to RWW as an administrator, can you connect to the
    server desktop ? If you can't get there either, it's likely the port issue.
     
    Les Connor [SBS Community Member - SBS MVP], Feb 3, 2005
    #2
    1. Advertisements

  3. Hi Gary,

    Couple other t-shooting ideas.

    Are you able to connect via RDP from inside the office LAN okay to the
    server and local XP computers?

    Have you attempted to log in to the server from your house using RDP
    directly? To try it go to Start - Run - then type mstsc.exe and place the
    static IP address of your office connection in the "computer" window of the
    Remote Desktop Client.

    Steve

    Steven Banks [SBS MVP]
    Banks Consulting Northwest Inc.
    http://www.banksnw.com

     
    Steven Banks [SBS MVP], Feb 3, 2005
    #3
  4. Gary Cee

    Gary Cee Guest

    Les,

    Responses to your questions:

    a) I opened port 4125 on the SBS server following the guidance of KB article
    828053
    b) User permissions are set on the computers I'm trying to connect to.
    c) Remote connection should be enabled on the wotkstations as I did use the
    wizard.

    I've logged in as Administrator and still can't connect to desktops.

    I made a Remote Connection Disk from the Server Management snap in and tried
    again to get the home machine to connect to network desktops - still no luck.
    The problem continues.

    Any more suggestions?

    Thanks.


     
    Gary Cee, Feb 4, 2005
    #4
  5. Gary Cee

    Gary Cee Guest

    Steven,

    I can connect to other computers from inside the office LAN

    I cannot log into the server from home using RDP.

    So I'm still stuck. Other attempts failed as well. Pls see my responses to
    Les.

    Thanks.



     
    Gary Cee, Feb 4, 2005
    #5
  6. Hi Gary,

    That KB probably doesn't apply, as your remote computer (the one at home)
    isn't behind ISA. The remote connection disk is for a VPN connection and
    that would just complicate things at this point.

    ** Do you have ISA server installed on your SBS, and does your SBS have two
    nics and a router? If not, please specify your configuration and topology.

    Assuming two nics and a router (with or without ISA)

    Run the Connect to the Internet Wizard on the SBS computer, making sure you
    select Remote Web Workplace in the web services configuration screen.

    Make sure you have port 4125 forwarded from your public IP address to the
    external IP address of your SBS (this is a router configuration).

    Try RWW again.

    Here are the horses mouth troubleshooting steps for SBS Standard (no ISA):

    .. Open Server Management and navigate to the Routing and Remote Access
    snap-in.

    .. Right-click NAT/Basic Firewall under IP Routing and select Properties.

    .. Click Services and Ports.

    .. Verify Remote Web Workplace is listed. If not, you can run CEICW to
    publish RWW, or you can

    manually open TCP port 4125 at RRAS.

    .. Verify TCP port 4125 is open at your hardware router or firewall.


    --
    Les Connor [SBS Community Member - SBS MVP]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member - SBS MVP], Feb 4, 2005
    #6
  7. Here's one of the more bizarre reasons why 4125 might not be available. I've
    seen Exchange take over ports in SBS2k, but not in SBS2k3. This KB says it
    can happen:

    http://support.microsoft.com/?id=886209

    Here's another one I haven't experienced.

    <snip>
    Windows XP SP2 has a pop-up blocker which may block the Web RDP session. In
    Internet Explorer on the workstation you are connecting from, go to Tools,
    Internet Options, then click on the Privacy tab, remove the check for Block
    pop-ups. Close and reopen IE and check if you can connect now. If you have
    third party popup blocking software installed, disable it.


    --
    Les Connor [SBS Community Member - SBS MVP]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member - SBS MVP], Feb 4, 2005
    #7
  8. Gary Cee

    Gary Cee Guest

    Les,

    Thanks for the prompt response. I'll try what you say when back in the
    office tomorrow.

    Server/network configuration info.:

    ISA is installed on the SBS server.
    The SBS server has two NICs
    There is no router
    Cable modem has static IP & second NIC is set to the modem static IPs.
    Second NIC connected directly to cable modem (via x-over cable)
    All computers connect through 10/100 Mbps switch

    I selected Remote Web Service when I ran the Internet Wizard

    I suspected the KB might not be applicable for the reason you stated and
    ditto for the Remote Connection Disk but I was looking for straws to grasp
    at. Thanks again for your input.

     
    Gary Cee, Feb 4, 2005
    #8
  9. With ISA installed in integrated mode (the default), RRAS won't be an issue
    so don't bother looking in there for the filter for port 4125. One would
    look in ISA packet filters instead, and ensure the filter is correct and
    enabled.

    If you suspect ISA, then you can look in the packet filter logs and see if
    4125 is logged as blocked.

    We'll see what you can find tomorrow.

    --
    Les Connor [SBS Community Member - SBS MVP]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member - SBS MVP], Feb 4, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.