Remote webspace logging off.

Discussion in 'Windows Small Business Server' started by Nick, Sep 14, 2007.

  1. Nick

    Nick Guest

    Could someone please advise me on why people are logged out of their remote
    workspaces. We have multiple sites connecting via a VPN to a server. Some of
    the people are complaining that they are logged out of their online diaries
    after a certain amount of time. Is it simply a matter of changing a setting
    to keep them logged on. It's strange because we have not changed any
    settings, and only some people are logged off, whereas others stay connected.
    Help someone!!!
     
    Nick, Sep 14, 2007
    #1
    1. Advertisements

  2. Like Cris Said you are talking Apples and Oranges.
    -------------------------------------------------------------------
    On VPN Before Connection on each user go to "Properties"
    Default is 10 Min time out. (Have User Increase to 20mins)
    I don't recommend very long on this 20min IMO is about the Max it should
    be.
    -------------------------------------------------------------------

    On RWW.

    Global RWW Time out Settings on the SBS 2003 server are here!

    The time out values (in minutes) are configured in the registry, at:

    HKLM\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\PublicTimeOut

    HKLM\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\TrustedTimeOut

    The PublicTimeOut is used when the user checks the box for "I'm using a
    public or shared computer" on the RWW logon page.

    The TrustedTimeOut is used when the user unchecks this checkbox.
    By default,

    PublicTimeOut is 20
    TrustedTimeOut is 120

    Russ

    --

    Russell Grover
    Microsoft Certified Gold Partner
    Microsoft Certified Small Business Specialist.
    MCP, MCPS, MCNPS, (MCP-SBS)
    Remote SBS2003 Support
    http://www.SBITS.Biz
     
    Russ Grover \(SBITS.Biz\), Sep 16, 2007
    #2
    1. Advertisements

  3. Hello Nick,

    Thank you for posting here. Let's thank Russ for the input.

    According to your description, I understand that on RWW users will log out
    their session after a certain amount of time. If I have misunderstood the
    problem, please don't hesitate to let me know.

    Based on my research, I suggest we try the following steps to see if we can
    resolve this issue:

    Please check the following settings:

    I. TSweb timeout
    ====================
    1. Make a copy of the C:\InetPub\Remote\tsweb.aspx file in the event you
    need to revert quickly.
    2. Edit tsweb.aspx with notepad.
    3. Search for "MsRdpClient.AdvancedSettings2.MinutesToIdleTimeout" (without
    the quotation marks) with a value of "= <%=rapLinks.timeoutSeconds
    / 120%>. Change the value to the actual time out or no more than 240 as
    testing with values over 240 result in the connection failure.
    4. Save the changes in the file and exit notepad.
    5. Restart the IIS Service or restart the SBS Server.

    II. Remote Web Workplace timeout:
    ======================
    The time out values (in minutes) are configurable in the registry, at:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\P
    ublicTimeOut
    REG_DWORD: 20 (Default)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\T
    rustedTimeOut
    REG_DWORD: 120 (Default)

    The PublicTimeOut is used when the user checks the box for "I'm using a
    public or shared computer" on the RWW logon page. The TrustedTimeOut is
    used when the user unchecks this checkbox. You can change the time out
    settings here.

    III. ASP.NET timeout
    ======================
    Edit the C:\inetpub\remote\web.config file.
    Look for line:
    <forms name="RemotePortalAuth" loginurl="logon.aspx" protection="All"
    path="/" timeout="120" />
    timeout = value in minutes of your largest timeout value.

    The default timeout in SBS 2003 is 120 minutes.

    IV. IIS timeout:
    =======================
    1. Go to Server Management -> Advanced Management -> Internet Information
    Server.
    2. Expand [Server Name] -> Web Sites -> Default Web Site.
    3. Right click Remote and choose Properties, in Virtual Directory tab,
    click the Configuration button and select the Options tab, modify the
    session timeout settings. The Default Session timeout in SBS 2003 is 120
    minutes.

    V. ISP timeout:
    =======================
    The ISP may have some session timeout settings, please contact your ISP to
    check it.

    VI. Router timeout:
    ========================
    As I know, some router or ADSL modem will have session timeout
    configuration options, please try to contact your hardware vendor to check
    it.

    VII. VPN connection timeout:
    =======================
    How do you setup the VPN connection between remote clients and SBS? Please
    check the timeout setting of your VPN connection.

    If we cannot resolve the issue after we perform the above steps, please
    help me collect some information for further investigation:

    1. Please try to access the RWW from SBS itself, then test this issue.

    2. Does the disconnection happen after a while of idle time?

    3. Do you get any error when the session logoff?

    4. Gather MPS network report on SBS:

    a. Download MPSrepot_network from
    http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
    15706/MPSRPT_NETWORK.EXE

    b. Run MPSRPT_NETWORK.exe on the server box.

    c. The tool will automatically collect the information. This procedure will
    take 10~15 minutes.

    d. Open Windows Explorer, navigate to the folder:
    %SystemRoot%\MPSReports\Network\Reports\Cab\

    e. Send the .cab file directly to me at

    Hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | Thread-Topic: Remote webspace logging off.
    | thread-index: Acf21raDpFDnMS+1Qru5FSnZsodn5w==
    | X-WBNR-Posting-Host: 207.46.19.168
    | From: =?Utf-8?B?Tmljaw==?= <>
    | Subject: Remote webspace logging off.
    | Date: Fri, 14 Sep 2007 06:54:04 -0700
    | Lines: 7
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2929
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGHUB02.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:63007
    | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | Could someone please advise me on why people are logged out of their
    remote
    | workspaces. We have multiple sites connecting via a VPN to a server. Some
    of
    | the people are complaining that they are logged out of their online
    diaries
    | after a certain amount of time. Is it simply a matter of changing a
    setting
    | to keep them logged on. It's strange because we have not changed any
    | settings, and only some people are logged off, whereas others stay
    connected.
    | Help someone!!!
    |
     
    Terence Liu [MSFT], Sep 17, 2007
    #3
  4. Nick

    Nick Guest

    Sorry, that was a bit of a ramble. All the users in question connection via
    VPN
     
    Nick, Sep 17, 2007
    #4
  5. Nick

    Nick Guest

    Cheers guys, I'm going have a look through the stuff you've kindly suggested
    today and I'll get back if it solves the problem

    Cheers

    Nick

     
    Nick, Sep 17, 2007
    #5
  6. Hello Nick,

    Thank you for your update.

    If the issue only happen on VPN clients, please take more care to check the
    VPN timeout settings.

    Does the VPN stop when the RWW session log off? Can you access other
    resource on SBS after the RWW log off?

    I hope everything is going well.

    If there's anything unclear, please do not hesitate to let me know.

    Thank you and have a nice day,

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | Thread-Topic: Remote webspace logging off.
    | thread-index: Acf4/xJfWW7YlIJ0RQOjmbCMADNasQ==
    | X-WBNR-Posting-Host: 207.46.19.168
    | From: =?Utf-8?B?Tmljaw==?= <>
    | References: <>
    <KdECLPP#>
    | Subject: RE: Remote webspace logging off.
    | Date: Mon, 17 Sep 2007 00:48:01 -0700
    | Lines: 187
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2929
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGHUB02.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:63423
    | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | Cheers guys, I'm going have a look through the stuff you've kindly
    suggested
    | today and I'll get back if it solves the problem
    |
    | Cheers
    |
    | Nick
    |
    | "Terence Liu [MSFT]" wrote:
    |
    | > Hello Nick,
    | >
    | > Thank you for posting here. Let's thank Russ for the input.
    | >
    | > According to your description, I understand that on RWW users will log
    out
    | > their session after a certain amount of time. If I have misunderstood
    the
    | > problem, please don't hesitate to let me know.
    | >
    | > Based on my research, I suggest we try the following steps to see if we
    can
    | > resolve this issue:
    | >
    | > Please check the following settings:
    | >
    | > I. TSweb timeout
    | > ====================
    | > 1. Make a copy of the C:\InetPub\Remote\tsweb.aspx file in the event
    you
    | > need to revert quickly.
    | > 2. Edit tsweb.aspx with notepad.
    | > 3. Search for "MsRdpClient.AdvancedSettings2.MinutesToIdleTimeout"
    (without
    | > the quotation marks) with a value of "= <%=rapLinks.timeoutSeconds
    | > / 120%>. Change the value to the actual time out or no more than 240 as
    | > testing with values over 240 result in the connection failure.
    | > 4. Save the changes in the file and exit notepad.
    | > 5. Restart the IIS Service or restart the SBS Server.
    | >
    | > II. Remote Web Workplace timeout:
    | > ======================
    | > The time out values (in minutes) are configurable in the registry, at:
    | >
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\P
    | > ublicTimeOut
    | > REG_DWORD: 20 (Default)
    | >
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\T
    | > rustedTimeOut
    | > REG_DWORD: 120 (Default)
    | >
    | > The PublicTimeOut is used when the user checks the box for "I'm using a
    | > public or shared computer" on the RWW logon page. The TrustedTimeOut is
    | > used when the user unchecks this checkbox. You can change the time out
    | > settings here.
    | >
    | > III. ASP.NET timeout
    | > ======================
    | > Edit the C:\inetpub\remote\web.config file.
    | > Look for line:
    | > <forms name="RemotePortalAuth" loginurl="logon.aspx" protection="All"
    | > path="/" timeout="120" />
    | > timeout = value in minutes of your largest timeout value.
    | >
    | > The default timeout in SBS 2003 is 120 minutes.
    | >
    | > IV. IIS timeout:
    | > =======================
    | > 1. Go to Server Management -> Advanced Management -> Internet
    Information
    | > Server.
    | > 2. Expand [Server Name] -> Web Sites -> Default Web Site.
    | > 3. Right click Remote and choose Properties, in Virtual Directory tab,
    | > click the Configuration button and select the Options tab, modify the
    | > session timeout settings. The Default Session timeout in SBS 2003 is
    120
    | > minutes.
    | >
    | > V. ISP timeout:
    | > =======================
    | > The ISP may have some session timeout settings, please contact your ISP
    to
    | > check it.
    | >
    | > VI. Router timeout:
    | > ========================
    | > As I know, some router or ADSL modem will have session timeout
    | > configuration options, please try to contact your hardware vendor to
    check
    | > it.
    | >
    | > VII. VPN connection timeout:
    | > =======================
    | > How do you setup the VPN connection between remote clients and SBS?
    Please
    | > check the timeout setting of your VPN connection.
    | >
    | > If we cannot resolve the issue after we perform the above steps, please
    | > help me collect some information for further investigation:
    | >
    | > 1. Please try to access the RWW from SBS itself, then test this issue.
    | >
    | > 2. Does the disconnection happen after a while of idle time?
    | >
    | > 3. Do you get any error when the session logoff?
    | >
    | > 4. Gather MPS network report on SBS:
    | >
    | > a. Download MPSrepot_network from
    | >
    http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
    | > 15706/MPSRPT_NETWORK.EXE
    | >
    | > b. Run MPSRPT_NETWORK.exe on the server box.
    | >
    | > c. The tool will automatically collect the information. This procedure
    will
    | > take 10~15 minutes.
    | >
    | > d. Open Windows Explorer, navigate to the folder:
    | > %SystemRoot%\MPSReports\Network\Reports\Cab\
    | >
    | > e. Send the .cab file directly to me at
    | >
    | > Hope these steps will give you some help.
    | >
    | > Thanks and have a nice day!
    | >
    | > Best regards,
    | >
    | > Terence Liu(MSFT)
    | >
    | > Microsoft CSS Online Newsgroup Support
    | >
    | > Get Secure! - www.microsoft.com/security
    | >
    | > =====================================================
    | > This newsgroup only focuses on SBS technical issues. If you have issues
    | > regarding other Microsoft products, you'd better post in the
    corresponding
    | > newsgroups so that they can be resolved in an efficient and timely
    manner.
    | > You can locate the newsgroup here:
    | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | >
    | > When opening a new thread via the web interface, we recommend you check
    the
    | > "Notify me of replies" box to receive e-mail notifications when there
    are
    | > any updates in your thread. When responding to posts via your
    newsreader,
    | > please "Reply to Group" so that others may learn and benefit from your
    | > issue.
    | >
    | > Microsoft engineers can only focus on one issue per thread. Although we
    | > provide other information for your reference, we recommend you post
    | > different incidents in different threads to keep the thread clean. In
    doing
    | > so, it will ensure your issues are resolved in a timely manner.
    | >
    | > For urgent issues, you may want to contact Microsoft CSS directly.
    Please
    | > check http://support.microsoft.com for regional support phone numbers.
    | >
    | > Any input or comments in this thread are highly appreciated.
    | > =====================================================
    | >
    | > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    | >
    | > --------------------
    | > | Thread-Topic: Remote webspace logging off.
    | > | thread-index: Acf21raDpFDnMS+1Qru5FSnZsodn5w==
    | > | X-WBNR-Posting-Host: 207.46.19.168
    | > | From: =?Utf-8?B?Tmljaw==?= <>
    | > | Subject: Remote webspace logging off.
    | > | Date: Fri, 14 Sep 2007 06:54:04 -0700
    | > | Lines: 7
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 7bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2929
    | > | Newsgroups: microsoft.public.windows.server.sbs
    | > | Path: TK2MSFTNGHUB02.phx.gbl
    | > | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:63007
    | > | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
    | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > |
    | > | Could someone please advise me on why people are logged out of their
    | > remote
    | > | workspaces. We have multiple sites connecting via a VPN to a server.
    Some
    | > of
    | > | the people are complaining that they are logged out of their online
    | > diaries
    | > | after a certain amount of time. Is it simply a matter of changing a
    | > setting
    | > | to keep them logged on. It's strange because we have not changed any
    | > | settings, and only some people are logged off, whereas others stay
    | > connected.
    | > | Help someone!!!
    | > |
    | >
    | >
    |
     
    Terence Liu [MSFT], Sep 18, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.