Resetting the default media player to Window Media Player

Discussion in 'Internet Explorer' started by Kirk, Dec 27, 2007.

  1. Kirk

    Kirk Guest

    Prior to installing an upgrade to QuickTime, downloading most video/movie
    files (wmv, avi, mpg, mpeg) in IE7, automatically launched Windows Media
    Player (not a plugin within an IE7 window) which then played the video.
    Since then however, downloading mpg and mpeg videos launches the QuickTime
    plugin in a new IE7 window (wmv files are unaffected, avi files launch a new
    IE7 window which then launches WMP). Even when I disable the QuickTime
    Plugin, a new window is still launched though the play obviously fails since
    the plugin is not available. How can I return the default media player to
    Windows Media Player for all video types downloaded via IE7?? (Note: WMP is
    already the default player for all the above file types when launched from
    Windows Explorer)??
     
    Kirk, Dec 27, 2007
    #1
    1. Advertisements

  2. Hi,

    Open Windows Media Player and click on Tools||Options||File Types.
    Remove all checkmarks from all file types and click APPLY.
    Close Windows Media Player.
    Open Windows Media Player again and click on Tools||Options||File Types.
    Reapply checkmarks to the file types you want WMP to handle in the Browser
    or click "Select all" to reapply the checkmarks to all file types and click
    on APPLY.

    Good luck,

    Donald Anadell




    (Note: WMP is
     
    Donald Anadell, Dec 27, 2007
    #2
    1. Advertisements

  3. Kirk

    Kirk Guest

    Donald,
    Thank you very much; your procedure cleared the problem. Since I could
    still launch WMP from a mpeg file in Windows Explorer, I had assumed the
    problem was with IE7 plugins. It turns out that when I looked at the 'File
    Types' in WMP 'Options', mpeg files were checked, but the check box had been
    shaded (wmv & avi where both checked but unshaded).

    (Sorry for the delayed response, I've been away for several days, and only
    just saw your post.)
     
    Kirk, Jan 1, 2008
    #3
  4. Your welcome Kirk, glad you were able to resolve the issue.

    Happy New Year,

    Donald Anadell
     
    Donald Anadell, Jan 1, 2008
    #4
  5. Kirk

    thecarrs156 Guest

    I have had the same problem with Quicktime becoming the default program for
    my mpg files. When I opened Windows Media Player and clicked on
    Tools//Options, the tabs listed did not include File Types. Trying to change
    it by using Open With and browse, or the Default Program//Set
    Associations//Change Program//Open With//Browse:wmplayer.exe just reverted me
    back to the unchanged Open With menu. Can you help?
     
    thecarrs156, Jan 9, 2008
    #5
  6. If you are using Vista with Windows Media Player 11(I don't have a machine
    with Vista on it here right now), I don't believe you will see a "file
    types" tab, because Vista uses a different file association mechanism than
    Windows XP. Media files are now controlled via the default programs
    mechanism in the control panel.

    Setting Windows Vista Default programs:
    http://www.windowsvistauserguide.com/default_programs.htm

    Windows Media Player discussion group:
    http://www.microsoft.com/communitie....aspx?dg=microsoft.public.windowsmedia.player

    Good luck,

    Donald Anadell
     
    Donald Anadell, Jan 9, 2008
    #6
  7. Kirk

    thecarrs156 Guest

    Unfortunately, the steps that I outlined in my question were straight from
    the windowsvistauserguide. There are only six programs listed as possible
    default programs and Windows Media Player is not one of them. QuickTime is
    listed, but the check marks are grayed and inaccessible for mpg files. Any
    other suggestions?
     
    thecarrs156, Jan 9, 2008
    #7
  8. Kirk

    thecarrs156 Guest

    I just blundered into a fix for this problem. By searching "add a default" I
    found a new page that allowed me to set default programs for my computer.
    Under "Custom", I was able to allow access to Windows Media Player and
    several other Windows default programs. Thanks for your input, it got me on
    the right track.
     
    thecarrs156, Jan 9, 2008
    #8
  9. You're welcome, glad you were able to resolve it.

    Good luck,

    Donald Anadell
     
    Donald Anadell, Jan 9, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.