Resume From Sleep: Wirelss Adapter Failure

Discussion in 'Windows Vista Networking' started by Stuscotland, Sep 7, 2008.

  1. Stuscotland

    Stuscotland Guest

    Dell XPS M1330 Core2Duo 2GB RAM laptop

    Vista Home Premium

    Intel Wireless WiFi Link 4965AGN

    Driver version 12.0.0.82

    Driver date 08/07/2008
    --------------------------------

    I have a big problem with my WiFi adaptor when resuming from Sleep. In all
    other circumstances it works perfect. Upgrading the driver version and my
    router firmware has not helped. Basically, when I resume from sleep, the
    WiFi indicator still shows connected in system tray. Clearly though, it is
    not as I have no internet access or IP address.

    When I click on the icon in the system tray, I should get the Network and
    Sharing Centre but nothing appears. If I try to open the Network Connections
    panel through Control Panel or elsewhere, it hangs that MMC. Currently the
    only way to get wireless back online is to reboot after which all is well
    again.

    Interestingly, browsing to the adaptor properties shows the option to
    Enable…but nothing happens when you try this. Disabling via DeviceManager
    and re-enabling hangs the console. I’ve tried everything else I can think
    of. The Intel wireless tools run their tests and show the driver loaded and
    hardware enabled, but sits for a long time on the Radio Test with no result.
    Explorer.exe will stop working if I run these tests, upon resuming the
    desktop shows the red cross against the adaptor (and even my battery as being
    flat.)

    The event logs are pretty useless; the resume from sleep time shows no
    related errors for networking.

    This is an example of a pooooor OS, reliability is not a strong point. Does
    anyone have suggestions on how to resolve this issue, suggestions welcomed?

    Thanks in advance.

    -----------------------

    Logs in order oldest to newest from event viewer: (see last event in
    particular).

    Log Name: System
    Source: BROWSER
    Date: 06/09/2008 22:31:01
    Event ID: 8033
    Task Category: None
    Level: Information
    Keywords: Classic
    User: N/A
    Computer: Stu-XPS
    Description:
    The browser has forced an election on network
    \Device\NetBT_Tcpip_{2369E8EC-7E09-4E02-88D8-1AE4691B0849} because a master
    browser was stopped.

    -----------------------

    Log Name: System
    Source: Microsoft-Windows-Kernel-Power
    Date: 06/09/2008 22:31:01
    Event ID: 42
    Task Category: None
    Level: Information
    Keywords: (4)
    User: SYSTEM
    Computer: Stu-XPS
    Description:
    The system is entering sleep.
    ------------------------

    Log Name: System
    Source: Tcpip
    Date: 06/09/2008 22:31:01
    Event ID: 4202
    Task Category: None
    Level: Information
    Keywords: Classic
    User: N/A
    Computer: Stu-XPS
    Description:
    The system detected that network adapter Wireless Network Connection was
    disconnected from the network and its network configuration has been
    released. If the network adapter was not disconnected, this may indicate that
    it has malfunctioned. Try updating the driver for the network adapter.

    -------------------------

    Log Name: System
    Source: NETw5v32
    Date: 07/09/2008 10:23:11
    Event ID: 7036
    Task Category: None
    Level: Information
    Keywords: Classic
    User: N/A
    Computer: Stu-XPS
    Description:
    The \Device\NDMP13 service entered the Intel(R) Wireless WiFi Link 4965AGN
    state.
    -------------------------




    Log Name: System
    Source: Microsoft-Windows-DistributedCOM
    Date: 07/09/2008 11:27:14
    Event ID: 10016
    Task Category: None
    Level: Error
    Keywords: Classic
    User: NETWORK SERVICE
    Computer: Stu-XPS
    Description:
    The machine-default permission settings do not grant Local Activation
    permission for the COM Server application with CLSID
    {A4199E55-EBB9-49E5-AF1A-7A5408B2E206}
    to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address
    LocalHost (Using LRPC). This security permission can be modified using the
    Component Services administrative tool.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Microsoft-Windows-DistributedCOM"
    Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="49152">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2008-09-07T10:27:14.000Z" />
    <EventRecordID>79631</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>Stu-XPS</Computer>
    <Security UserID="S-1-5-20" />
    </System>
    <EventData>
    <Data Name="param1">machine-default</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{A4199E55-EBB9-49E5-AF1A-7A5408B2E206}</Data>
    <Data Name="param5">NT AUTHORITY</Data>
    <Data Name="param6">NETWORK SERVICE</Data>
    <Data Name="param7">S-1-5-20</Data>
    <Data Name="param8">LocalHost (Using LRPC)</Data>
    </EventData>
    </Event>
     
    Stuscotland, Sep 7, 2008
    #1
    1. Advertisements

  2. Stuscotland

    Stuscotland Guest

    I'll give it a go - neither option was ticked for allowing to put into sleep
    or wake etc.

    Would have thought they'd have the driver setup already to work in line with
    hibernation :)

    S
    MCSE/MCP
     
    Stuscotland, Sep 7, 2008
    #2
    1. Advertisements

  3. You were talking of sleep mode in original post?
    I expect it would have worked from hibernate because it is a full power up
    condition.
    If the wireless card is not working from restore from hibernation then my
    suggestion is probably bogus.


    Michael
     
    Michael Walraven, Sep 7, 2008
    #3
  4. Stuscotland

    Stuscotland Guest

    No sorry, it was my inaccuracy in the terminology - problem is sleep mode
    only. Will update the post later with the result. Cheers.
     
    Stuscotland, Sep 7, 2008
    #4
  5. Stuscotland

    Pavel A. Guest

    AFAIK this is a known issue and a driver update should be available.
    If you indeed have latest 4965 driver and BIOS, please contact Dell
    support.

    --PA
     
    Pavel A., Sep 7, 2008
    #5
  6. Stuscotland

    Stuscotland Guest

    Stuscotland, Sep 8, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.