right click disabled

Discussion in 'Windows Server' started by Dan, Apr 28, 2007.

  1. Dan

    Dan Guest

    Hi,

    I installed Windows server 2003 with all the latest patches and service pack
    2. I just discovered that when I right click any item from Start-Programs the
    right click menu doesn't appear. The menu appears ok in other instances like
    windows explorer and desktop.

    I have a feeling it could be one of the patches but haven't found any clue
    from the web. Any ideas would be appreciated.

    Thanks
    Dan
     
    Dan, Apr 28, 2007
    #1
    1. Advertisements

  2. Dan

    Herb Martin Guest

    The Start menus ARE Windows Explorer.

    Explorer (which runs those menus and the task bar) is FULL of little
    intermittent and sporadic bugs in how it handles this stuff.

    You may find that it *is* handling the right-click but only after excessive
    delay and only if you are patient enough to hold the mouse RIGHT THERE
    until it does.
    Does the right click work on the Task Bar and Start button itself?

    Sometimes for intermittent problems the best thing to do is just
    KILL Explorer and restart it.

    Task Manager can do both, or you can use the command line
    which I prefer since it can be more agressive when killing hard to
    kill programs.

    TaskList shows program names and PIDs.

    TaskKill will kill them, e.g., taskkill /im explorer.exe or taskkill /pid
    2222.

    Add /f to "force" but be careful using this on system processes including
    LOW numbered SvcHost.exe.

    Then restart Explorer by just typing that name use using the TaskMgr
    File menu.
     
    Herb Martin, Apr 28, 2007
    #2
    1. Advertisements

  3. Dan

    roga Guest

    Right click on the taskbar, select properites, click "start menu",
    customize, advanced,

    Ensure "enable dragging and dropping" is ticked

    roga
     
    roga, Apr 28, 2007
    #3
  4. Dan

    Herb Martin Guest

    Wow, does that really have anything to do with "right clicking on items"?

    This week my own 2003 Server "lost the Administrative tools" -- looked
    in All Users and my Profile and they were there.

    Checked the properties and the Show Admin Tools was (spontaneously)
    clear.

    Only I use this machine and there is no explantion for how that box
    was cleared -- I haven't even been in the Options for weeks until
    I fixed it.
     
    Herb Martin, Apr 28, 2007
    #4
  5. Dan

    roga Guest

    We hit the same problem a few weeks ago and discoverd the solution by trial
    and error

    Roga
     
    roga, Apr 28, 2007
    #5
  6. Dan

    Herb Martin Guest

    I believe you -- it may have been just some kind of
    "reset" behavior that was kicked off by making any change,
    or maybe any of a subset of changes.

    Explorer really does have a ton of little bugs -- little because
    they aren't really fatal and seem to be intermittent.
     
    Herb Martin, Apr 29, 2007
    #6
  7. Dan

    Dan Guest

    Thanks roga,,,I enabled dragging and dropping and now its working..

    - Dan
     
    Dan, Apr 29, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.