Roaming Profiles Not Roaming!

Discussion in 'Active Directory' started by robinwilson16, Apr 29, 2006.

  1. Hello

    I have a server running as a domain controller with Windows Server 2003 and
    5 computers all running Windows XP.

    I set up folder redirection and also roaming user profiles
    I created 2 shared folders on the server.

    Following an article I set up the permissions on the shares as follows:

    Creator_Owner - Full Control - Subfolders and files only
    Everyone - Special - Traverse Folder/Execute File, List Folder/Read Data,
    Read Attributes, Create Folders/Append Data - This Folder Only
    System - Full Control - This folder, sub folders and files

    Using group policy I redirected My Documents, Application Data, Desktop,
    Start Menu and this all works well and I also mapped my documents to drive Z

    However I set the profile path in the users accounts to be
    \\Servername\Sharename\profiles using Active Directory Users and Computers
    but next time the users log on it creates a folder for them using their
    username in the share but after they log off it is left empty and is never
    filled with their favorites etc so that their favorites and other data are
    only stored locally and don't syncronise with the server so that their
    favorites list is empty when they log on elsewhere.

    I have read all the articles I can find on setting up roaming profiles and
    believe I have followed everything exactly.
    Could there be some group policy causing problems. Is it to do with
    disabling offline folders? Or do I need some permissions on the share? Or
    have I missed some other setting somewhere?

    I did get roaming profiles working on the old server somehow!

    Any help would be much appreciated as I cannot see what is wrong.

    Thanks
    Robin
     
    robinwilson16, Apr 29, 2006
    #1
    1. Advertisements

  2. Hello

    Thanks for the help. I did try that but it didn't work either. I then added
    some extra permissions on the share (which weren't on the tutorials) and it
    now seems to be working for all XP 32bit machines but my XP x64 machine will
    download the roaming profile of the user if it does not exist but when
    logging off will not syncronise back to the server. This appears to be the
    same with the server itself. Is there some policy I can enable which will
    force it to always download the roaming profile when logging on and then
    re-syncronise it when I log off?
    I hope this isn't another problem related to using x64!

    Thanks
    Robin
     
    robinwilson16, Apr 30, 2006
    #2
    1. Advertisements

  3. I have now fixed it

    I enabled a GPO which said something like "only allow login if remote
    profile can be downloaded" and that seems to be forcing it to download the
    roaming profile and updating it on the affected machines.

    So the problem is solved although I don't really see why that GPO should fix
    it

    Robin
     
    robinwilson16, May 1, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.