Robocopy - Access Denied issue - migration from 2003 to 2008

Discussion in 'Server Migration' started by Brian Brocker, Oct 24, 2008.

  1. I need to migrate data from Server 2003 to Server 2008, however I am getting
    'Access Denied' on some directories. I'm using Robocopy XP027 that comes with
    Server 2008 with the backup mode switch. It seems that if I don't have at
    least 'Read' access to the source directories on Server 2003, then I can't
    get passed the 'Access Denied' issue.

    This same process worked just fine when migrating data between two servers
    running Server 2003, just doesn't work when one server is running 2008.

    Please help! I'm getting nowhere fast (or slow - been working on this for
    several weeks unsuccessfully).

    Thanks,
    Brian
     
    Brian Brocker, Oct 24, 2008
    #1
    1. Advertisements

  2. Hello Brian,

    Are the folders encrypted? What kind of permissions are set there, different
    form the others? Is the 2008 in the same domain or different? From what groups
    is the account you use member of? Did you try also to copy the data from
    the 2008 machine?

    Best regards

    Meinolf Weber
     
    Meinolf Weber, Oct 24, 2008
    #2
    1. Advertisements

  3. Meinolf,

    Sorry for the late reply - I had troubles getting logged back into the
    correct place to respond.

    1. Folders Encrypted? --- NO
    2. Different Domains? -- NO, they are in the same domain
    3. Group Membership of Account used -- Domain Administrator (and thus a
    local administrator on both machines - I double checked that this was the
    case) -- I've also tried explicitly assigning backup and restore priviledges
    to this account also - which had no effect (being a member of administrators
    group - it already has this as I understand it).
    4. Permissions -- on the successful files/folders, the local administrators
    group (which includes domain administrators) has full access on the source
    machine (my testing has shown that a minimum of read access on the source
    files/folders is required for success). On the unsuccessful files/folders,
    the local administrators group does not have access to them. (As noted
    originally, when only two 2003 machines are involved, the '/B' (backup mode)
    switch overcomes this lack of access. That is not the case though for the
    2008 machine.
    5. I've tried running robocopy from the 2008 machine to 'pull' the data from
    2003. (using versions XP027, XP026, and XP010) - Unsuccessful directories
    report 'Error 5 (0x00000005) Scanning source directory
    \\2003server\H$\folder\subfolder Access is Denied'. Additionally, on the
    failed directory, I get 'Error 5 (0x00000005) Copying NTFS Security to
    Destination File (or Directory as applicable)\\2008server\H$\folder\subfolder
    Access is Denied'

    6. I have also tried running robocopy from the 2003 server to 'Push' the
    files to 2008 (with XP026 version) - this method gets past the first error
    (Scanning source directory), but still give the seond error (Copying NTFS
    Security to Destination Directory....)

    It appears to me that the /B (backup mode) is not recognized in Server 2008.
     
    Brian Brocker, Nov 12, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.