Robocopy sets attributes on destination folder to system and hidde

Discussion in 'Windows Vista General Discussion' started by MitchW, Jun 21, 2007.

  1. MitchW

    MitchW Guest

    Hello,

    I am trying to copy a file from one Vista system to another. I have created
    a mapped drive on one box.

    I issue the command

    robocopy c:\ y:\images\ 1.wim I have also tried
    robocopy c: y:\images 1.wim

    Each time when robocopy completes the directory attribbutes on the second
    system \images is set to system and hidden.

    If I issue the same command to the same system (i.e., robocopy c:\ c:\temp
    1.wim) the attributes on c:\temp are not set to system and hidden.

    Is there some way to fix this or what am I doing wrong?

    thanks,
    mitch
     
    MitchW, Jun 21, 2007
    #1
    1. Advertisements

  2. MitchW

    glennpsion Guest

    Did you ever get a reply?
    I have found if the destination folder exists, then things work.
    If it doesn't then the destination folder is created as a hidden folder
    AND you cannot remove it as it is made as a 'system folder'.
    I have got aroung this my using mkdir command before running the
    robocopy command..............but surely robocopy should have an answer
    to this (a switch?) or is this a bug?
     
    glennpsion, Aug 10, 2008
    #2
    1. Advertisements


  3. Nobody in the newsgroup knows what you are talking about as you didn't quote
    what you were replying to. Most people here are not using the forum that
    you are using.

    Anyway, what switches are you using? I have never seen behaviour as you
    describe with Robocopy, although I do not use /COPYALL.

    ss.
     
    Synapse Syndrome, Aug 10, 2008
    #3
  4. MitchW

    glennpsion Guest

    unbelievable. I just spent 10 mintue typing a reply into the box, go to
    send, and it says it
    has logged me out.............mail totally lost. Great...........!
    I'll start again, this time cutting and pasting from a notepad file.

    ............."Nobody in the newsgroup knows what you are talking about
    as you didn't quote
    what you were replying to"..............if it is that difficult to use
    the web site no
    wonder very few people use it. I saw the message, I pressed reply.
    Anyway, on to the problem:
    I am actually using XP, but I understand from searches on the Web that
    all this is also a
    VISTA problem. This problem definitely exists:
    'Robocopy and Hidden Files : Robocopy'
    (http://www.experts-exchange.com/Storage/Misc/Q_23481234.html)
    'Robocopy creates hidden directorys in win xp'
    (http://tinyurl.com/598d3x)
    'Destination Folder hidden/invisible after using xcopy or robocopy -
    Neowin Forums' (http://www.neowin.net/forum/index.php?showtopic=579263)
    The script I am using is:
    robocopy F: "M:\290_MOB1_BU_D_Media" *.* /MIR /X /FP /V /XD "_RESTORE"
    "System Volume Information" /R:1 /W:1 /TEE
    If the destination drive is empty and robocopy has to create the
    folder, then the folder is not only created as a hidden folder, but
    created as a system folder, so th hidden attribute cannot be undone.
    I get around this at the moment by putting the following script before
    the robo script:
    mkdir "M:\290_MOB1_BU_D_Media"
    Everything then works ok and the folder is not hidden.
    If the folder already exist, the command effictively gets ignored.
    This has to be a bug.
    If not AT THE VERY LEAST the documentation should explain why this
    behaviour is so.
    Glenn
     
    glennpsion, Aug 11, 2008
    #4

  5. That is weird, and not something that I have had happen to me. What version
    of Robocopy are you using? I use XP026 on XP, which is a newer version than
    the one that comes in the Windows Server 2003 Resource Kit. One of the
    links you gave suggests that this is not a problem in later versions of
    Robocopy, like the Vista version.

    Does this also happen with the /B switch, for Backup mode?

    You can always use..

    ATTRIB -h - s <folder name>

    ...to get rid of those attributes. If you use the command without any name,
    it should be applied to all folders and files in the current directory.

    ss.
     
    Synapse Syndrome, Aug 13, 2008
    #5
  6. MitchW

    glennpsion Guest

    I am using XP010.........so an older version
    I can't even remember where I got it now

    Perhaps it was on the Windows XP CD

    Perhaps I need to get the newer version. Any idea where you can dow
    load it

    Perhaps setting the attribute will help, but creating the director
    equally works................ both is one command too many

    I haven't tried the /B switch

    I'll put this down as a bug which probably got fixed. I would need t
    find an official XP026 and see what 'bugs' were fixed in there and i
    this was one of them

    Glen
     
    glennpsion, Aug 13, 2008
    #6
  7. XP026 is the latest version that works correctly in XP, as far as I know.
    The Vista RTM or SP1 versions do not work in XP. It's pretty stupid that
    they still distribute XP010 in the Windows Server 2003 Resource Kit, as it
    also has other bugs, like not copying over the correct folder timestamps
    when told to do so.

    The only way to get XP026, as far as I know, is to install the Robocopy GUI.
    When you do that, XP026 gets added to your system32 folder.

    http://technet.microsoft.com/en-us/magazine/cc160891.aspx

    Alternatively you can email me at the address in the headers (remove
    spamtrap) and I will send it to you.

    Post back if it does solve your problem.

    ss.
     
    Synapse Syndrome, Aug 13, 2008
    #7
  8. MitchW

    glennpsion Guest

    I'll probably give at this point unless it becomes a real problem
    It clearly is a bug but I have got around it and my daily, weekly an
    monthly backup, since I changed to backing up from the root of a disk
    are now all working fine again

    .......at least I know there is an updated version

    Thanks for your help though. I hope others that have this problem ge
    to see this

    Regard

    Glen
     
    glennpsion, Aug 13, 2008
    #8
  9. MitchW

    alank Guest

    Seems to have something to do with going directly from a root of
    drive. I am trying to backup my D: drive where I store all of my data
    C: is reserved for just the OS. I'm backing up to my G: drive which i
    external USB. To get around this problem I had to add attrib command a
    end of my script. And I also create the Backups directory first incas
    it doesnt exist for some reason or you will fail for the LOG param. I
    the Backup dir does already exist, the mkdir is ignored
    @echo of
    mkdir G:\Backup
    robocopy D: G:\Backups /XD Images $RECYCLE.BIN "System Volum
    Information" /S /R:0 /W:0 /LOG+:"G:\Backups\backup.log" /TEE /NFL /ND
    /N
    attrib -h -s G:\Backu
     
    alank, Jan 9, 2009
    #9
  10. MitchW

    mtech Guest

    I have exactly the same problem with Windows 7 64 Bit Professional.
    Bought a 1½ Tb Drive for all my backups and they are all hidden which i
    a PITA. Going to try your attrib command
     
    mtech, Nov 28, 2009
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.