safe way to upgrade KMDF from V1.0 to V1.1

Discussion in 'Windows Vista Drivers' started by hanzhu, Aug 25, 2006.

  1. hanzhu

    hanzhu Guest

    I have a driver based on KMDFV1.0 StaticBus and it contained only a
    little change. It worked well for the last few months. However, when I
    tried to upgrade it to KMDFV1.1 today, it cannot been initialized.
    Device manager told me the error code is 37. However, Devcon.exe
    returned success info for install operation.
    My steps as the following:
    1) change the coinstaller to the corresponding one of V1.1(x86fre build)
    2) update the .inx file according to the sample of KMDFV1.1
    3) devcon install statbus.inf "root\statbus.inf"
    4) sxe ld:statbus.sys hit, set a breakpoint on statbus!DriverEntry
    5) The breakpoint was never hit.
    6) devcon returned successfully, however device manager couldn't start
    the device. I found out wdfldr.sys,wdf0010.sys and statbus.sys had been
    unloaded.

    several questions:
    1) How can I upgrade it successfully?
    2) I build the driver with WDK5483. I'm afraid the tools chain is not
    installed successfully since it complains about "_objects.mac file time
    is in the future". How can I validate it?
    3) Is it safe use the check build KMDF coinstaller on a free build
    win2k3sp1? There is something different if I use chkbuild coinstaller. I
    can observe some info in Windbg and Devcon.exe failed when it returned.
    Any hints and help will be appreciated.
     
    hanzhu, Aug 25, 2006
    #1
    1. Advertisements

  2. if you built the driver in the WDK, the driver requires KMDF v1.5. you
    need to build the driver in the server sp1 ddk w/the v1.1 bits. this is why
    your DriverEentry is never called.

    you cannot use the chk coinstaller on any fre build, it is a limitation of
    update.xe


    d
     
    Doron Holan [MS], Aug 25, 2006
    #2
    1. Advertisements

  3. hanzhu

    hanzhu Guest

    Doron,
    I changed it to KMDFV1.5 cointaller. Everything seems the same as
    before. :-(
    Any more tips?

    Doron Holan [MS] дµÀ:
     
    hanzhu, Aug 25, 2006
    #3
  4. --
    I have the similar problem with my drivers when I upgraded them from
    KMDF 1.0 to 1.1.
    I used regmon utility from sysinternals to log KMDF co-installer
    accesses to the registry, and I manually restore those that were
    absent, in order to correctly install and start new 1.1 driver.
    It seems that KMDF co-installer expects some entries in the registry to
    pre-exist and failed when it does not find them. If this is true, it
    may be useful to change it's algorithm and create those entries during
    it's work if, for some reason, they are absent. Or, at least, clearly
    describe this situation to the user in some way.

    Regards,
    Gennady Mayko.
     
    Gennady Mayko, Aug 25, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.