Sandisk Cruzer Micro 512MB Flash Drive

Discussion in 'Windows Update' started by Rodeoguy, Mar 28, 2006.

  1. Rodeoguy

    Rodeoguy Guest

    I just bought a Sandisk Cruzer Micro 512MB Flash Drive to transport data from
    my office to my home. The Flash Drive works great at my office (Running
    Windows XP with all current updates on PC) and I've already saved data to it.
    It wil not, however, work on my home computer.

    I have 6 USB ports, two of which are occupied, on my home computer. I have
    tried the Flash Drive on all ports. I am running Windows XP Pro. My platform
    is an AMD AthlonXP2600+, 2.09 GHz with 1.00 GB of RAM. The error message I
    get when I plug the Flash Drive in to any USB port is: "NO USB DRIVE IS
    PLUGGED IN" or "USB DEVICE NOT RECOGNIZED" or "UNKNOWN USB DEVICE".

    I have emailed SanDisk (www.Sandisk.com) for help, but am still waiting for
    a reply. Am I missing a Driver? I hate to screw around with the Registry,
    as I am not that computer-savvy.

    If anyone has any ideas, your help would be greatly appreciated. I would
    really like to use the device. It's much easier to transport than CD's, and
    is a more stable media.
    Regards,
    Rodeoguy
     
    Rodeoguy, Mar 28, 2006
    #1
    1. Advertisements

  2. Rodeoguy

    Mr. Nobody Guest

    Just a guess here, but is the flash drive USB 2, and you only have USB 1
    ports??? Maybe that drive will only use a USB 2 port. You need to read the
    instructions that came with it and install a USB 2 port if that is the case.
    Maybe your motherboard has a USB 2 port and its just not installed (driver
    installed).

    This is really not the place to ask, I think there maybe a USB news group or
    web site somewhere, sorry I don't know of any myself.

    Hope this helps in some way.

    Mr. Nobody
     
    Mr. Nobody, Mar 29, 2006
    #2
    1. Advertisements

  3. Rodeoguy

    Brains,None Guest

    does anything pop up such as "too much power on USB port?" (I know
    that's not exact, but that's the gist of it)

    Usually, those special flashdrives have a driver on it, unless you
    formatted it, or erased it. try going to the website for a driver?

    Jim
     
    Brains,None, Mar 29, 2006
    #3
  4. Rodeoguy

    Rodeoguy Guest

    Thanks, Jim...
    No pop up like the one you mentioned. I did check the SanDisk website for a
    list of their drivers, but there is not one available for the Cruzer Micro.
    I don't believe I reformatted or or erased anything. I remain baffled as to
    why it works on one computer and not on the other. Still no reply from
    SanDisk Tech Help... Starting to think I'm spending too much time on this
    issue. Maybe I should just try another Flash drive?
     
    Rodeoguy, Mar 29, 2006
    #4
  5. Rodeoguy

    Brains,None Guest

    I have a situation where a flashdrive I have works directly in the
    computer, and NOT on a hub.. try that?

    jim
     
    Brains,None, Mar 29, 2006
    #5
  6. I am sure you know this but the problem resides with your computer and not
    the flash drive. The Sandisk Cruzer does not require a special driver for
    WINXP, the native drive is OK. As a suggestion and what I would do under
    the same circumstances, is to disconnect all USB devices on your machine
    then go into the Registry and delete all references to USB drives then try
    the Sandisk device. Hopefully it will then work.

    As you reconnect the other USB devices recheck the Sandisk to locate a
    conflict if it exists.
     
    Edward W. Thompson, Mar 30, 2006
    #6
  7. Rodeoguy

    Brains,None Guest

    hhmm.. Edward, I didn't know that a conflict could be possible on a USB
    device... the idea fits this scenario, tho. Can you explain more for
    this feeble mind?

    Jim
     
    Brains,None, Mar 30, 2006
    #7
  8. No sure there is a rational explanation other than to say when I had a USB
    problem, wiping out all references to installed USB devices, physically
    disconnecting the devices rebootingon my machine then reconnect one at a
    time and allowing the machine to redetect the devices, worked for me. If
    you haven't tried that, I would.

    I would firstly disconnect all USB devices, , then backup the Registry ( use
    ERUNT not that flaky System Restore utility) then go to Device Manager and
    remove all USB entries there. Now search the registry (regedit) for
    HKLM/System/CurentControlSet/Enum/USB where you will find the USB devices
    presently installed. You can now delete these entries close out then reboot
    the machine. Now reconect each device, testing as you go. The machine will
    automatically detect the devices as they are connected. Hopefully this will
    correct your problem.
    For more information 'Google' for 'remove usb devices from the registry' and
    you will find plenty of advice.
     
    Edward W. Thompson, Mar 31, 2006
    #8
  9. It is very common for Sandisk units not to work. Sandisk will say it is a
    pirated copy. After I changed to another brand I had no troubles.
     
    John Mitchell, Apr 5, 2006
    #9
  10. Where did you get this info from, that is "it is very common for Sandisk
    units not tyo work"?
     
    Edward W. Thompson, Apr 6, 2006
    #10
  11. Rodeoguy

    somo Guest

    i did not think that sandisk will have a problem either but it has i hava a
    sandisk mini512 and the same thing some found ADIR ROm and then does not get
    the drivers and i run win2K svc pck 4 so no reason for it not to run and i
    foud quite a few references of sandisk not running on win2k and xp. this
    means its not a isolated problem
     
    somo, Apr 11, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.