Saving credential in RDP connection in Vista

Discussion in 'Windows Vista Security' started by AP, Oct 24, 2007.

  1. AP

    AP Guest

    Hi All

    Having problems saving the credential in an rdp conenction i have saved to
    the desktop for a laptop running windows vista business.
    In Vista Business under the Options/General tab the Username field is not
    available?

    I have read artcicles on the web to make sure the terminal server is nt
    impossing the rule to force authentication to the server twice.
    Here what I've checked and is set to avoid double authentication:
    ---------
    The most likely is the "Always prompt for password" setting is enabled on
    the server. In order to disable the setting, the administrator of the
    server you are connecting to must run Terminal Server Configuration
    administrative tool (tscc.msc) and double click on RDP-Tcp. In the "Logon
    Settings" tab, there is an option labeled "Always prompt for password" (see
    the option circled in red below).

    Alternatively: For Windows Server 2003, an administrator may have set the
    group policy located at: "Administrative Templates\Windows
    Components\Terminal Services\Encryption and Security\Always prompt client
    for password upon connection". For Vista, this same policy is located
    "Administrative Templates\Windows Components\Terminal Services\Terminal
    Server\Security\Always prompt client for password upon connection." Note:
    This policy is set as not configured by default; if this has been set
    remember it could have been configured either on the local group policy or a
    domain based group policy.
    ----------

    After doing allt he above and checking other articles, still getting in
    Vista the following message which has always been the case.

    "Remote desktop cannot verify the identity of the computer you want to
    connect to. This problem can occur if:
    1) The remote cmputer is running a version of windows that is earlier than
    windows vista.
    2) The remote cmputer is configured to support only the RDP security layer.
    Contact your network administrator or the owner of the remote computer for
    assistance.
    Do you want to connect anyway?"

    The above warning message always appear when I try to conenct to a Windows
    2000 Terminal Server.

    How can I make sure the RDP connection saves credentials when doing a 'saved
    as' tot he desktop?

    Thank you.
     
    AP, Oct 24, 2007
    #1
    1. Advertisements

  2. AP

    Tie Various Guest

    They took RDP from XP and made into RDP= Retarded Dork Protocol...

    its another CRAPPY change from the ease of use that XP's RDP had. Sure I
    like the extra features... but
    why cant they make something good without destroying other aspects of the
    program.
    I mean I think vista development had 2 teams.
    1) Improve, 2) Seek and Destroy!

    GESH!!!
     
    Tie Various, Oct 24, 2007
    #2
    1. Advertisements

  3. That sounds like your answer.

    In the RDP Client on Vista, under the Options, Advanced tab there is a
    "Server Authentication" dialogue. By default, this is set to "Warn me if
    authentication fails". RDP version 6.0, as used by Vista, tries to
    authenticate the server machine, before making the conection. RDP servers
    prior to Windows Server 2003 SP2 cannot pass through their identity to the
    RDP client; so, you get the warning message that you see. To connect to
    Windows 2000 without the warning prompt, you need to select the option
    "Always connect, even if authentication fails".

    See the topic "What are server authentication options?" in Vista "Help and
    Support", on the Start menu. This help topic describes the warning message
    you're seeing, and what to do about it.


    Hope it helps,
     
    Andrew McLaren, Oct 24, 2007
    #3
  4. Andrew McLaren, Oct 24, 2007
    #4
  5. AP

    AP Guest

    Thanks Andrew for your explanation, it certainly helped in resolving the
    issues of supressing the authentication warning.
    I still havent found a way to be able to save the credentials for a user
    acocunt on the RDP connection, this is still an issue.

    Have also read that blog to find a solution to how to save username/password
    to the RDP connection. Instaead all i see is quite a few dissapointed
    bloggers venting their fustrations in the new features to version 6 of the
    RDP client in Vista. The so called "features" and improvements have actualy
    done more harm than good.

    It certainly stops the smooth running of RDP connections, maybe the MS RDP
    team should of have thought of introducing a 'Legacy' mode so
    users/administrator can change back the behaviour of the rdp client and to
    avoid this.

    I know the popular saying, "everyone hates change" but if only the change
    actualy made somethin that worked flawlessly better then we wouldnt be
    complaining.
     
    AP, Oct 24, 2007
    #5
  6. I see. Hmmm. Is the Windows 2000 Server in an Active Directory Domain? And
    if so, is it in the same Domain as the Vista machine?

    Is the Vista machine connecting over a LAN? or WAN?
     
    Andrew McLaren, Oct 24, 2007
    #6
  7. And, another question ... in your RDP Client on Vista, do you see the "The
    saved credentials for this remote computer will be used to connect" string?

    That is: does the client *think* it has saved the credentials, even if it
    appears not to be using them?
     
    Andrew McLaren, Oct 24, 2007
    #7
  8. AP

    AP Guest

    Yes the Laptop running Vista is on the same domain as the terminal server am
    trying to connect too, but eventually the laptop will be out in the wild and
    will still need to connect to the terminal server.
    The save credetial box does appear and I delegently tick the box, but it has
    no effect. I still need to type the username/password everytime i lounch
    the rdp connection saved on the desktop.
     
    AP, Oct 24, 2007
    #8
  9. In that case ... er sorry, stuffed if I know. I don't have a Windows 2000
    Server on hand, to test with; otherwise I'd try to set up a repro.

    But I did notice this comment from one of the MSFT guys:
    http://blogs.msdn.com/ts/archive/20...op-connection-authentication-faq.aspx#1672338

    I dunno when or how it will "be addressed" ...

    Sorry I couldn't help more.
     
    Andrew McLaren, Oct 24, 2007
    #9
  10. AP

    AP Guest

    Well spotted, I missed that response.
    Thanks for all the help mate.
     
    AP, Oct 24, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.