SBS 2003 and Great Plains problem

Discussion in 'Windows Small Business Server' started by Kerry Brown, Sep 16, 2006.

  1. Kerry Brown

    Kerry Brown Guest

    I have a customer who wants to run Great Plains 9.0 on their SBS 2003 SP1
    server. The MS partner that sold them Great Plains doesn't seem to know much
    about setting it up on SBS so I am testing it on a test server for the
    customer before they install it on their server. They will be using MSDE
    with Great Plains as they have SBS 2003 Standard. According to the GP
    documentation this is a supported configuration. When I installed the MSDN
    version of Great Plains 9.0 on my test server everything installed, I
    created a new MSDE instance, Great Plains found it and was happy. The
    problem occurred when I tried to backup the server. I couldn't use the SBS
    Backup or do manual backups with NTBackup. It failed when trying to create a
    shadow copy. The error was:

    Error returned while creating the volume shadow copy:0xffffffff.

    Searching the Internet and the MS KB gave me quite a few things to try to
    fix it but none of them worked. Uninstalling GP 9.0 and the MSDE instance
    then rebooting the server fixed it. I'm thinking it is the MSDE instance
    causing the problem. This is the command line I used to install MSDE

    setup SAPWD=password SECURITYMODE=SQL INSTANCENAME=GreatPlains

    This created a new instance called GreatPlains with the correct password. GP
    9.0 could connect to it OK.

    Have I setup MSDE wrong? Is there something I have to do other than this to
    get the backup working with the new instance of MSDE?
     
    Kerry Brown, Sep 16, 2006
    #1
    1. Advertisements

  2. Kerry Brown

    Mark Crall Guest

    I've had similar issues with running SQL 5 Express. The VSS MSDE writer
    fails.

    See http://support.microsoft.com/Default.aspx?kbid=912414

    For me the following process had the .\username format:

    SQL Server VSS Writer

    I changed that, restarted ALL sql related services and then ran a backup
    from the Server Manager. It hung for a while at "preparing to backup from
    shadow copy services" but then suddenly it started to copy data over.
    --

    Regards,
    Mark Crall, MCP
    Charlotte Tech Care Team
    Charlotte SBS Group Lead (www.sbs-charlotte.com)
    CITPG IT & Meetings Director (www.carolinait.org)

    Direct: (704) 248-8328 x33

    If you think installing patches and security updates is expensive, try not
    installing them.
     
    Mark Crall, Sep 16, 2006
    #2
    1. Advertisements

  3. Kerry Brown

    Kerry Brown Guest

    I did see that KB article and checked that the SQL service for the
    GreatPlains instance was running under the LocalSystem account. All the
    services for all the SQL instances were running with the LocalSystem
    account. I don't see the "SQL Server VSS Writer" service. Is it part of SQL
    2005 Express?

    Thanks for the help.
     
    Kerry Brown, Sep 17, 2006
    #3
  4. Kerry Brown

    Kerry Brown Guest

    I got it working. I don't know what the cause was or what fixed it but I now
    have a new instance of MSDE working and the SBS backup also works. I deleted
    all the leftover files from the other tries at installing a new instance. I
    then stopped the SBSMONITORING and SHAREPOINT instances as well as SQLAgent.
    The first time I tried to install a new instance the install quit with an
    error. A quick Google search didn't turn up anything that looked likely. I
    deleted the leftover files from this install and tried again with the exact
    same setup command. This time it installed with no errors. I set the new
    instance service to automatic and rebooted. I started SQLAgent for the new
    instance and set it to automatic. Both of these I had done on previous
    tries. I then tried NTBackup of the System State. It paused for a long time
    at the start where it says "Preparing to backup using shadowcopy". It
    stalled there for about fifteen minutes but this time the disk was being
    accessed continuously. Previously when it stalled here there was no disk
    activity. Then it started copying files and finished with no errors. I don't
    know if stopping the other MSDE instances was the fix but it was the only
    thing I did different from the previous tries.
     
    Kerry Brown, Sep 17, 2006
    #4
  5. Kerry Brown

    Kerry Brown Guest

    I spoke too soon. NTBackup worked until I rebooted again. Now it hangs at
    the same spot. No errors in the logs. It just hangs and I have to use the
    task manager to stop it. It doesn't matter if the new instance of MSDE is
    running or stopped. Another oddity with the new instance is the SQLAgent for
    it won't start. It did before the reboot. I think something is wrong with
    the MSDE instance. I can't use osql to logon with Windows or SQL
    authentication. The registry entry for the login mode was 0. Changing it to
    1 or 2 makes no difference. I'm going to give up for now and try again
    tomorrow. Any suggestions of things to try would be greatly appreciated.

    Thanks,
     
    Kerry Brown, Sep 17, 2006
    #5
  6. Kerry Brown

    Mark Crall Guest

    At this point I would encourage you (for more reasons than solving this
    issue) to consider putting Dynamics on another box. I know there is a large
    up-front cost associated with doing that but I believe in keeping LOB apps
    isolated to avoid exactly the problems you are having (shhhh... don't say
    this too loud on an SBS group ;-)).

    --
    Regards,
    Mark Crall
    Systems Engineer
    Charlotte Tech Care Team / Carolina VoIP
    Microsoft Small Business Specialist
    Charlotte SBS Group Leader - www.sbs-charlotte.com
    Direct: (704) 248-8328 x33

    If you think installing patches and security updates is expensive, try not
    installing them...
     
    Mark Crall, Sep 17, 2006
    #6
  7. Kerry Brown

    Kerry Brown Guest

    That was mine and the other MS Dynamics partner's suggestion from the start.
    The client is a non-profit society with limited funds. They are still
    recovering from the SBS install six months ago. I tried to talk them into a
    simpler accounting solution but the head of their accounting dept. is sold
    on Great Plains. They are presently using Accpac DOS so anything will be
    better. I'm going to try installing the SQL 2000 tools from an eval version
    and see if I can confgure the MSDE instance that way. Something is going
    wrong configuring it via the command line and registry.
     
    Kerry Brown, Sep 17, 2006
    #7
  8. Kerry Brown

    Kerry Brown Guest

    I got it almost working. The MSDE instance is installed and working. Great
    Plains 9.0 is installed and working on the server. The problem is clients
    can't connect to the MSDE instance on the server with SQL authentication. I
    can connect with Windows authentication from a client computer. I can
    connect from the server with SQL or Windows authentication. (i.e. osql -U sa
    logn on fine) I can set up the OBDC connection with SQL authentication. I
    installed Enterprise management on a client computer and connected with
    Windows authentication. The server shows that it is in mixed mode. I have
    restarted the service and rebooted the server several times. I'm pulling
    what little hair I have left out. Everything is working except client
    computers can't connect with sql authentication even though the MSDE
    instance is set for Windows and SQL.
     
    Kerry Brown, Sep 18, 2006
    #8
  9. Have you made MSDE network aware as when you set it up it is only for a
    single user. Go to the enterprise manager and right click on the instance
    and amend the network parameters to include netbios and tcpip.

    Test you connection on a client by creating a text file and calling it
    test.udl
     
    Robert Searle, Sep 18, 2006
    #9
  10. Kerry Brown

    Kerry Brown Guest

    I just tried Enterprise Manager from this computer. When I click on Network
    Configuration nothing happens. I did install the instance with
    DISABLENETWORKPROTOCOLS=0 and when I check the registry settings for the
    instance it looks like TCP and Named Pipes is set up. I'll install
    Enterprise Manager on the server tomorrow and see if that allows me to get
    into the Network Configuration.

    Thanks
     
    Kerry Brown, Sep 18, 2006
    #10
  11. Kerry Brown

    Kerry Brown Guest

    I had to change the port number for the instance. The default instance
    SBSMONITORING was also using 1433.
     
    Kerry Brown, Sep 19, 2006
    #11
  12. Kerry Brown

    Mark Crall Guest

    That solved it? Go figure.

    --
    Regards,
    Mark Crall
    Systems Engineer
    Charlotte Tech Care Team / Carolina VoIP
    Microsoft Small Business Specialist
    Charlotte SBS Group Leader - www.sbs-charlotte.com
    Direct: (704) 248-8328 x33

    If you think installing patches and security updates is expensive, try not
    installing them...
     
    Mark Crall, Sep 20, 2006
    #12
  13. Kerry Brown

    Kerry Brown Guest

    Once I realised what was happening I felt pretty dumb. Several hours of
    troubleshooting, messed up the test server once and had to restore from an
    image, and in the end it was something so basic it was one of the first
    things I should have tried.

    I guess that's why we use test networks before actually deploying something
    :)
     
    Kerry Brown, Sep 20, 2006
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.