SBS 2003 SP2 will not install KB961143

Discussion in 'Windows Small Business Server' started by R. Riddle, May 18, 2009.

  1. R. Riddle

    R. Riddle Guest

    I have the same issue as another posted earlier today however for what seems
    to be a different reason. Here is my 961143.log.

    Any ideas?

    1.516:
    ================================================================================
    1.516: 2009/05/18 12:18:15.152 (local)
    1.516:
    C:\WINDOWS\SoftwareDistribution\Download\323d85ff57a6f2eb856a208cd2ac95a6\update\update.exe (version 6.3.14.0)
    1.531: Failed To Enable SE_SHUTDOWN_PRIVILEGE
    1.594: Hotfix started with following command line: -q /Z
    /ParentInfo:dabb1d4b59326a4a81b1429d10c9c46f
    1.703: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with
    error 0x2
    1.797: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\KB961143 is not
    Present
    1.797: Condition succeeded for section ChkInstalled.Section in Line 1 of
    PreRequisite
    1.844: Return Value From IsSbs2003 = 1
    1.844: IsSbs2003 returned value( 0x1 ) which is Equal To 0x1
    1.844: Condition succeeded for section ChkSBS.Section in Line 2 of
    PreRequisite
    1.844: ServicePackNumber is Present
    1.844: SOFTWARE\Microsoft\SmallBusinessServer\ServicePackNumber is Equal To
    Specified Value
    1.844: Condition succeeded for section ChkSBSSP.Section in Line 3 of
    PreRequisite
    1.844: SOFTWARE\Microsoft\.NETFramework\policy\v2.0 is Present
    1.844: Condition succeeded for section ChkCLR20.Section in Line 4 of
    PreRequisite
    1.844: LangID is Present
    1.844: SOFTWARE\Microsoft\SmallBusinessServer\LangID is Equal To Specified
    Value
    1.844: Condition succeeded for section ChkLang.Section in Line 5 of
    PreRequisite
    6.641: In Function TestVolatileFlag, line 11825, RegOpenKeyEx failed with
    error 0x2
    6.641: In Function TestVolatileFlag, line 11857, RegOpenKeyEx failed with
    error 0x2
    6.641: ---- Old Information In The Registry ------
    6.656: Source:C:\Documents and Settings\All Users\Application
    Data\McAfee\Common Framework\UpdateDir
    6.656: Destination:
    6.656: ---- New Information In The Registry ------
    6.656: Source:C:\Documents and Settings\All Users\Application
    Data\McAfee\Common Framework\UpdateDir
    6.656: Destination:
    6.672: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with
    error 0x2
    6.672: SetProductTypes: InfProductBuildType=BuildType.IL
    6.672: SetAltOsLoaderPath: No section uses DirId 65701; done.
    6.828: DoInstallation: FetchSourceURL for
    c:\windows\softwaredistribution\download\323d85ff57a6f2eb856a208cd2ac95a6\update\update.inf failed
    6.828: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB961143$
    6.844: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed:
    0xe0000102
    6.844: BuildCabinetManifest: update.url absent
    6.844: Starting AnalyzeComponents
    6.844: AnalyzePhaseZero used 0 ticks
    6.891: OEM file scan used 0 ticks
    6.891: AnalyzePhaseOne: used 47 ticks
    6.891: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    6.891: AnalyzeComponents: Hotpatching is disabled.
    7.109: AnalyzePhaseTwo used 218 ticks
    7.109: AnalyzePhaseThree used 0 ticks
    7.109: AnalyzePhaseFive used 0 ticks
    7.109: AnalyzePhaseSix used 0 ticks
    7.109: AnalyzeComponents used 265 ticks
    7.109: Downloading 0 files
    7.109: bPatchMode = FALSE
    7.109: Inventory complete: ReturnStatus=0, 281 ticks
    7.109: Num Ticks for invent : 281
    7.109: Allocation size of drive C: is 512 bytes, free space = 55444236288
    bytes
    7.219: AnalyzeDiskUsage: Skipping EstimateDiskUsageForUninstall.
    7.219: Drive C: free 52875MB req: 5MB w/uninstall: NOT CALCULATED.
    7.219: CabinetBuild complete
    7.219: Num Ticks for Cabinet build : 110
    7.219: DynamicStrings section not defined or empty.
    7.234: FileInUse:: Detection disabled.
    8.234: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed:
    0xe0000102
    8.297: Num Ticks for Backup : 1078
    8.563: Num Ticks for creating uninst inf : 266
    8.578: Registering Uninstall Program for -> KB961143, KB961143 , 0x0
    8.578: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed:
    0xe0000102
    9.156: PFE2: Not avoiding Per File Exceptions.
    9.375: GetCatVersion: Failed to retrieve version information from
    C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\KB961143.cat with error 0x57
    9.672: Copied file:
    C:\WINDOWS\$NtUninstallKB961143$\spuninst\SetAuthProviders.exe
    9.750: DoInstallation: Installing assemblies with source root path:
    c:\windows\softwaredistribution\download\323d85ff57a6f2eb856a208cd2ac95a6\
    9.750: Num Ticks for Copying files : 1187
    9.750: Num Ticks for Reg update and deleting 0 size files : 0
    9.750: Starting process: SetAuthProviders.exe /install
    9.750: Working directory: C:\WINDOWS\$NtUninstallKB961143$\spuninst
    13.141: Return Code = 4294967295
    13.141: DoInstallation:RunInfProcesses for ProcessesToRun Failed
    13.141: KB961143 Setup encountered an error: An error in updating your
    system has occurred.
    13.203: An error in updating your system has occurred.

    Select 'OK' to undo the changes that have been made.
    13.203: Starting process:
    C:\WINDOWS\$NtUninstallKB961143$\spuninst\spuninst.exe /~ -q -z
    14.500: Software Update Rollback has completed successfully. The original
    error message was: 0x1
     
    R. Riddle, May 18, 2009
    #1
    1. Advertisements

  2. Hello,

    Thanks for your post.

    First of all, I would like to ask do you have any trouble visiting and using Companyweb on the SBS server or from the client computers? Have you tried
    manually download and install this update?

    If not, I'd like suggest you manually downloaded from the following KB article and manually install it from your local disk to have a try.

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=961143&kbln=en-us

    Now, please try again to use Admin account to install the downloaded update which named "SBS2003SP1-KB961143-X86-ENU.EXE"

    More information:

    Error message when you access the http://companyweb Web site in Windows Small Business Server 2003: "HTTP 401.1 - Unauthorized"
    http://support.microsoft.com/kb/961143/en-us

    However, if the update still cannot be installed manually, you may try the following suggestions to troubleshoot it:

    1. Disable antivirus, antispyware, and third-party firewall programs
    Please temporarily disable any antivirus, antispyware, and third-party firewall programs and try to install the update again.


    2. This issue may occur The Application Pool was not configured correctly.
    Please open IIS console and then Companyweb node under Web Sites, check if the Home Directory tab of companyweb to see if it is using a different
    AppPool other than DefaultAppPool. If so, change it to use the DefaultAppPool. Then run IISReset command to restart IIS.

    After that, please try to install the update again.


    3. If the issue persists, you may consider modify the following registry keys which listed in KB896861 article, it addressed internal website authentication
    issue. Note, please backup the "Lsa" key before you do any modification.

    Open Registry Editor and locate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    Create the reg dword "DisableLoopbackCheck" under Lsa and gave it a value of 1.
    Quit Registry Editor, and then restart your computer.

    For more information, please check KB896861.

    You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or IIS 6
    http://support.microsoft.com/kb/896861/en-us

    Hope this helps.




    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support

    ==================================================================
    Please post your EBS related questions to the EBS newsgroup on Connect website:
    https://connect.microsoft.com/ebs08/community/discussion/richui/default.aspx

    If you want to use a newsreader other than a web forum to access these newsgroups,
    please refer to the following blog to apply NNTP password and configure a newsreader:
    http://msmvps.com/blogs/bradley/archive/2008/11/02/signing-up-for-the-sbs-2008-newsgroups.aspx
    ==================================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ==================================================================
     
    Robbin Meng [MSFT], May 19, 2009
    #2
    1. Advertisements

  3. R. Riddle

    R. Riddle Guest

    I'm working on this now however I cannot reboot the machine until this
    evening. I'm going to try to run the SBS set again for the intranet and
    monitoring tools. I think it will fail because I've updated SharePoint. Does
    anyone have any suggestions how to get the intranet re-installed with an
    updated sharepoint installation?


     
    R. Riddle, May 19, 2009
    #3
  4. R. Riddle

    R. Riddle Guest

    I cannot get the SBS setup to run. It bombs out due to an issue with trying
    to load a service pack mssql 2000. I'm running 2005 now. Not sure yet how to
    proceed. Does anyone know if there is a reference somewhere on how to reload
    components of SBS 2003 whith a fully updated server? Seems the updates are
    keeping it from installing and I'm not sure how to get updated install files.

     
    R. Riddle, May 20, 2009
    #4
  5. Hello,

    Please check if the following articles help:

    How to restore a Windows SharePoint Services 2.0 CompanyWeb database after the intranet component and SQL Server or MSDE 2000 have been
    removed on Windows Small Business Server
    http://support.microsoft.com/kb/829113/en-us

    How to remove and how to install the Windows Small Business Server 2003 SharePoint Services 2.0 companyweb Web site
    http://support.microsoft.com/kb/829114/en-us

    Windows SharePoint Services components may be deleted after you reinstall the Intranet component of Windows Small Business Server 2003 SP1
    http://support.microsoft.com/kb/909988/en-us

    Hope it helps.


    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support
     
    Robbin Meng [MSFT], May 21, 2009
    #5
  6. R. Riddle

    R. Riddle Guest

    Hi Robbin. Thank you for helping here. The first link did not pertain to me,
    however the second link did. I follwed the steps and received this error
    after attempting to reinstall the intranet:

    "MSDE 2000 Service Pack 4 did not install. For additional instructions, see
    the SQL Server 2000 Service Pack Web site at
    http://go.microsoft.com/fwlink/?LinkId=46241."

    This error was listed under the "Server Configuration" error messages and
    under the "Intranet" error messages I found this:

    "An error occurred while installing Windows SharePoint Services and creating
    your intranet site."

    Not sure where to go from here. I'm running MSDE 2005. Will that cause this
    problem?
     
    R. Riddle, May 22, 2009
    #6
  7. Hello,

    Thanks for your post.

    Did you ever installed SharePoint Services 3.0 on the SBS server? If so, did you do a inplace upgrade or a side-by-side installation over 2.0? Please be
    assured, we much install WSS 3.0 side-by-side with WSS 2.0.

    Regarding the error message you encountered when installing/viewing companyweb website, please refer to the following articles to apply KB832880
    update:

    This critical update corrects the issue "Installation of intranet component and browsing to http://companyweb fail in Windows Small Business Server
    2003"

    Critical Update for Windows Small Business Server 2003 (KB832880)
    http://www.microsoft.com/downloads/...FamilyID=cb7e90a1-de9d-4a83-85f8-951e9f055bf0


    Windows SharePoint Services and Windows Small Business Server 2003 Installation Update(Frequently Asked Questions)
    http://www.microsoft.com/windowsserver2003/sbs/techinfo/sharepointinstall.mspx

    More information about installing WSS 3.0 on SBS 2003, please see:

    Installing Windows SharePoint Services 3.0 on a Server Running Windows Small Business Server 2003
    http://www.microsoft.com/downloads/...81-EFFF-4F5B-A28A-8265F1E99F5B&displaylang=en

    How to install Windows SharePoint Services 3.0 side-by-side with Windows SharePoint Services 2.0 on a computer that is running Windows Small
    Business Server 2003
    http://support.microsoft.com/kb/928095/en-us

    Installing Windows SharePoint Services 3.0 on a Server Running Windows Small Business Server 2003
    http://technet.microsoft.com/en-us/library/cc671966.aspx


    Hope this helps.


    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support
     
    Robbin Meng [MSFT], May 25, 2009
    #7
  8. R. Riddle

    R. Riddle Guest

    Yes 3.0 was installed a while back however it has since been removed and I do
    not know if it was a side by side or an update to the existing 2.0. My
    problem now is when I try to install the Intranet or the Monitoring from the
    CD's I get an error about MSDE2000 sp4 could did not install correctly. I've
    tried eveything I could find to fix that problem however it still fails. As
    it stands right now I've removed the intranet, monitoring and all sharpoint
    installations. I'm still unable to get the intranet and monitoring to
    install. I'm not sure if MSDE2000 SP4 is the main reason or just 1 reason why
    it will not install. I'm trying to work this out however so far everything
    I've come up with has landed me in the same situation.
     
    R. Riddle, May 28, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.