SBS 2008 Sharepoint - Error 2424 & Warning 2436 every 5 minutes

Discussion in 'Windows Small Business Server' started by RJeremy, Jul 22, 2009.

  1. RJeremy

    RJeremy Guest

    RJeremy, Jul 22, 2009
    #1
    1. Advertisements

  2. Try eventid.net - or one of us could try it for you, but you'll need to
    copy/paste the error from even viewer so it's complete.
     
    Les Connor [SBS MVP], Jul 22, 2009
    #2
    1. Advertisements

  3. RJeremy

    Leythos Guest

    This is a very common error and MS doesn't have a patch for it, but
    there is a manual solution - I don't have the details on how to fix it,
    but every SBS2008 machine I've installed does this after installing all
    updates.
     
    Leythos, Jul 22, 2009
    #3
  4. Hello,

    Thank you for posting here.

    According to your description, I understand that:

    You receive the Event 2436, 2424 about WSS 3.0 on the SBS 2008 server.

    If I have misunderstood the problem, please don't hesitate to let me know.

    Suggestions:
    ======================
    First of all, please provide the exact error message of the Event 2436,
    2424.

    1. Check on which account Windows Sharepoint search is running (Properties
    ->logon tab). Please make sure that the account is a member of local admin
    , iis_wpg,wss_wpg,wss_wpg_admin and wss_wpg_restricted_admin.

    2. Set the BackConnectionHostNames registry value.


    a. Click Start, click Run, type regedit, and then click OK.
    b. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    c. Right-click MSV1_0, point to New, and then click Multi-String Value.
    d. Type BackConnectionHostNames, and then press ENTER.
    e. Right-click BackConnectionHostNames, and then click Modify.
    f. In the Value data box, type the URL mentioned in the above warning
    event, plus sites and companyweb (on separate lines) and then click OK.
    g. Quit Registry Editor, and then restart the IIS service.


    3 .Open command prompt with admin privileges and switch to

    c:\program files\common files\Microsoft shared\Web server extensions\12\Bin
    and run the following command to check how it works.

    "stsadm -o spsearch -action fullcrawlstart" (without quotes)

    If you have any questions or concerns, please do not hesitate to let me
    know.



    Best regards,

    Miles Li

    Microsoft Online Newsgroup Support

    ==================================================================
    Please post your SBS 2008 related questions to the SBS newsgroup on Connect
    website:
    https://connect.microsoft.com/sbs08/community/discussion/richui/default.aspx


    Please post your EBS related questions to the EBS newsgroup on Connect
    website:
    https://connect.microsoft.com/ebs08/community/discussion/richui/default.aspx


    If you want to use a newsreader other than a web forum to access these
    newsgroups,
    please refer to the following blog to apply NNTP password and configure a
    newsreader:
    http://msmvps.com/blogs/bradley/archive/2008/11/02/signing-up-for-the-sbs-20
    08-newsgroups.aspx
    ==================================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ==================================================================
     
    Miles Li [MSFT], Jul 23, 2009
    #4
  5. RJeremy

    RJeremy Guest

    Hello Miles,

    Thank you for your response and apologies for the delay in my post.

    I have followed your solution below and the 2424 and 2436 seem to be gone,
    hopefully, forever. Its a been a day without them re-occuring.

    Now however, I am getting DCOM errors in my event logs, a copy of the error
    below:

    Log Name: System
    Source: Microsoft-Windows-DistributedCOM
    Date: 2009/11/04 02:00:03 AM
    Event ID: 10016
    Task Category: None
    Level: Error
    Keywords: Classic
    User: NETWORK SERVICE
    Computer: MSERVER01.company.local
    Description:
    The application-specific permission settings do not grant Local Activation
    permission for the COM Server application with CLSID
    {61738644-F196-11D0-9953-00C04FD919C1}
    to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address
    LocalHost (Using LRPC). This security permission can be modified using the
    Component Services administrative tool.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Microsoft-Windows-DistributedCOM"
    Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="49152">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-11-04T00:00:03.000Z" />
    <EventRecordID>455935</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>MSERVER01.company.local</Computer>
    <Security UserID="S-1-5-20" />
    </System>
    <EventData>
    <Data Name="param1">application-specific</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{61738644-F196-11D0-9953-00C04FD919C1}</Data>
    <Data Name="param5">NT AUTHORITY</Data>
    <Data Name="param6">NETWORK SERVICE</Data>
    <Data Name="param7">S-1-5-20</Data>
    <Data Name="param8">LocalHost (Using LRPC)</Data>
    </EventData>
    </Event>

    I have followed the solution at
    http://geekswithblogs.net/mhamilton/archive/2006/12/19/101568.aspx and I will
    wait a day before checking if these errors re-occur. In my case, it was also
    the IIS WAMREG admin service that popped up when I followed the article's
    instructions.

    I will post my results tomorrow.
     
    RJeremy, Nov 4, 2009
    #5
  6. RJeremy

    RJeremy Guest

    Well, all seems to be good. No further errors. Thanks for you help.
     
    RJeremy, Nov 5, 2009
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.