[SBS 2008] Sharepoint only works viaLocalhost.

Discussion in 'Windows Small Business Server' started by Mike W., May 18, 2010.

  1. Mike W.

    Mike W. Guest

    I've just installed WSS 3.0 on SBS2008. (Well, when I say "install," I really
    mean that I ran the hands-off configuration utility in SBS2008.)

    My goal with this Sharepoint server is to allow myself access from the
    Internet. Right now, however, I can only raise the Sharepoint site by
    pointing a browser on the server itself to:

    https://localhost:987/

    There are some external hostnames that, I believe, were automatically setup
    by the wizard, but when I attempt to use that external hostname on the
    server, I am prompted for credentials three times then taken to a blank page.

    This is my first installation of WSS. So, I am quite lost and scared. Ok,
    maybe not scared, but hold me.

    m
     
    Mike W., May 18, 2010
    #1
    1. Advertisements

  2. You probably just need to install the latest updates. For this issue
    specifically, get SBS 2008 Update Rollup 4 KB 979454.

    979454 Description of Windows Small Business Server 2008 Update Rollup 4
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;979454

    If it's the fix I am thinking of, it first went into UR2, so the summary of
    UR4 will not mention it. The UR's are cumulative so you only need to install
    the latest one.

    I would also recommend getting the latest Exchange 2007 Update Rollup as
    well.

    Hold off on WSS 3.0 SP 2 until you read this:
    http://blogs.technet.com/sbs/archiv...repoint-connectivity-failure-in-sbs-2008.aspx
     
    Chris Puckett [MSFT], May 18, 2010
    #2
    1. Advertisements

  3. Mike W.

    Mike W. Guest

    Hey Chris and all,

    I ran through the HotFix and read the KB article re: SP2. I feel a little
    better about the situation personally, but I'm probably in the same boat.

    I ran the HOTFIX as I already had WSS SP2 and Update Rollup 4.
    Interestingly, the article about WSS SP2, notes that I should install WSS SP2
    after the hotfix, but I can't tell if it means I should _reinstall_ the
    HotFix, or leave as-is. I don't pretend to understand everything I've read.

    Here's how I can break it down when trying to access the MAIN Sharepoint site.

    https://SERVER1:987 -- No Credential Prompt / Accessible
    https://localhost:987 -- No Credential Prompt / Accessible

    https://server1.domain.local:987 -- Credential Prompt (3x) / Blank Page
    https://server1.domain.net:987 (External) -- Credential Prompt (3x) / Blank
    Page

    Now, I noticed something else. When I try to access the the Central
    Administration page, I access the FIRST page fine, but if I click, say,
    Application Management, the URL gets changed into the internal FQDN and I am
    prompted for credentials three times with no effect.

    On the other hand, if I access the Central Administration page in Firefox as
    opposed to IE, the URL doesn't get changed when I click links and I can
    access the CA's internal pages.

    I should mention that in trying to fix this over the last couple of days,
    I've looked at Authentication within IIS several times for the Sharepoint
    site. I've also looked at Alternative Access. I can't say whether anything
    I've done in these places have caused further problems.

    My plan is to use WSS over SSL only. I have an externally qualified cert
    tied to a certain hostname and I'd like to eventually use that for all
    Sharepoint access from the Internet. (The server sits at a remote location.
    There are no local workstations. My partner and I will access Sharepoint
    remotely via https.) I should note that the CURRENT external URL that's tied
    to sharepoint is the _wrong_ hostname. It's remote.domain.net, but it should
    be buddy.domain.net. I am unsure where to change this.

    My IIS is a bit altered to suit our needs. I have another site running on
    port 80, so disabled the binding to 80 for sharepoint. I've also got a few
    host headers and one redirect to OWA when people type
    "http://outlook.domain.net" from the outside.

    Thanks everyone.
     
    Mike W., May 19, 2010
    #3
  4. The hotfix can be installed before or after WSS SP2. You do not need to
    reinstall WSS SP2 afterwards. The point of installing it before is to
    prevent a configuration failure that can occur when the Sharepoint Products
    and Technologies wizard runs right after WSS SP2. Since you have WSS SP2
    already installed and companyweb works, you can leave it as is.

    What happens if you use https://remote.domain.net:987 to access the
    Sharepoint site? Does that work?

    It's possible that the configuration changes you have made have resulted in
    this behavior, but let's start with remote.domain.net and buddy.domain.net.
    To fix this, you should re-run the Internet Address Management Wizard. On
    the page where it asks for your domain name, type that in, but do not click
    Next yet. There is a link below the box that says Advanced Settings. Click
    that and specify the host name, buddy. Then complete the wizard.

    Now try to browse https://buddy.domain.net:987 to access the Sharepoint
    site? Does that work?

    --
    Chris Puckett

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Chris Puckett [MSFT], May 19, 2010
    #4
  5. Mike W.

    Mike W. Guest

    I think I may be all set for now.

    I got an inkling elsewhere that I might have troubles with this because my
    alternate access settings were messed up. I wasn't sure and I didn't really
    understand the feature, so I looked it up.

    I found this article:
    http://certcities.com/editorial/columns/story.asp?EditorialsID=370

    So, following that, I made an Intranet rule and an Internet rule. I then
    altered my host headers for the correct external URL coming in from the
    outside. I then iisreset. Lastly, I punched a hole in the firewall to allow
    987 into the org and can now browse Sharepoint and interact with it.

    The latest thing I have to overcome is changing the automatic log-off time.
    It's a little too short for my tastes! :)

    But that's a different topic.

    Thanks!



    :
     
    Mike W., May 20, 2010
    #5
  6. Chris Puckett [MSFT], May 20, 2010
    #6
  7. Mike W.

    Mike W. Guest

    Thanks! I'm not too sure I'll need it as we're primarily interfacing with
    documents on the server via Word 2010.
     
    Mike W., May 20, 2010
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.