SBS2003 + Outlook 2007 with SP2 + Vista Pro with SP2 / network saveproblem.

Discussion in 'Windows Small Business Server' started by Pitti, Apr 26, 2010.

  1. Pitti

    Pitti Guest

    Hello,

    First, sorry about my bad english.

    So here is the problem, and some background info.

    OS: Windows Vista Pro 32-bit with SP2
    Office: Office 2007 SBE with SP2 (includes Outlook)
    Server: Small Business Server 2003 Premium (Updates and Service Packs done)
    Adobe Reader 9.3.2 installed in Vista workstation(if it matters)

    Problem: When receiving email to Outlook with attachment (example, pdf,
    jpg, about 4Mb and larger), cannot save it to the network location
    (mapped drive). It is possible to save local disk (example C:\Test -
    folder).
    When tried to save to network location, Outlook starts to saving
    attachment, but takes about 30 second, and then comes pop up info
    "cannot save the attachment". Then I checked to the network drive, and
    there is *.tmp-file which is same size as attacment that I tried to save.

    I all ready tried to clean Outlook temp-folder, but no help.
    I also tried to Re-register a .dll by clicking Start/Run then type
    regsvr32.exe ole32.dll
    And I also make change to Vista workstation, that SMB2.0 changed to
    SMB1.0, that helped *.xls-attachments, but not example *.pdf-files.

    So any help is really welcome here.
    If some more information is needed, I will happily give it.

    Best Regards,
    Pitti
     
    Pitti, Apr 26, 2010
    #1
    1. Advertisements

  2. Pitti,

    You've attempted quite a few support steps. What articles (links) did
    you follow to make these changes?

    My initial feelins is the AV may be scanning the attachment on your
    end as it saves it to the server. I've seen this problem in the past
    with CA Antivirus. It was corrected by not allowing it to scan network
    drives both on the server and the workstation AV policies.

    Have you seen the following link? I think it may help.
    http://social.technet.microsoft.com.../thread/c58ac4a5-16b7-4531-973d-30229ba29e5c/


    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and confers no rights.

    Please reply back to the newsgroup or forum for collaboration benefit among responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    If you feel this is an urgent issue and require immediate assistance, please contact Microsoft PSS directly. Please check http://support.microsoft.com for regional support phone numbers.
     
    Ace Fekay [MVP - Directory Services, MCT], Apr 26, 2010
    #2
    1. Advertisements

  3. Pitti

    Pitti Guest

    Hello Ace,

    Thanks about fast reply.

    Sorry, but I don't have those links saved, but I have been done lot of
    googling.
    I have been seen, that there are similar problems available, but no
    solutions yet found.

    Antivirus-program is Microsoft Forefront Client Security, and I tested
    it (disabled from workstation and server both), but no help, still
    Outlook gives error on workstation, that it can't save the attachment to
    mapped drive (B39A3F14.tmp file was created to the server, and it's size
    was exactly same as *.pdf-file, what was tried to save).

    I also checked the link you send, and there are few good ideas.
    I only deleted files in Outlook Secure Temp folder, not Temporary
    Internet Files and other Temp-folders in workstation, have to try that
    for next.

    When done that, will give feedback.

    Best regards,
    Pitti
     
    Pitti, Apr 27, 2010
    #3
  4. Pitti

    Pitti Guest

    Info update,

    Vista workstation: deleted Temporary Internet Files + Outlook Security
    Temp + User Profile Temp + Windows\Temp - folders files, and after that
    started Outlook and tried to save attachment to mapped drive = no help,
    still error, and *.tmp - file on server.

    Tried to save 4MB and larger files -> always *.tmp - file on the server,
    and tmp-file size is same as attachment size.
    Tried to save *.pdf - file, and then tried to rename *.tmp - file on the
    server to *.pdf, and after that tried to open with Adobe Reader. Reader
    just said that the file is corrupt.

    Network is 100Mb between workstation and server, ping goes nicely to the
    server (ping server.domain.local, so this this ping does DNS resolving).
    Monitored network traffic when saving Outlook attachment to the server
    -> immediatelly when pressing save-button, the network traffic rices to
    about 25%, and then really fast goes down to 0%, then Outlook wait about
    30 second, and after all Outlook gives the error, can't save the
    attachment. There also goes the infobar, tha Outlook is saving file, but
    the bars indicator doesn't move, and stays about 10% place.

    Best Regards,
    Pitti
     
    Pitti, Apr 27, 2010
    #4
  5. Unfortunate to hear that. So you've disabled all antivirus,
    anti-malware, firewalls, etc, before testing it, then cleared the temp
    and secure temp locations, and it still doesn't allow to save it to
    the Temp location?

    Can you save it elsewhere, such as to your My Documents?

    Ace
     
    Ace Fekay [MVP - Directory Services, MCT], Apr 27, 2010
    #5
  6. Pitti

    Pitti Guest

    Hello Ace,

    I disabled all Antivirus (no other Antispyware-software installed to the
    workstation), but didn't disabled Windows own firewall (no other
    Firewall-software installed), should I test that too?

    Yes, I can save the big attachment locally example to C:\Test-folder,
    and then copy to the server mapped drive with explorer, no problem.
    Also can save it to My Documents, no problem.

    Best Regards,
    Pitti
     
    Pitti, Apr 27, 2010
    #6
  7. Since it is a mapped drive, was AV also disabled on the server where
    the share is located?

    What we did to figure out a similar issue with Power Point saving to a
    network share, we had to use Process Explorer. We figured out from
    using it, that the AV process was intercepting the call to transfer
    the data to the share. When we disabled Network Scanning of Drives on
    both the workstation AND the server, only did the problem go away.

    If you decide to use Process Explorer, keep in mind, the output can be
    overwhelming. You see every process running. You may see 30-50
    processes in some cases, running within one (1) second. You have to
    run it, then try to save, then stop it, then read the log. It can get
    tedious.

    Process ExplorerProcess Explorer, also known as procexp.exe, shows you
    information about which handles and DLLs processes have opened or
    loaded.
    http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

    Ace
     
    Ace Fekay [MVP - Directory Services, MCT], Apr 29, 2010
    #7
  8. Pitti

    Pitti Guest

    Hello Ace,

    I haven't tried Process Explorer yet, but will in next week.

    I think, that this information could be important.
    Small Outlook attachments are saving to servers mapped drive just fine,
    no problem (tried 45KB PDF-attachment), but when attachment is larger,
    for example 2MB, Outlook gives error that it cannot save attachment to
    mapped drive.

    Windows Vistas own firewall is on and has exception, that Outlook can
    communicate to network, and no other firewall software is installed to
    workstation.

    Best Regards,
    Pitti / Jani
     
    Pitti, Apr 30, 2010
    #8
  9. Is there possibly a quota set at the location it's trying to download
    to?

    Ace
     
    Ace Fekay [MVP - Directory Services, MCT], May 1, 2010
    #9
  10. Pitti

    Pitti Guest

    Hello Ace,

    I checked the servers quota settings, there are two disks C- and D-drive
    and neither has no quota settings on.
    So user can save so much data that they want.

    That was a good point!

    Best Regards,
    Pitti / Jani
     
    Pitti, May 2, 2010
    #10
  11. It was just something else that came to mind. Otherwise, I am at a
    loss with the save issue. Sorry...


    Ace
     
    Ace Fekay [MVP - Directory Services, MCT], May 2, 2010
    #11
  12. Hello Pitti,

    Thanks for your post and Ace's good suggestions.

    Meanwhile, just my two cents, I also would like to confirm with you that:

    1. Does this issue only occurs to certain client computer or to all Outlook clients? Please help to confirm.
    2. Have you checked the shared folder's NTFS and sharing permission? Or tried another network shared folder with other locations?

    If it only occurs to certain Outlook client, please try to create a new Outlook profile to test the issue again or use OWA to try to save attachment and see if it changes.

    How to create a new e-mail profile in Outlook 2007 and in Outlook 2003
    <http://support.microsoft.com/kb/829918/en-us>

    If it works when saving to other network locations, then please double check and make sure "Everyone" group has Full control over the shared folder's NTFS and Sharing
    permission.

    Hope this helps.


    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support
     
    Robbin Meng [MSFT], May 5, 2010
    #12
  13. Pitti

    Pitti Guest

    Hello Robbin,

    Thanks for reply!

    Sorry about my long delay to answer.

    1. Yes, this does only occur on one client computer. In same office has
    this one Vista computer, and two Window 7 computers, and many Windows XP
    computers, only this one Vista computer has this Outlook problem.

    2. I have been checked NTFS-permissions, and also Share-permissions,
    they are OK. This Vista computer can save those attachments locally,
    example C-drive, and then attachment can copied to servers mapped drive
    with Explorer (copy, paste). Error only occurs when saving attachment
    directly Outlook to servers mapped drive.

    I have been crated brand new Outlook profile, but still getting same
    error, when saving attachment that is bigger than 2MB.

    I haven't tried yet saving with OWA, but I will.

    If more ideas are available, just send it.

    Best regards,
    Pitti / Jani
     
    Pitti, May 12, 2010
    #13
  14. Hi Pitti,

    Glad to get your response and thank you for letting me know the current situation.

    So it is apparently a particular Outlook client or Windows Vista workstation issue. Please go on to test with OWA to save attachments. If OWA works, try to open Outlook with "/Safe"
    switch to load Outlook in its Safe Mode so that it doesn't load any add-ins and extensions component.

    Command-line switches for Microsoft Office Outlook 2007
    http://office.microsoft.com/en-us/outlook/HP012185891033.aspx

    Please take your time to have a try and post if any help needed.


    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support
     
    Robbin Meng [MSFT], May 12, 2010
    #14
  15. Pitti

    Pitti Guest

    Hi Robin,

    First, I am really sorry this long delay to post again to this forum!

    Well, this problem still exists, and I haven't found any solutions.
    I have been test to uninstall Office 2007 package (word, excel, outlook,
    everything), and then booted workstation, and installed Office 2007 back
    to workstation. Everything else worked fine (word, excel,,,), but
    Outlook cannot save attachment to network server. I also installed
    Office 2007 SP2, but no difference. Outlook always says "Cannot save
    attachement", when trying to save to network server. Outlook can save
    attachment locally, example C-drive.

    After that I uninstalled Outlook 2007, and left other Office programs
    still in the workstation (word, excel,,,). Then I installed Outlook 2003
    to the workstation, and tested to save attachment to network, but no
    luck, even Outlook 2003 gives error that it cannot save the attachment.
    Also installed Office 2003 SP3.

    Workstation has Vista Business, and every Microsoft update-packages are
    installed.

    If someone has clue for this, I really, really need help.

    Best Regards,
    Pitti
     
    Pitti, Jun 20, 2010
    #15
  16. Hi Pitti,

    Thanks for writing back to me. I understand the issue persists after you have reinstalled Office 2007 including Outlook 2007 or Outlook 2003 on that Windows Vista Business
    workstation.

    1. Have you tried saving to another shared network location instead of the original place? And the same thing occurs?
    2. Have you tried OWA to save the attachment instead of Outlook 2007, so that we can tell if this is a Outlook program or Windows Vista system issue?

    If the issue always occurs, let's test if it also occurs under Windows Vista "Clean Boot" mode. Please follow below steps:

    Clean boot
    =================
    Let's disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform
    the following steps:

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when
    Windows starts" box and click OK.

    Please restart the computer and test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly
    narrow down which entry is causing the issue.

    For more information about this step, please refer to the following KB article:

    How to troubleshoot a problem by performing a clean boot in Windows Vista
    http://support.microsoft.com//kb/929135

    Hope this helps.



    Best regards,
    Robbin Meng(MSFT)
    Microsoft Online Newsgroup Support
    ==================================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ==================================================================
     
    Robbin Meng [MSFT], Jun 21, 2010
    #16
  17. Pitti

    Pitti Guest

    Hello,

    Just information, I did format the problem computer, and removed Vista +
    installed Windows 7.
    Now everything looks like working, of course.

    Sorry, that I couln´t solve this, even with great support, Thanks for
    everyone.

    Best Regards
    Pitti
     
    Pitti, Jul 7, 2010
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.