Screen corruption - ATi Radeon 9550 AGP w/Vista Ultimate

Discussion in 'Windows Vista Hardware' started by John, May 1, 2007.

  1. John

    John Guest

    I have just installed Vista Ultimate with the latest Catalyst display
    drivers and latest Hyperion chipset drivers for my VIA KM400-based Athlon
    motherboard. I have a lot of garbage on the screen and don't know how I can
    get rid of it. My machine was reported as being Vista capable. The computer
    doesn't lockup or anything and runs fine, but the screen corruption is very
    difficult to cope with. The graphics card is not damaged and runs fine with
    XP.

    Anything that can I do to try to improve the situation? I have not activated
    Vista yet and can get back to XP as I have no problem with this OS.
    A decrease in graphics performance, as a last resort, would be an acceptable
    solution.

    Thanks

    John
     
    John, May 1, 2007
    #1
    1. Advertisements

  2. What happens if you use the default Microsoft drivers? There shouldn't be a
    compatibility problem with that setup, though. If the default MS drivers
    work, you may try some older Catalyst drivers. The older cards are sometimes
    picky on which drivers work and which ones don't.
     
    Dustin Harper, May 1, 2007
    #2
    1. Advertisements

  3. John

    John Doe Guest

    The drivers that come with Vista produce the same effect. I also had
    the same effect without the Hyperion chipset drivers installed.
    At the moment I am trying out my system with AGP speed set to 4X
    (instead of 8X) and an aperture size of 64M instead of 128. Fingers
    crossed.
     
    John Doe, May 2, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.