Seagate ST3300622AS-RK SATA HDD being detected as wrong Model HDD

Discussion in 'Windows Vista Hardware' started by JohnnyGFX, Feb 7, 2007.

  1. JohnnyGFX

    JohnnyGFX Guest

    I am in the process of helping a friend of mine with his Vista Home Premium
    (mine is working great).

    The problem is that it is detecting and loading drivers for his HDD that are
    wrong.

    Vista thinks the HDD is a ST330062 2AS SCSI HDD

    In reality the HDD is a ST3300622AS-RK (SATA) drive

    I have been racking my brain trying to figure out how to get around this
    problem, but so far I have come up with no solution. Has anyone had this same
    problem and how did you manage to fix it.

    Motherboard is an Asus p4s800d-x

    After booting up with the drive plugged into the SATA slot, Vista shows it
    in the device manager and lists it as 'working properly' but no where else
    does it show (not in the explorer or in the Administrative Disk Management
    tools).

    I even had him try it in his secondary SATA connection and got the exact
    same result.

    Any help would be greatly appreciated and I will be happy to provide any
    additional details that might be necessary to find/fix the issue.
     
    JohnnyGFX, Feb 7, 2007
    #1
    1. Advertisements

  2. JohnnyGFX

    pete Guest

    My Sata HD showed as that until I loaded the SATA drivers.........
    What does it show In Device Manager under Storage Controllers???
    peter
     
    pete, Feb 8, 2007
    #2
    1. Advertisements

  3. I've seen zillions of questions about SATA drives and Vista. Since I
    was in the same boat, I'll share a simple solution. Go to BIOS,
    carefully step through all the options and write down the setting as
    they are now for SATA, then change to IDE. The SATA drive should work
    fine under IDE mode.

    Is this a new drive or one that has already been formatted? If it has
    been formatted, and shows up in Device Manager but not anywhere else
    AFTER you try changing to IDE mode, go back to Device Manager and
    simply remove the drive. Do not physically remove the drive from the
    system. Immediately reboot. Windows should reinstall the drive and say
    it found new hardware right after it boot up.

    Windows is a dumb beast and will often misname devices. I once had a
    external drive case with a SATA drive inside. Windows saw it, but said
    it had 0 capacity, which was strange since it was a formatted disk and
    had about 50GB of data on it and worked fine if I plugged it into any
    of the internal connectors. The kicker was every time I tried to
    access it it when in the external encloser Windows said insert blank
    disk. That's a pretty hard trick to do to a hard drive. Windows
    thought it was one of those old zip disk drives. Simple fix, just
    replaced the encloser with a different brand.
     
    Adam Albright, Feb 8, 2007
    #3
  4. JohnnyGFX

    JohnnyGFX Guest

    We tried that method as well. It's a it's a SIS 180 something or other
    controller. I tried the latest version of the driver from Asus for the RAID
    controller (which I think doubles as the SATA driver since I can't find an
    actual SATA driver for the motherboard). I also tried the newer driver
    directly from SIS. The drivers allegedly install correctly, but even after
    deleting the drive from the Device Manager and rebooting, it was still
    detected as a SCSI drive.

    I'm not sitting in front of my friend's computer at the moment so I can't
    confirm this, but he is telling me that the BIOS does not allow him to change
    any settings other than SATA On Chip Controller Enabled or Disabled. I even
    had him try the latest beta bios to see if that could help with the issue.

    The thing is... this drive worked perfectly fine in XP. But now in Vista
    it's being detected wrong, which leads me to believe that this is an issue
    with Vista and it's SIS SATA drivers (or the ones available anyway).

    My friend claimed that he went through every single option in his BIOS to
    try and find a way to change the SATA to IDE mode, but was unable to find a
    method to do it on the motherboard. I haven't been able to make it to his
    house to look myself, but he absolutely insists that the option is not
    anywhere.

    So... needless to say, the problem still exists and we've been unable to
    solve it so far.
     
    JohnnyGFX, Feb 8, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.