Searchindexer.exe hogs CPU

Discussion in 'Windows Vista Performance' started by Wolffoley, Sep 17, 2009.

  1. Wolffoley

    Wolffoley Guest

    We run Vista home premium on a Dell Dimension E521. Last spring ou
    system slowed way down--we didn't know why. We backed everything up an
    reloaded the system. It worked well for about 2 months. Now the CPU i
    running consistently at 100%, and we finally discovered that it i
    Searchindexer.exe. We "end process" three times, and it will turn of
    each time, but restarts after the first two times. By the third time, i
    stays off. In Control Panel=> Indexing options, it says "Indexing is no
    running" even when Searchindexer is hogging all the memory. Are thes
    separate activities? How can we disable this annoying memory hog? Jus
    turn it off totally

    Thanks for any help. I've seen this problem reported in a variety o
    forums, but the things suggested so far haven't worked for us
     
    Wolffoley, Sep 17, 2009
    #1
    1. Advertisements

  2. Wolffoley

    SC Tom Guest

    A quick Google search turned this up:

    "To modify Indexing Service performance
    Open Computer Management.
    In the console tree, click Indexing Service:Computer Management >Services
    and Applications >Indexing Service

    On the Action menu, click Stop (It may be stopped already).

    On the Action menu, point to All Tasks, and then click Tune Performance.

    In the Indexing Service Usage dialog box, select the option that best fits
    the way Indexing Service is used on your computer.

    If you selected Customize, click the Customize button and proceed to **. If
    you did not select Customize, continue to ***.

    ** . In the Desired Performance dialog box, move the Indexing slider to Lazy
    for less immediate indexing or to Instant for immediate indexing of new and
    changed documents. Lazy indexing uses fewer resources; Instant indexing uses
    as much of the computer's resources as it can.

    Move the Querying slider to Low load if you expect to process only a few
    queries at a time or to High load if you expect to process many queries at a
    time. Low load uses fewer resources; high load uses more.

    ***Close the Desired Performance dialog box.

    Close the Indexing Service Usage dialog box and restart Indexing Service."

    I have the indexing service disabled on my Vista and XP PC's and have
    noticed no discernable reduction in performance.

    SC Tom
     
    SC Tom, Sep 17, 2009
    #2
    1. Advertisements

  3. Wolffoley

    Wolffoley Guest

    Thanks! We will try it this way and see if it works

    It is frustrating--many similar postings on various logs are greete
    with comments about how one shouldn't disable such an important featur
    of Vista, or even deny that it can happen. The fact is that somethin
    goes wrong, and the computer stops working unless it is turned off. Th
    messages for this problem on Vista go back two full years. Surel
    Microsoft should be able to post a patch?
     
    Wolffoley, Sep 18, 2009
    #3
  4. Wolffoley

    Wolffoley Guest

    Searchindexer.exe rose from the dead, and has continued to take control
    of our CPU. I don't know what reanimates it, but after a period of
    non-use, the Searchindexer is always on, and CPU is always running at
    100%. I can turn it off, but why should I have to do this?
     
    Wolffoley, Sep 20, 2009
    #4
  5. Wolffoley

    Wolffoley Guest

    In case it helps...
    In Task Manager=>Services the Indexing Service "CISVC" is listed a
    "Stopped.

    In Control Panel=> Indexing options, it says "Indexing is not running.
    We don't have the ability to turn it on--it's just off, and all button
    greyed out

    In Control Panel=>Administrative tools=>Services=>Windows Search,
    have just set it to "Disabled" as recommended in this website 'Disabl
    and Turn Off Windows Vista Search Indexer and Indexing Service » M
    Digital Life
    (http://www.mydigitallife.info/2007/...ws-vista-search-indexer-and-indexing-service/
    [we did this once before, but it seems to have gone back t
    "Automatic." I have disabled it again.

    I haven't yet turned off the indexing for the C and D drives fro
    Windows Explorer as is also described in the article above, but did tur
    it off for our backup drive
     
    Wolffoley, Sep 20, 2009
    #5
  6. Wolffoley

    SC Tom Guest

    Do you have Windows Search 4.0 installed? If so, go to Control Panel,
    Programs and Features and uninstall it. That may take care of it. I have
    that uninstalled, Windows Search service disabled, and indexing turned off
    on my HDD. For searching for files, etc., I use Agent Ransack (
    http://www.mythicsoft.com/agentransack/Page.aspx?page=home ), and find it to
    be one of the better search engines.

    SC Tom
     
    SC Tom, Sep 20, 2009
    #6
  7. Wolffoley

    blue75 Guest

    I use this program it turns off a lot of things when I want to pla
    games.Now I find I use it even when I'm not gaming because my PC flie
    in gaming mode.
    'Game Booster | Faster Play, Free Download | Free Game Accelerato
    Download' (http://www.iobit.com/gamebooster.html?Str=download
    Also right click start / explore right click on the drive and unchec
    Index this drive for faster searching.I think thats what you're tryin
    to do ;
     
    blue75, Sep 21, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.