Security centre can't turn on windows firewall??

Discussion in 'Windows Vista Security' started by granabulaxx, Oct 8, 2006.

  1. granabulaxx

    granabulaxx Guest

    The message is "Security centre can't turn on windows firewall.<A
    HREF="ErrorActionWindowsFirewallCo...
    on windows firewall manually</A>

    Any ideas?????
     
    granabulaxx, Oct 8, 2006
    #1
    1. Advertisements

  2. Try a repair installation of Vista

    regards
    Robert
     
    Robert R. Johnson Jr, Oct 8, 2006
    #2
    1. Advertisements

  3. granabulaxx

    granabulaxx Guest

    Nope....upgraded to 5744 and it has added two different screens but still at
    the end tries to start the service but fails...
     
    granabulaxx, Oct 9, 2006
    #3
  4. granabulaxx

    Tim Starid Guest

    Try bypassing the security center by going to control panel: System and
    Maintenance: Administrative Tools: Services:

    verify the following services are running (If not start in this order):
    (All of these should be set to automatic startup)

    RPC
    DCOM Service Process Launcher
    Windows Firewall
     
    Tim Starid, Oct 9, 2006
    #4
  5. granabulaxx

    granabulaxx Guest

    Ok, so turning them on in order after trying to turn on windows firewall
    service now gives me error code 13???
     
    granabulaxx, Oct 9, 2006
    #5
  6. granabulaxx

    onerats Guest

    I'm having the same problem here (security center can't start the
    firewall, trying to start from the services control panel gets error
    #13). Looking at the event viewer, I see:

    The Windows Firewall Service was unable to retrieve the security policy
    from the local storage. The service will continue enforcing the current
    policy. Error Code: 2147942413

    And:

    The Windows Firewall Service was unable to parse the new security
    policy. The service will continue with currently enforced policy.
    Error Code: 2147942413

    I've gone into the group policy object editor and fiddled with the
    firewall policy settings, but to no avail -- I just can't get the
    firewall to start. Suggestions?
     
    onerats, Oct 10, 2006
    #6
  7. granabulaxx

    Theano Guest

    Running RTM build. I had RC1 previously and firewall was on. After upgrading
    to RTM firewall is off and can't be turned on, citing Group Policy.

    I followed the advice below re: the Services Control Panel, the other two
    are started, but Firewall isn't even listed on either tab.

    Someone asked me is OneCare installed. No. I had it under XP but had to
    uninstall it with Vista beta 2.

    Why has Windows turned off my firewall and why can't I turn it back on?
     
    Theano, Nov 12, 2006
    #7
  8. granabulaxx

    Theano Guest

    Followup in case this helps anybody. First of all Windows Firewall was
    present in services after all (under W) and showed as already started, but I
    kept getting the security warning it was not on. It turned out that I had to
    use the Windows Firewall with Advanced Security in MMC to turn on the
    firewall. Running Ultimate, build 6000. Worked like a charm after that but
    still cannot use Firewall control panel to control it, must use the advanced
    MMC version with "Group Policy," nuts cuz I'm not on a domain. Thanks a lot.

    Theano
     
    Theano, Nov 20, 2006
    #8
  9. granabulaxx

    T. Ashley Guest

    I am on a domain and I am geting this error, anybody find any workaround?
     
    T. Ashley, Nov 22, 2006
    #9
  10. granabulaxx

    granabulaxx Guest

    Events viewer states:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
    <Provider Name="Service Control Manager"
    Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service
    Control Manager" />
    <EventID Qualifiers="49152">7024</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2006-11-23T14:47:28.000Z" />
    <EventRecordID>17995</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>Peter-PC</Computer>
    <Security />
    </System>
    - <EventData>
    <Data Name="param1">Windows Firewall</Data>
    <Data Name="param2">13 (0xD)</Data>
    </EventData>
    </Event>

    HELP!
     
    granabulaxx, Nov 23, 2006
    #10
  11. granabulaxx

    muarrif Guest

    I am having the exact same problem. At first I thought it was AVG
    Internet Security Firewall causing the issue but perhaps not. However I
    have sent the logs to the guys at AVG.

    WHEN I TRY TO START FIREWALL MANUALLY IT GIVES ME THE FOLLOWING ERROR:
    Windows could not start he Windows Firewall service on Local Computer.
    Error 1068: The dependancy service or group failed to start.

    Firewall part of the AVG Internet Security Suite also does not work and
    shows in red possibly because it relies on the same module.


    +-------------------------------------------------------------------+
    |Filename: Security Essentials.jpg |
    |Download: http://forums.techarena.in/attachment.php?attachmentid=6324|
    +-------------------------------------------------------------------+
     
    muarrif, Jul 5, 2007
    #11
  12. granabulaxx

    Spirit Guest

    START - type WF.msc in the search box
     
    Spirit, Jul 5, 2007
    #12
  13. granabulaxx

    muarrif Guest

    searching for *WF.msc* in windows doesn't return any results.

    Why am I searching for this
     
    muarrif, Jul 6, 2007
    #13
  14. granabulaxx

    Spirit Guest

    Spirit, Jul 6, 2007
    #14
  15. granabulaxx

    muarrif Guest

    muarrif, Jul 6, 2007
    #15
  16. granabulaxx

    Spirit Guest

    WF.msc IS the Windows Firewall read the links I posted
     
    Spirit, Jul 6, 2007
    #16
  17. granabulaxx

    anandk Guest

    ensure that the following services are set to automatic and started :

    Application Layer gateway Service
    Network Connections
    Network Location Awareness
    Telephony
    Remote Access Connection Manager
    Plug and Play

    also see if something here helps u
    http://windowsxp.mvps.org/sharedaccess.htm
     
    anandk, Jul 9, 2007
    #17
  18. granabulaxx

    muarrif Guest

    All of the above are running and on automatic.
    Still the same proble
     
    muarrif, Jul 9, 2007
    #18
  19. granabulaxx

    dean-dean Guest

    You could try this:

    Right-click Command Prompt and Run as Administrator. Type the following
    command:

    winmgmt /verifyrepository

    If the system returns "WMI repository is not consistent", run this command:

    winmgmt /salvagerepository

    The first time you run this it will fail. It will issue stop commands to
    the services causing it to fail. It might take a couple minutes for the
    services to shut down. Run the command again. You actually may have to run
    it 3 times before it finally runs and completes on its own.

    Reboot your system.
     
    dean-dean, Jul 9, 2007
    #19
  20. granabulaxx

    muarrif Guest

    WMI Repository is consistent

    I AM GOING MAD nothing seems to work. The guys at AVG are being really
    patient with me and very helpful too but still no luck with firewall.
    Windows firewall on its own do not work.


    +-------------------------------------------------------------------+
    |Filename: WMI Repository is consistant.jpg |
    |Download: http://forums.techarena.in/attachment.php?attachmentid=6329|
    +-------------------------------------------------------------------+
     
    muarrif, Jul 11, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.