Security component upgrade (greyed out)

Discussion in 'Windows Media Player' started by JustinCredible, May 15, 2010.

  1. I recently purchased a DVD that provided me with a digital copy. When I tried
    activating the digital copy it told me to first upgrade the security
    components of windows media player. It provided me with a link to click on,
    when I clicked on the link the it told me to click on the upgrade box to
    begin downloading. However the upgrade box was greyed out, so I couldn't
    download it.

    I've spent over an hour now looking for another link and I cannot find one
    for my version of Media Player. I believe I am running Media Player 12
    because I am running Windows 7 and I believe Media Player 12 is the standard
    player installed after activating the OS. Where do I go from here? Why is the
    link greyed out?

    My ActiveX is installed and running, and there are no promptings on the
    screen other than "error" on the bottom left corner, which appears after the
    page is finished loading. Well of course there's an error the boxed is
    greyed out, but is it an error on my part or a website error, maybe somone
    just didn't finish their job and forgot to upload the hyperlink for the
    download. What do I do and where do I go from here?
     
    JustinCredible, May 15, 2010
    #1
    1. Advertisements

  2. DRM is the workof the Devil and should be
    avoided by users as much as possible.
     
    Dave and Rosanna, May 24, 2010
    #2
    1. Advertisements

  3. Yes it's terrible. When I heard that Amazon had the power to remotely
    remove
    access to books on the Kindle reader that users had already bought, right
    there -
    for me, that was to much. I would never, ever by such an item just based on
    that.

    Microsoft has tried to push an environment where DRM is the "norm", and it's
    a kind of brainwashing. A whole way of thinking, that frankly, is unholy.

    I hope it dies a well deserved death.


     
    Dave and Rosanna, May 25, 2010
    #3
  4. Hi Neil-
    I used to buy many CD's myself, used and new.
    It was a fun thing to do, browsing through the racks.
    Don't do it anywhere near as much these days.
    Shame in a way, end of an era. Look what happened to
    Tower Records and others.

    Do you know anything about the "proteced path" in Vista ?
    Why does it play non-protected files in this thread?
    Doesn't affect me, because I don't play the files on any
    non-HDPC devices - just something I noticed while looking
    in task manager.

     
    Dave and Rosanna, May 27, 2010
    #4
  5. JustinCredible

    Robyn Guest

    I'm with sending the Digital copy because I thought I was crazy having this
    issue! I have followed all the steps and the button is still greyed out
    though - HELP! PLEASE!
     
    Robyn, Jun 11, 2010
    #5
  6. JustinCredible

    Tim De Baets Guest

    What version of WMP and Windows? Did you reset the DRM cache, as
    explained at http://support.microsoft.com/kb/891664 ?

    Are you using Internet Explorer to surf to the website? Are all other
    web browsers and WMP closed?

    Regards
     
    Tim De Baets, Jun 11, 2010
    #6
  7. JustinCredible

    Robyn Guest

    WIndows Vista (YUCK) YEs reset - emptied folder - I did not delete the folder
    since it told me to empty the contents. WMP - version 11

    Yes Internet explorer and all other windows closed. ALso restarted IE and
    Computer.
    PLEASE HELP - this has taken hours!!!
     
    Robyn, Jun 12, 2010
    #7
  8. JustinCredible

    Robyn Guest

    ALso the Warner Bros site - said you had to uncheck the "enable protected
    mode" box under internet options - tried that too - to no avail:-(
     
    Robyn, Jun 12, 2010
    #8
  9. JustinCredible

    Moto2121 Guest

    From the Disney Site - To resolve this issue, click Tools and select Internet
    Options. In the window that appears, select the Security tab. Then uncheck
    the "Enable protected mode (requires restarting Internet Explorer)" option
    and click OK, and close the browser. Click here to return to the security
    upgrade page. After completing the upgrade, please restart your computer and
    run the Digital Copy installation again.

    This worked for me.
     
    Moto2121, Jun 19, 2010
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.